В кафе продается мороженое по 3 или по 5 шариков в порции?

Информатика | 5 - 9 классы

В кафе продается мороженое по 3 или по 5 шариков в порции.

Определить, можно ли купить K шариков мороженного.

Входные данные : Во входном потоке в первой строке задано натуральное число К (K < ; = 1000) Выходные данные : Вывести YES или NO.

Пример входного файла (input.

Txt) : 2.

Ответить на вопрос
Ответы (1)
Irenairena1 8 сент. 2020 г., 10:12:29

1. Решение для сомневающихся и привыкших писать программы безмозгло "в лоб"

var k, p, q : integer ; flag : boolean ; f : Text

begin Assign(f, 'input.

Txt') ; Reset(f) ; read(f, k) ; Close(f) ; case k of 1, 2, 4, 7 : writeln('NO') ; 3, 5 : writeln('YES') ; else q : = k mod 5 ; if (q = 0) or (k = 3) then writeln('YES') else begin q : = (k div 5) ; flag : = false ; while (not flag) and (q > ; 0) do begin p : = k - 5 * q ; if p mod 3 = 0 then begin writeln('YES') ; flag : = true end ; q : = q - 1 end ; if (not flag) then writeln('NO') end end

end.

2. Решение в соответствии с алгоритмом, приведенным в комментарии к вопросу.

Const Kno = [1, 2, 4, 7] ;

var k : integer ; f : Text

begin Assign(f, 'input.

Txt') ; Reset(f) ; read(f, k) ; Close(f) ; if k in Kno then writeln('NO') else writeln('YES')

end.

Anastasia19jeni 1 нояб. 2020 г., 06:21:23 | 10 - 11 классы

Даны два целых числа?

Даны два целых числа.

Определить, какое из них больше или определить их равенство.

Вывести знак '> ; ' если первое число больше, знак '< ; ' если второе число больше, знак ' = ' если числа равны.

Входные данные : Выходные данные : Во входном потоке в первой строке через пробел заданы целые числа A и B ( - 30000 < ; A, B < ; 30000).

В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : 5 7 Пример выходного файла (output.

Txt) : < ;

Larisapolukhin1 25 февр. 2020 г., 23:19:20 | 5 - 9 классы

Вывести все значения элементов заданной числовой последовательности?

Вывести все значения элементов заданной числовой последовательности.

Входные данные : Выходные данные : Во входном потоке в первой строке записано единственное целое число N (0 < ; N < ; = 100) - число элементов числовой последовательности ; Во второй строке перечислены значения элементов целочисленной последовательности (через пробел).

Значения элементов по модулю не превышают 1000.

В выходной поток вывести значения элементов числовой последовательности в столбик, каждое с новой строки.

Пример входного файла (input.

Txt) : 10 43 564 32 76 342 76 43 342 876 42 Пример выходного файла (output.

Txt) : 43 564 32 76 342 76 43 342 876 42 ПОМОГИТЕ ПОЖАЛУЙСТААА!

Ghfgdfg 16 сент. 2020 г., 11:45:38 | 1 - 4 классы

Дано натуральное трехзначное число N ?

Дано натуральное трехзначное число N .

Определить сумму и произведение его цифр.

Имя входного файла Input.

Txt, имя выходного файла output.

Txt.

Ilmatrastamp 24 апр. 2020 г., 12:12:22 | 5 - 9 классы

Дана строка, состоящая из заглавных английских букв и цифр?

Дана строка, состоящая из заглавных английских букв и цифр.

Вывести первый символ строки.

Входные данные : В единственной строке входного потока дана строка символов, длина которой не превышает 255.

Выходные данные : В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : KDSFJHGLKDJGHLSUIRH5HGUHG58H.

Пример выходного файла (output.

Txt) : K.

Barselona93 28 окт. 2020 г., 13:35:53 | 5 - 9 классы

Ограничения [Время : 1000ms, Память : 128MB, Сложность : 2%] Задана продолжительность некоторого события в секундах целым числом?

Ограничения [Время : 1000ms, Память : 128MB, Сложность : 2%] Задана продолжительность некоторого события в секундах целым числом.

Считая, что в одном часе 60 минут, а в минуте 60 секунд, определить продолжительность события в часах, минутах и секундах.

Входные данные : Во входном потоке задано единственное натуральное число T (T < ; 10000000) Выходные данные : Вывести три натуральных числа через пробел : часов, минут, секунд Пример входного файла (input.

Txt) : 3666.

Komogorova07 5 июн. 2020 г., 07:16:59 | 10 - 11 классы

Заданы два натуральных числа N и K?

Заданы два натуральных числа N и K.

Вычислить остаток от деления первого числа на второе.

Входные данные : Входной поток содержит два целых числа N и K (1 < ; = N < ; = 10 ^ 100, 1 < ; = K < ; = 10 ^ 9) записанные в двух отдельных строках.

Выходные данные : В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.

Txt) : 239 16 Пример выходного файла (output.

Txt) : 15.

Adamgulova2002 28 сент. 2020 г., 16:42:34 | 10 - 11 классы

Заданы два натуральных числа N и K?

Заданы два натуральных числа N и K.

Вычислить остаток от деления первого числа на второе.

Входные данные : Входной поток содержит два целых числа N и K (1 < ; = N < ; = 10 ^ 100, 1 < ; = K < ; = 10 ^ 9) записанные в двух отдельных строках.

Выходные данные : В выходной поток выведите остаток от деления N на K.

Пример входного файла (input.

Txt) : 239 16 Пример выходного файла (output.

Txt) : 15.

Варя81 7 окт. 2020 г., 00:35:35 | 5 - 9 классы

Напишите программу, которая заменяет расширение у заданного имени файла?

Напишите программу, которая заменяет расширение у заданного имени файла.

Входные данные Первая строка содержит имя файла, которое нужно изменить.

Во второй строке записано нужное расширение.

Выходные данные Программа должна вывести изменённое имя файла с заданным расширением.

Примеры входные данные qwerty exe выходные данные qwerty.

Exe входные данные qwetry.

Old. pas html выходные данные qwetry.

Old. html.

Balashovamarin 2 июл. 2020 г., 18:04:30 | 5 - 9 классы

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное?

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное.

Входные данные : Входная строка содержит единственное натуральное число.

Выходные данные : Если введённое число – трёхзначное, нужно вывести ответ YES, если нет, то вывести ответ NO.

Serjana 9 окт. 2020 г., 05:42:28 | 10 - 11 классы

Уровень B?

Уровень B.

Задача M.

Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 5221 выходные данные YES входные данные 1232 выходные данные NO

Уровень C.

Задача O.

Две одинаковые цифры Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом (как, например, 212).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 212 выходные данные YES входные данные 12345 выходные данные NO.

На этой странице сайта размещен вопрос В кафе продается мороженое по 3 или по 5 шариков в порции? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.