Дано целое число N и набор из N чисел?

Информатика | 5 - 9 классы

Дано целое число N и набор из N чисел.

Найдите номер первого наибольшего и номер последнего наименьшего числа в наборе.

Ввод Целое число N и набор из N чисел в одной строке.

Вывод Номер первого наибольшего и номер последнего наименьшего числа в наборе.

Ввод 10 4 3 1 7 9 1 9 2 5 6 Вывод 5 6 Пожалуйста очень срочно.

Ответить на вопрос
Ответы (1)
Guksones 25 февр. 2020 г., 15:29:18

Program bistro ;

var i, mi, ma, a1, a2, a, n : integer ;

begin

read(n) ;

mi : = 1 ;

ma : = 1 ;

read(a) ; a1 : = a ;

a2 : = a ;

for i : = 2 to n do begin read(a) ; if a > ; a1 then begin ma : = i ; a1 : = a ; end ; if a < ; = a2 then begin mi : = i ; a2 : = a ; end ; end ;

writeln(ma, ' ', mi) ;

end.

Marsikjane 21 янв. 2020 г., 13:29:52 | 5 - 9 классы

Pascal, задания на min max Дано целое число N и набор из N целых чисел?

Pascal, задания на min max Дано целое число N и набор из N целых чисел.

Найти количество элементов, расположенных после последнего максимального элемента.

RomkaNorin 12 янв. 2020 г., 18:29:51 | 5 - 9 классы

Пожалуйста решите на языке C + + : Series8?

Пожалуйста решите на языке C + + : Series8.

Дано целое число N и набор из N целых чисел.

Вывести в том же порядке все четные числа из данного набора и количество K таких чисел.

Aselyaabylhano 19 апр. 2020 г., 13:19:05 | 10 - 11 классы

Помогите пожалуйста решить эту задачу в паскале, просто для новичка и с объяснениями, почему выполнено то или иное действие?

Помогите пожалуйста решить эту задачу в паскале, просто для новичка и с объяснениями, почему выполнено то или иное действие.

Очень срочно надо.

Дано целое к и набор из ненулевых чисел, признак его завершения - число 0.

Вывести количество чисел в наборе, меньших к.

EmmaMiller 6 авг. 2020 г., 21:40:23 | 5 - 9 классы

Решите пожалуйста Абрамян М Э 1000 задачь на С + + Series22 Дано целое число N(больше 0) и набор на N вещественных чисел Если данный набор образует убываюшию последовательность то вывести 0 ; в против?

Решите пожалуйста Абрамян М Э 1000 задачь на С + + Series22 Дано целое число N(больше 0) и набор на N вещественных чисел Если данный набор образует убываюшию последовательность то вывести 0 ; в противном случае вывести номер первого числа нарушаюшую закономерность.

Polinazilova 10 июл. 2020 г., 18:57:29 | 10 - 11 классы

Дано целое число?

Дано целое число.

Найти наименьшее четное из набора.

То есть если число 123, то ответом будет 1.

Язык паскаль.

Дашуляяяяяяяяяя 1 июн. 2020 г., 18:30:20 | 5 - 9 классы

Напишите задачи в Паскале задача1 {вводится целое число n от [0?

Напишите задачи в Паскале задача1 {вводится целое число n от [0.

200].

Затеи вводится n целых чисел от [0.

1000000] Вывести на экран их произведение.

} задача2 {вводится целое число n от [0.

200].

Затеи вводится n целых чисел от [0.

1000000] вывести на экран наибольшее из них} задача 3 {вводится целое число n от [0.

200].

Затеи вводится n целых чисел от [0.

1000000] Вывести на экран номер наименьшего из них.

}.

Olegro123 27 дек. 2020 г., 18:16:16 | 5 - 9 классы

С клавиатуры вводится целое число N?

С клавиатуры вводится целое число N.

Затем вводится N целых чисел.

Перед вводом каждого из чисел должно появляться сообщение вида "Введите i - е число", где i - номер очередного числа.

Найдите среднее арифметическое вводимых чисел.

Kalerija 31 мая 2020 г., 10:44:10 | 1 - 4 классы

Дано целое число?

Дано целое число.

Напишите программу, которая выводит на экран последнюю букву данного числа, потом вводит её в квадрат и выводит на экран монитора результат.

Мэридиана 26 мая 2020 г., 05:33:09 | 5 - 9 классы

Составьте программу для ввода с клавиатуры в массив 7 целых чисел и вывода последних 2 - х чисел в обратном порядке в первую строку, а во вторую строку – первые пять чисел в обычном порядке?

Составьте программу для ввода с клавиатуры в массив 7 целых чисел и вывода последних 2 - х чисел в обратном порядке в первую строку, а во вторую строку – первые пять чисел в обычном порядке.

Lidiya85 25 сент. 2020 г., 04:08:36 | 5 - 9 классы

Составьте программу для ввода с клавиатуры в массив 10 целых чисел и вывода первых 5 - и чисел в обратном порядке в первую строку, во вторую строку – последние четыре числа в обычном порядке, а в трет?

Составьте программу для ввода с клавиатуры в массив 10 целых чисел и вывода первых 5 - и чисел в обратном порядке в первую строку, во вторую строку – последние четыре числа в обычном порядке, а в третьей строке – первый и девятый элементы массива (.

Вопрос Дано целое число N и набор из N чисел?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.