В двумерном массиве 7Х7 произвольных целых чисел вычислить сумму элементов, расположенных слева от побочной диагонали?

Информатика | 10 - 11 классы

В двумерном массиве 7Х7 произвольных целых чисел вычислить сумму элементов, расположенных слева от побочной диагонали.

Определить минимальный элемент главной диагонали (значение и координаты).

Ответить на вопрос
Ответы (1)
ЗайкаАнька 14 окт. 2020 г., 08:12:01

Const n = 7 ;

var a : array[1.

N, 1.

N] of integer ; i, j, sum, min, imin : integer ;

begin Randomize ; for i : = 1 to n do for j : = 1 to n do a[i, j] : = random(100) - 50 ; writeln('Исходный массив') ; for i : = 1 to n do begin for j : = 1 to n do write(a[i, j] : 4) ; writeln end ; sum : = 0 ; min : = 100 ; / / у нас в массиве числа на ( - 50 : 50) for i : = 1 to n - 1 do for j : = 1 to n - i do sum : = sum + a[i, j] ; for i : = 1 to n do if min > ; a[i, i] then begin min : = a[i, i] ; imin : = i end ; writeln('Сумма элементов левее побочной диагонали = ', sum) ; writeln('Минимальный элемент на главной диагонали = ', min, ', его координаты (', imin, ', ', imin, ')')

end.

Контрольный пример :

Исходный массив 14 39 - 7 - 26 10 - 33 9 48 - 21 - 19 6 2 24 - 16 27 - 41 - 26 - 7 16 - 27 - 34 42 32 - 12 - 37 - 9 20 - 26 - 35 - 20 - 34 40 - 3 5 1 23 31 - 11 - 9 26 - 28 25 34 26 - 30 11 43 19 - 26

Сумма элементов левее побочной диагонали = - 4

Минимальный элемент на главной диагонали = - 37, его координаты (4, 4).

Marmaduke 16 нояб. 2020 г., 23:38:13 | 10 - 11 классы

HELP?

HELP!

Заменить значения всех элементов главной диагонали массива на нулевые.

Kateprincess 17 февр. 2020 г., 13:34:20 | 5 - 9 классы

1. Нахождение наибольшего элемента главной диагонали?

1. Нахождение наибольшего элемента главной диагонали.

(Паскаль, двумерные массивы ) 2.

Нахождение наименьших элементов в столбцах массива.

(Паскаль, двумерные массивы ).

Yyyyulya 7 нояб. 2020 г., 18:44:21 | 10 - 11 классы

Дана матрица К(3, 3), найти минимальный элемент массива в строке с индексом 3 и заменить этим значением все элементы главной диагонали?

Дана матрица К(3, 3), найти минимальный элемент массива в строке с индексом 3 и заменить этим значением все элементы главной диагонали.

Batov64 25 мая 2020 г., 02:56:43 | 10 - 11 классы

Заменить элементы побочной диагонали минимальными значениями строк?

Заменить элементы побочной диагонали минимальными значениями строк.

Помогите еще раз!

Ako1999kz 1 дек. 2020 г., 20:27:17 | 10 - 11 классы

1) Двумерные массивыДана квадратная матрица (5 * 5)?

1) Двумерные массивы

Дана квадратная матрица (5 * 5).

Заполнить ее случайными целыми числами и вывести на экран в виде таблицы.

Заменить все элементы матрицы, расположенные выше главной диагонали на 1, ниже главной диагонали - 0.

Главную диагональ оставить без изменения.

Вывести на экран полученную матрицу.

2) Дан двумерный массив целых чисел(4 * 5).

Заполнить его случайными числами и вывести на экран в виде таблицы.

Найти минимальный элемент массива и количество элементов, равных минимальному.

3) Дана квадратная матрица (4 * 4).

Заполнить ее случайными целыми числами и вывести на экран в виде таблицы.

Найти произведение всех ненулевых элементов главной и побочной диагоналей.

AnnaR2011 17 мар. 2020 г., 20:00:07 | 10 - 11 классы

Вычислить среднее арифметическое отрицательных элементов выше главной и ниже побочной диагонали?

Вычислить среднее арифметическое отрицательных элементов выше главной и ниже побочной диагонали.

Ldinka73 2 нояб. 2020 г., 21:12:06 | 10 - 11 классы

Задан двумерный массив Y из 4 - х строк и 4 - х столбцов?

Задан двумерный массив Y из 4 - х строк и 4 - х столбцов.

Составить программу, которая вычисляет S – сумму элементов побочной диагонали и значение суммы всех элементов массива

На с + + подробне пожалуйста эту задачу я не понял что то.

SKBORTSOVA 15 февр. 2020 г., 19:03:32 | 10 - 11 классы

СРОЧНО?

СРОЧНО!

ПАСКАЛЬ!

30 БАЛЛОВ В двумерном массиве 4х4 определить количество чётных отрицательных элементов на главной диагонали матрицы.

Про100Черешенка 21 февр. 2020 г., 20:17:00 | 10 - 11 классы

Информатика?

Информатика.

Массивы.

PascalABC.

1. В двумерном массиве 4х5 вычислить сумму элементов кратных 3, значения которых больше 20.

2. Найти среднее арифметическое элементов главной диагонали квадратной матрицы 5х5.

Crazy8606 1 янв. 2020 г., 20:16:07 | 10 - 11 классы

ПАСКАЛЬ?

ПАСКАЛЬ!

ПОЖАЛУЙСТА В двумерном массиве 4х4 определить количество чётных отрицательных элементов на главной диагонали матрицы.

Вы находитесь на странице вопроса В двумерном массиве 7Х7 произвольных целых чисел вычислить сумму элементов, расположенных слева от побочной диагонали? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.