1. Нахождение наибольшего элемента главной диагонали?

Информатика | 5 - 9 классы

1. Нахождение наибольшего элемента главной диагонали.

(Паскаль, двумерные массивы ) 2.

Нахождение наименьших элементов в столбцах массива.

(Паскаль, двумерные массивы ).

Ответить на вопрос
Ответы (1)
Oskurtu1 17 февр. 2020 г., 13:34:25

Всё, что находится между комментариями {1 + }.

{1 - } относится к первой программе, {2 + }.

{2 - } — ко второй.

Const n = 5 ;

type matrix = array[1.

N, 1.

N] of integer ; {2 + } row = array[1.

N] of integer ; {2 - }

{1 + }

function maxElemOfMainDiag(m : matrix) : integer ;

var i, max : integer ;

begin max : = m[1, 1] ; for i : = 2 to n do if m[i, i] > ; max then max : = m[i, i] ; maxElemOfMainDiag : = max ;

end ;

{1 - }

{2 + }

function minElemOfColumns(m : matrix) : row ;

var i, j : integer ; r : row ;

begin for i : = 1 to n do begin r[i] : = m[1, i] ; for j : = 2 to n do if m[j, i] < ; r[i] then r[i] : = m[j, i] ; end ; minElemOfColumns : = r ;

end ;

{2 - }

var m : matrix ; {2 + } r : row ; {2 - } i, j : integer ;

begin writeln('Исходный массив : ') ; randomize ; for i : = 1 to n do begin for j : = 1 to n do begin m[i, j] : = random(100) + 1 ; write(m[i, j] : 4) ; end ; writeln ; end ; {1 + } writeln('Максимальный элемент главной диагонали равен ', maxElemOfMainDiag(m)) ; {1 - } {2 + } r : = minElemOfColumns(m) ; writeln('Минимальные элементы столбцов : ') ; for i : = 1 to n do write(r[i] : 4) ; writeln ; {2 - }

end.

Пример вывода :

Исходный массив : 22 13 80 77 14 50 86 49 22 7 88 68 48 27 79

100 3 11 43 94 85 30 53 34 9

Максимальный элемент главной диагонали равен 86

Минимальные элементы столбцов : 22 3 11 22 7.

BadiWorld1 3 февр. 2020 г., 16:37:10 | 10 - 11 классы

Найти наименьший элемент в двумерном массива?

Найти наименьший элемент в двумерном массива?

ДаняняТ 27 февр. 2020 г., 22:22:13 | 10 - 11 классы

Двумерные массивыВ двумерном массиве М[1?

Двумерные массивы

В двумерном массиве М[1.

6, 1.

4] определить индексы наименьшего элемента в каждой строчке.

Marsovin 7 февр. 2020 г., 08:25:25 | 10 - 11 классы

Паскаль, составьте программу для двумерного массива : Найти произведение отрицательных элементов указанной строки двумерного массива размером 4 * 5 целых чисел?

Паскаль, составьте программу для двумерного массива : Найти произведение отрицательных элементов указанной строки двумерного массива размером 4 * 5 целых чисел.

SKBORTSOVA 15 февр. 2020 г., 19:03:32 | 10 - 11 классы

СРОЧНО?

СРОЧНО!

ПАСКАЛЬ!

30 БАЛЛОВ В двумерном массиве 4х4 определить количество чётных отрицательных элементов на главной диагонали матрицы.

Elviraartisheva 5 июн. 2020 г., 06:39:40 | 1 - 4 классы

Дано два одномерных массива A и B?

Дано два одномерных массива A и B.

Заменить местами максимальные элементы массивов A и B.

Использовать процедуру нахождения максимального элемента массива.

Преобразовать эту программу для двумерного массива.

Crazy8606 1 янв. 2020 г., 20:16:07 | 10 - 11 классы

ПАСКАЛЬ?

ПАСКАЛЬ!

ПОЖАЛУЙСТА В двумерном массиве 4х4 определить количество чётных отрицательных элементов на главной диагонали матрицы.

Катерина706 18 янв. 2020 г., 03:57:13 | 5 - 9 классы

Найдите сумму всех элементов двумерного массива и сумму элементов каждой строки?

Найдите сумму всех элементов двумерного массива и сумму элементов каждой строки.

(паскаль).

Linochk552 1 окт. 2020 г., 20:41:06 | 5 - 9 классы

Найти наибольшее значение элементов двумерного массива паскаль?

Найти наибольшее значение элементов двумерного массива паскаль.

Викакарттер 13 сент. 2020 г., 05:08:58 | 10 - 11 классы

Помогите решить ?

Помогите решить .

Составьте программу формирования и вывода на экран одномерного массива , состоящего из элементов главной диагонали двумерного массива , заданного с помощью датчика случайных чисел.

(Паскаль абс) С объяснением .

Диана067 19 сент. 2020 г., 14:26:41 | 5 - 9 классы

Два двумерных массива?

Два двумерных массива.

Написать и вывести.

Паскаль.

Вы открыли страницу вопроса 1. Нахождение наибольшего элемента главной диагонали?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.