Дана матрица К(3, 3), найти минимальный элемент массива в строке с индексом 3 и заменить этим значением все элементы главной диагонали?

Информатика | 10 - 11 классы

Дана матрица К(3, 3), найти минимальный элемент массива в строке с индексом 3 и заменить этим значением все элементы главной диагонали.

Ответить на вопрос
Ответы (1)
Amina20061 7 нояб. 2020 г., 18:44:22

Var a : array [1.

3, 1.

3] of integer ; min, i, j : integer ;

begin randomize ; for i : = 1 to 3 do begin for j : = 1 to 3 do begin a[i, j] : = random(9) + 1 ; write (a[i, j] : 4) ; end ; writeln ; end ; min : = a[3, 1] ; for i : = 2 to 3 do if a[3, i]< ; min then min : = a[3, i] ; writeln ('Min : ', min) ; for i : = 1 to 3 do begin for j : = 1 to 3 do begin if (i = j) then a[i, j] : = min ; write (a[i, j] : 4) ; end ; writeln ; end ; readln ;

end.

Marmaduke 16 нояб. 2020 г., 23:38:13 | 10 - 11 классы

HELP?

HELP!

Заменить значения всех элементов главной диагонали массива на нулевые.

Kiryashonok1 1 июл. 2020 г., 00:45:12 | 10 - 11 классы

Дана целочисленная квадратная матрица?

Дана целочисленная квадратная матрица.

Найти число строк, сумма элементов которых равна сумме элементов главной диагонали данной матрицы.

Нужна на языке си.

АНДРИЕВСКИЙ 27 июл. 2020 г., 08:57:22 | 1 - 4 классы

Дана матрица Z(3?

Дана матрица Z(3.

3) заменить все на нули все её элементы, расположенные на главной диагонали.

Преобразованную и исходную матрицу вывести по строкам.

Kuryaevruslan2014 18 авг. 2020 г., 21:46:41 | 5 - 9 классы

Написать программу на ассемблере?

Написать программу на ассемблере.

В массиве из восьми элементов найти минимальный элемент и его индекс.

Batov64 25 мая 2020 г., 02:56:43 | 10 - 11 классы

Заменить элементы побочной диагонали минимальными значениями строк?

Заменить элементы побочной диагонали минимальными значениями строк.

Помогите еще раз!

Коля2004 21 мар. 2020 г., 13:08:48 | 1 - 4 классы

Дана матрица А(3, 3)?

Дана матрица А(3, 3).

В строках с отрицательным элементом на главной диагонали найти суммы всех элементов.

Вывести номера строк, суммы, а так же матрицу А по строкам.

Паскаль.

NikitaPetrovBest 30 дек. 2020 г., 11:27:53 | 10 - 11 классы

В квадратной матрице найти сумму минимального и максимального элементов главной диагонали?

В квадратной матрице найти сумму минимального и максимального элементов главной диагонали.

YSHAKURSKAYA1 26 июл. 2020 г., 20:17:46 | 5 - 9 классы

Найти минимальный элемент массива и его индекса (в паскале)?

Найти минимальный элемент массива и его индекса (в паскале).

XXpp 26 апр. 2020 г., 09:04:53 | 10 - 11 классы

В матрице С(5, 6) найти значение и индексы минимального элемента матрицы и количество положительных элементов?

В матрице С(5, 6) найти значение и индексы минимального элемента матрицы и количество положительных элементов.

Соня611 30 сент. 2020 г., 23:21:13 | 10 - 11 классы

Дана матрица А размером 5x5 , все элементы которой различны ?

Дана матрица А размером 5x5 , все элементы которой различны .

Получить последовательность элементов главной диагонали a11, a22, .

, a55 и указать на максимальное и минимальное значение .

Все первоначальные элементы массива вводятся с клавиатуры.

ПАСКАЛЬ.

На этой странице сайта размещен вопрос Дана матрица К(3, 3), найти минимальный элемент массива в строке с индексом 3 и заменить этим значением все элементы главной диагонали? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.