Вычислить среднее арифметическое отрицательных элементов выше главной и ниже побочной диагонали?

Информатика | 10 - 11 классы

Вычислить среднее арифметическое отрицательных элементов выше главной и ниже побочной диагонали.

Ответить на вопрос
Ответы (1)
Metthew22 17 мар. 2020 г., 20:00:12

Var i, j, n, x, kol, xx : int64 ;

begin

read(n) ;

for i : = 1 to n do begin for j : = 1 to n do begin read(x) ; if (i + j> ; n + 1)and(i< ; j)and(x< ; 0) then begin inc(kol) ; inc(xx, x) ; end ; end ; end ;

writeln(xx / kol) ;

end.

Snezhana250603 28 нояб. 2020 г., 02:59:38 | 5 - 9 классы

23. Дана действительная квадратная матрица порядка n?

23. Дана действительная квадратная матрица порядка n.

Выяснить, верно ли, что наибольшее из значений элементов главной диагонали больше, чем наименьшее из значений элементов побочной диагонали.

Nastasyamorar 4 авг. 2020 г., 21:22:39 | 5 - 9 классы

1)Найти треть произведения элементов кратных три массива А (4, 7) водимого из блока данных2)Матрица А (К, К) формируется датчиком случайных чисел из интервала (10, 45)?

1)Найти треть произведения элементов кратных три массива А (4, 7) водимого из блока данных

2)Матрица А (К, К) формируется датчиком случайных чисел из интервала (10, 45).

Найти пятую часть произведение элементов последней строки матрицы кратных 5 и сумму положительных элементов главной диагонали.

Определить разность полученных элементов

3)Матрица А (9, 9) формируется датчиком случайных чисел из интервала (12, 55).

Найти среднее арифметическое значение нечетных по значению элементов последнего столбца матрицы и сумму элементов больших 25 главной диагонали матрицы

4)Длина матрицы А (5, 5) элементы которые формируются датчиком случайных чисел из интервала( - 20, 70) Найти среднее арифметическое значение нечетных по сравнению элементов побочной диагонали.

5)Длина матрицы А (5, 5) элементы которые формируются датчиком случайных чисел из интервала( - 40 - 10) Найти среднее арифметическое значение нечетных по сравнению элементов главной диагонали.

6)Длина матрицы С (К, К) найти половину сумы элементов побочной диагонали , больших 5 7)Длина матрицы С (5, 5)найти среднее арифметическое значение элементов диагоналей матрицы С 8)Длина матрицы С (7, 7)найти среднее арифметическое значение элементов побочной диагонали и половину суммы элементов главной диагонали матрицей С.

Angelinaaleksan 7 мая 2020 г., 22:38:13 | 10 - 11 классы

Дана вещественная квадратная матрица А порядка n?

Дана вещественная квадратная матрица А порядка n.

Найти среднее арифметическое среди положительных элементов матрицы, находящихся на главной и побочной диагоналях.

Выдать сообщение, если таких элементов нет.

Gill009 27 дек. 2020 г., 04:57:54 | 10 - 11 классы

Опишите на С + + алгоритм определения количества положительных элементов квадратной матрицы, превышающих по величине среднее арифметическое всех элементов главной диагонали?

Опишите на С + + алгоритм определения количества положительных элементов квадратной матрицы, превышающих по величине среднее арифметическое всех элементов главной диагонали.

Gvovan007 14 окт. 2020 г., 08:11:59 | 10 - 11 классы

В двумерном массиве 7Х7 произвольных целых чисел вычислить сумму элементов, расположенных слева от побочной диагонали?

В двумерном массиве 7Х7 произвольных целых чисел вычислить сумму элементов, расположенных слева от побочной диагонали.

Определить минимальный элемент главной диагонали (значение и координаты).

NURLAN1999 7 янв. 2020 г., 10:30:42 | 10 - 11 классы

В массике 50 элементов , числа от - 50 до 50 , вычислить среднее арифметическое отрицательных чисел?

В массике 50 элементов , числа от - 50 до 50 , вычислить среднее арифметическое отрицательных чисел.

Egor270899 28 дек. 2020 г., 14:51:34 | 5 - 9 классы

Вычислить среднее арифметическое отрицательных элементов вектора Q(21) p?

Вычислить среднее арифметическое отрицательных элементов вектора Q(21) p.

S. через программу паскаль.

IvanWein 14 сент. 2020 г., 17:25:44 | 10 - 11 классы

Написать программу для следующей задачи : в матрице А(8, 8) все отрицательные элементы, стоящие на главной диагонали и ниже нее, заменить нулями?

Написать программу для следующей задачи : в матрице А(8, 8) все отрицательные элементы, стоящие на главной диагонали и ниже нее, заменить нулями.

Денис333337 13 сент. 2020 г., 17:12:06 | 10 - 11 классы

Помогите пожалуйста, я должна написать 6 лабораторных работ((?

Помогите пожалуйста, я должна написать 6 лабораторных работ((.

Написать программу на Паскале.

Дана матрица.

Вычислить среднее арифметическое четных элементов главной диагонали.

Zvezdochka4561 24 сент. 2020 г., 16:36:14 | 10 - 11 классы

Задача на плюсах?

Задача на плюсах.

Помогите, пожалуйста.

Найти среднее арифметическое кратных пяти элементов побочной диагонали матрицы.

Нужно с динамическим массивом решить.

На этой странице находится вопрос Вычислить среднее арифметическое отрицательных элементов выше главной и ниже побочной диагонали?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.