Заменить элементы побочной диагонали минимальными значениями строк?

Информатика | 10 - 11 классы

Заменить элементы побочной диагонали минимальными значениями строк.

Помогите еще раз!

Ответить на вопрос
Ответы (1)
DeByLLIka 25 мая 2020 г., 02:56:44

Const n = 10 ;

var a : array [1.

N, 1.

N] of integer ; i, j, min : integer ;

begin Randomize ; Writeln(' * * * Исходная матрица * * * ') ; for i : = 1 to n do begin for j : = 1 to n do begin a[i, j] : = Random(101) - 50 ; Write(a[i, j] : 4) end ; Writeln end ; { Собственно, замена } for i : = 1 to n do begin min : = 32767 ; for j : = 1 to n do if min > ; a[i, j] then min : = a[i, j] ; a[i, n - i + 1] : = min end ; { Результат } Writeln(' * * * Результирующая матрица * * * ') ; for i : = 1 to n do begin for j : = 1 to n do Write(a[i, j] : 4) ; Writeln end

end.

Тестовое решение : * * * Исходная матрица * * * 40 7 17 - 35 21 2 28 9 6 22 - 18 - 10 - 26 - 21 12 2 - 40 7 32 - 25 - 40 - 34 - 40 16 15 - 37 - 36 40 7 - 3 50 - 15 - 11 43 - 49 - 48 - 46 - 10 48 - 31 - 26 3 25 38 - 39 14 9 - 20 46 7 - 29 - 14 - 15 - 50 39 23 - 4 - 49 1 7 - 13 39 - 49 - 42 22 47 - 49 - 19 - 23 10 - 2 21 9 12 - 49 8 - 8 - 27 5 - 50 5 35 44 - 50 - 25 14 - 50 - 12 - 46 - 21 7 - 47 40 - 9 33 - 15 1 17 - 35 - 36 * * * Результирующая матрица * * * 40 7 17 - 35 21 2 28 9 6 - 35 - 18 - 10 - 26 - 21 12 2 - 40 7 - 40 - 25 - 40 - 34 - 40 16 15 - 37 - 36 - 40 7 - 3 50 - 15 - 11 43 - 49 - 48 - 49 - 10 48 - 31 - 26 3 25 38 - 39 - 39 9 - 20 46 7 - 29 - 14 - 15 - 50 - 50 23 - 4 - 49 1 7 - 13 39 - 49 - 49 22 47 - 49 - 19 - 23 10 - 2 21 - 50 12 - 49 8 - 8 - 27 5 - 50 5 - 50 44 - 50 - 25 14 - 50 - 12 - 46 - 21 - 47 - 47 40 - 9 33 - 15 1 17 - 35 - 36.

Marmaduke 16 нояб. 2020 г., 23:38:13 | 10 - 11 классы

HELP?

HELP!

Заменить значения всех элементов главной диагонали массива на нулевые.

Snezhana250603 28 нояб. 2020 г., 02:59:38 | 5 - 9 классы

23. Дана действительная квадратная матрица порядка n?

23. Дана действительная квадратная матрица порядка n.

Выяснить, верно ли, что наибольшее из значений элементов главной диагонали больше, чем наименьшее из значений элементов побочной диагонали.

2001алёська 10 нояб. 2020 г., 07:43:53 | 10 - 11 классы

Заменить значения всех четных элементов главной диагонали массива на нулевые?

Заменить значения всех четных элементов главной диагонали массива на нулевые.

Pascal.

Alsunya91 17 июн. 2020 г., 06:45:17 | 10 - 11 классы

Помогите написать программу в pascal'e?

Помогите написать программу в pascal'e.

Если матрица квадратная, то поменять местами минимальный и максимальный элементы побочной диагонали.

В противном случае - заменить элементы четных строк нулями.

Yyyyulya 7 нояб. 2020 г., 18:44:21 | 10 - 11 классы

Дана матрица К(3, 3), найти минимальный элемент массива в строке с индексом 3 и заменить этим значением все элементы главной диагонали?

Дана матрица К(3, 3), найти минимальный элемент массива в строке с индексом 3 и заменить этим значением все элементы главной диагонали.

Gvovan007 14 окт. 2020 г., 08:11:59 | 10 - 11 классы

В двумерном массиве 7Х7 произвольных целых чисел вычислить сумму элементов, расположенных слева от побочной диагонали?

В двумерном массиве 7Х7 произвольных целых чисел вычислить сумму элементов, расположенных слева от побочной диагонали.

Определить минимальный элемент главной диагонали (значение и координаты).

315017 22 дек. 2020 г., 09:27:53 | 10 - 11 классы

В двумерном массиве а из m строк и n столбцов найти систему всех элементов и заменить на нули элементы на главной диагонали помогите пожалуйста выполнить через Pascal?

В двумерном массиве а из m строк и n столбцов найти систему всех элементов и заменить на нули элементы на главной диагонали помогите пожалуйста выполнить через Pascal!

AnnaR2011 17 мар. 2020 г., 20:00:07 | 10 - 11 классы

Вычислить среднее арифметическое отрицательных элементов выше главной и ниже побочной диагонали?

Вычислить среднее арифметическое отрицательных элементов выше главной и ниже побочной диагонали.

Dracula666 4 нояб. 2020 г., 05:05:36 | 10 - 11 классы

Заполнить матрицу А 5х5 случайными числами до 20 и далее выполнить задание : 1?

Заполнить матрицу А 5х5 случайными числами до 20 и далее выполнить задание : 1.

Найти максимальный элемент на побочной диагонали ; 2.

Составить одномерный массив В из минимальных элементов каждой строки ; 3.

В одномерном массиве В найти среднее арифметическое и вывести на экран элементы массива В, которые больше среднего арифметического.

Ldinka73 2 нояб. 2020 г., 21:12:06 | 10 - 11 классы

Задан двумерный массив Y из 4 - х строк и 4 - х столбцов?

Задан двумерный массив Y из 4 - х строк и 4 - х столбцов.

Составить программу, которая вычисляет S – сумму элементов побочной диагонали и значение суммы всех элементов массива

На с + + подробне пожалуйста эту задачу я не понял что то.

На этой странице находится вопрос Заменить элементы побочной диагонали минимальными значениями строк?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.