Написать программы суммирования чисел от 1 до 100, используя все циклические конструкции (Repeat?

Информатика | 10 - 11 классы

Написать программы суммирования чисел от 1 до 100, используя все циклические конструкции (Repeat.

Until, While.

Do, For.

To). Найти среднее арифметическое этих чисел.

Ответить на вопрос
Ответы (1)
Klepazka2010 12 мая 2020 г., 02:56:08

Var sum, i : integer ;

sa : real ;

begin

i : = 0 ;

sum : = 0 ;

for i : = 1 to 100 do

sum : = sum + i ;

writeln(sum) ;

sa : = sum / i ;

writeln(sa : 1 : 2) ;

end.

123я456 30 июл. 2020 г., 10:00:18 | 5 - 9 классы

Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры?

Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры.

Вид экрана : Введите числа.

Для завершения последовательности нажмите ноль.

45 23 15 0 введено чисел : 3 сумма чисел : 83 Среднее арифметическое : 27.

67 С ЦИКЛОМ While do пожалуйста напишите а не с Repeat untill.

Randy322 17 нояб. 2020 г., 09:15:42 | 5 - 9 классы

Напишите программу для вычисления n - й степени числа x?

Напишите программу для вычисления n - й степени числа x.

Вычисление описать каждым из трех вариантов оператора цикла : For.

To. do, While.

Do, Repeat.

Until.

Lex766 23 дек. 2020 г., 05:25:58 | 5 - 9 классы

Составить программу с использованием циклических конструкций While… do… и Repeat… Until…?

Составить программу с использованием циклических конструкций While… do… и Repeat… Until….

Антон20052005 6 сент. 2020 г., 02:27:46 | 10 - 11 классы

Написать фрагмент программы на VBA для нахождения произведения чисел с шагом 2 на интервале от - 10 до 10 используя For - Next, Do - Loop While с предпосылкой и Do - Loop Until с послесловием?

Написать фрагмент программы на VBA для нахождения произведения чисел с шагом 2 на интервале от - 10 до 10 используя For - Next, Do - Loop While с предпосылкой и Do - Loop Until с послесловием.

05sanek05 21 июл. 2020 г., 21:36:51 | 5 - 9 классы

Легкая задачка на циклы?

Легкая задачка на циклы.

ОБЯЗАТЕЛЬНО с циклами.

Pascal.

For…do, while…do и repeat…until любой.

Иванова2 24 авг. 2020 г., 14:38:28 | 10 - 11 классы

Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать)?

Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать).

Сделайте три варианта программы, используя операторы While, Repeat , For.

Никитакиоссе2 10 нояб. 2020 г., 21:02:09 | 10 - 11 классы

Вычислить сумму первых N чисел натурального ряда?

Вычислить сумму первых N чисел натурального ряда.

С использованием операторов цикла For - To (или For - Downto), While - Do и Repeat - Until.

Паскаль.

Хрен62118 11 мая 2020 г., 18:36:10 | 10 - 11 классы

Найти сумму семи нечетных чисел натурального ряда, начиная с N> ; 0?

Найти сумму семи нечетных чисел натурального ряда, начиная с N> ; 0.

N вводится с клавиатуры.

Сделать нужно по 3 циклам в паскале (repeat until, for to do, while do).

Nurtjt99 9 дек. 2020 г., 14:45:10 | 5 - 9 классы

1. Найти среднее арифметическое и среднее геометрическое двух чисел?

1. Найти среднее арифметическое и среднее геометрическое двух чисел.

Написать программу (Паскаль).

Bozhena0307 22 нояб. 2020 г., 12:56:23 | 10 - 11 классы

50 + лучшийСоставьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел(массив не использовать)?

50 + лучший

Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел

(массив не использовать).

Сделайте три варианта программы, используя операторы While, Repeat, For.

На этой странице сайта размещен вопрос Написать программы суммирования чисел от 1 до 100, используя все циклические конструкции (Repeat? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.