Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать)?

Информатика | 10 - 11 классы

Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать).

Сделайте три варианта программы, используя операторы While, Repeat , For.

Ответить на вопрос
Ответы (2)
Юльчик198 24 авг. 2020 г., 14:38:33

Программа может выглядеть так :

uses Crt ;

const n = 10 ;

var a, i, Sum : integer ; Sred : real ;

begin

ClrScr ;

Sum : = 0 ;

i : = 1 ;

While i< ; = 10 do

begin Write ('a = ') ; ReadLn(a) ; Sum : = Sum + a ; i : = i + 1 ;

end ;

Sred : = Sum / n ;

Writeln('Sred = ', Sred : 6 : 2) ;

WriteLn ;

Sum : = 0 ;

i : = 1 ;

repeat Write ('a = ') ; ReadLn(a) ; Sum : = Sum + a ; i : = i + 1 ;

until i> ; n ;

Sred : = Sum / n ;

Writeln('Sred = ', Sred : 6 : 2) ;

WriteLn ;

Sum : = 0 ;

for i : = 1 to n do begin Write ('a = ') ; ReadLn(a) ; Sum : = Sum + a ; end ;

Sred : = Sum / n ;

Writeln('Sred = ', Sred : 6 : 2) ;

ReadLn ;

end.

Kriazanowa2015 24 авг. 2020 г., 14:38:40

1. While :

var a, i, s : integer ;

begin

s : = 0 ;

i : = 0 ;

while i< ; 10 do

begin

i : = i + 1 ;

write('a = ') ;

readln(a) ;

s : = s + a ;

end ;

writeln('Среднее арифметическое = ', s / 10) ;

end.

2. Repeat

var a, i, s : integer ;

begin

s : = 0 ;

i : = 0 ;

repeat

i : = i + 1 ;

write('a = ') ;

readln(a) ;

s : = s + a ;

until i = 10 ;

writeln('Среднее арифметическое = ', s / 10) ;

end.

3. For :

var a, i, s : integer ;

begin

s : = 0 ;

for i : = 1 to 10 do

begin

write('a = ') ;

readln(a) ;

s : = s + a ;

end ;

writeln('Среднее арифметическое = ', s / 10) ;

end.

Пример :

a = 4

a = 6

a = 9

a = 7

a = 1

a = 3

a = 6

a = 5

a = 4

a = 8

Среднее арифметическое = 5.

3.

Karpova20000 14 авг. 2020 г., 14:52:49 | 10 - 11 классы

Составьте программу, которая вычисляет среднее арифметическое положительных и четных чисел из N введенных?

Составьте программу, которая вычисляет среднее арифметическое положительных и четных чисел из N введенных.

Значение N вводится с клавиатуры.

Нужно сделать в системе КуМир тремя способами (1) Для (2) При (3) Пока.

Tmiezhieninaru 30 сент. 2020 г., 23:43:56 | 5 - 9 классы

ЯЗЫК QBASIC ?

ЯЗЫК QBASIC !

Решите задачи, используя цикл while - wend 1.

Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры.

2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).

222нез 12 мая 2020 г., 02:56:06 | 10 - 11 классы

Написать программы суммирования чисел от 1 до 100, используя все циклические конструкции (Repeat?

Написать программы суммирования чисел от 1 до 100, используя все циклические конструкции (Repeat.

Until, While.

Do, For.

To). Найти среднее арифметическое этих чисел.

Goldniti80 24 дек. 2020 г., 23:10:32 | 10 - 11 классы

Помогите пожалуйста, срочно?

Помогите пожалуйста, срочно!

1. Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать).

Сделайте три варианты программ, используя операторы цикла While, Repeat и For.

2. Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате сообщит, сколько среди введенных чисел четных и сколько нечетных.

Заранее спасибо!

Lomar100 12 февр. 2020 г., 19:03:58 | 5 - 9 классы

Ребят, помогите пожалуйста, очень надо)))) Напишите программу, в которой осуществляется ввод целых чисел ( ввод осуществляется до тех пор, пока не будет введен ноль) и определение максимального (наибо?

Ребят, помогите пожалуйста, очень надо)))) Напишите программу, в которой осуществляется ввод целых чисел ( ввод осуществляется до тех пор, пока не будет введен ноль) и определение максимального (наибольшего) из введенных чисел.

Используйте оператор repeat.

Программу нужно написать в паскале.

Viktoria3311 9 нояб. 2020 г., 18:19:25 | 5 - 9 классы

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введен нуль) и подсчет суммы и среднего арифметического введенных положительных чисел?

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введен нуль) и подсчет суммы и среднего арифметического введенных положительных чисел.

Используйте оператор repeat.

Фатима61 25 сент. 2020 г., 15:26:56 | 5 - 9 классы

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчет количества введеных чисел ?

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчет количества введеных чисел .

Используйте оператор while.

Решить в паскале.

Tanomy 27 июл. 2020 г., 04:18:13 | 5 - 9 классы

Составить программу, которая в последовательности из любых N целых чисел (до 100 чисел) считает количество чисел меньших среднего арифметического всех введенных чисел?

Составить программу, которая в последовательности из любых N целых чисел (до 100 чисел) считает количество чисел меньших среднего арифметического всех введенных чисел.

Bozhena0307 22 нояб. 2020 г., 12:56:23 | 10 - 11 классы

50 + лучшийСоставьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел(массив не использовать)?

50 + лучший

Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел

(массив не использовать).

Сделайте три варианта программы, используя операторы While, Repeat, For.

Fifsangy1245 13 нояб. 2020 г., 10:36:26 | 5 - 9 классы

Составьте программу для вычисления суммы натуральных чисел от 20 до 99?

Составьте программу для вычисления суммы натуральных чисел от 20 до 99.

Решите задачку в двух вариантах - с использованием операторов while и repeat.

СРОЧНО ПОЖАЛУЙСТА ПОМОГИТЕ.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать)?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.