Помогите пожалуйста решить задачу в паскале : Составить программу, проверяющую, является ли заданное натуральное число палиндромом, т?

Информатика | 5 - 9 классы

Помогите пожалуйста решить задачу в паскале : Составить программу, проверяющую, является ли заданное натуральное число палиндромом, т.

Е. таким, которое читается одинаково слева направо и справа налево(например : 23132).

Ответить на вопрос
Ответы (1)
Polonickaya 26 мар. 2020 г., 17:30:12

Var n, m, p : word ;

begin write('Enter number : ') ; readln(n) ; m : = n ; p : = 0 ; while m > ; 0 do begin p : = p * 10 + m mod 10 ; m : = m div 10 ; end ; if n = p then writeln('Palindrome') else writeln('Not palindrome') ;

readln ;

end.

Aminka9707 26 июн. 2020 г., 14:32:03 | 5 - 9 классы

Помогите, пожалуйста, решить задачу на Паскале?

Помогите, пожалуйста, решить задачу на Паскале.

Строка содержит одно слово.

Проверить, будет ли оно читаться одинаково справа налево и слева направо.

При условии, что выполнение цикла будет закончено после найденной неравной пары.

Kraynova009 2 апр. 2020 г., 15:39:02 | 5 - 9 классы

Дано трёхзначное число?

Дано трёхзначное число.

Напишите в паскаль программу, которая определяет : Является ли число "перевёртышем", т.

Е. числом, десятичная запись которого читается одинаково слева направо и справа налево.

Милена40 2 авг. 2020 г., 13:59:55 | 5 - 9 классы

Составить программу в паскале для определения является ли заданное слово палиндромом?

Составить программу в паскале для определения является ли заданное слово палиндромом.

Anzhelako 28 дек. 2020 г., 08:06:38 | 5 - 9 классы

Число называется палиндромом, если справа налево и слева направо читается одинаково?

Число называется палиндромом, если справа налево и слева направо читается одинаково.

Например, 12321 – палиндром.

Найдите ближайший палиндром, больший числа 13244.

Пример : для числа 12 ближайший палиндром, больший него, это 22.

Zexxxxxx 19 окт. 2020 г., 15:28:12 | 10 - 11 классы

Палиндромом назовем число, состоящее не менее чем из 2 - х символов или цифр, одинаково читающееся как слева направо, так и наоборот?

Палиндромом назовем число, состоящее не менее чем из 2 - х символов или цифр, одинаково читающееся как слева направо, так и наоборот.

Например, число «1221» является палиндромом, а число «1224» – нет.

Назовем палиндромом - 1016 число, являющееся палиндромом в десятичном и шестнадцатеричном представлении.

Количество палиндромов - 1016 среди первых десяти миллионов натуральных чисел составит….

Аннушка56 5 авг. 2020 г., 11:22:28 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Напишите программу, которая определяет : является ли число "перевертышем", т.

Е. числом, десятичная запись которого читается одинаково слева направо и справа налево.

123 - нет 121 - да 222 - да.

Samoshina170287 16 авг. 2020 г., 03:24:18 | 5 - 9 классы

Помогите пожалуйста с задачей?

Помогите пожалуйста с задачей!

Последовательность букв называется палиндромом, если справа налево она читается так же, как слева направо, например, АББА – палиндром.

Сколько существует слов длины 13, которые составлены только из букв a и b и не являются палиндромами?

Romario06gr 9 нояб. 2020 г., 22:53:39 | 5 - 9 классы

Петя узнал на уроке английского языка в школе о том, что существуют палиндромы – слова, которые читаются справа налево и слева направо одинаково?

Петя узнал на уроке английского языка в школе о том, что существуют палиндромы – слова, которые читаются справа налево и слева направо одинаково.

Придя на урок математики, он обнаружил, что число 101 тоже палиндром.

На уроке информатики, в этот же день, Петя изучал логические переменные.

«Вот интересно», - подумал Петя, - «смогу ли я самостоятельно написать программу, которая будет моделью англичанина, определяющего на слух слова и числа палиндромы?

». Требуется написать программу, которая сможет смоделировать деятельность англичанина, определяющего на слух слова и числа, которые являются палиндромами.

Bolgari1994 24 февр. 2020 г., 17:46:41 | 10 - 11 классы

Написать программу на языке Pascal Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево?

Написать программу на языке Pascal Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево.

Рассмотрим все натуральные числа, запись которых в десятичной системе счисления является палиндромом (при этом запись не начинается с нуля).

Например, числа 121 и 1331 являются палиндромами, а число 123 — нет.

По данному числу N найдите N - e в порядке возрастания число - палиндром.

Программа получает на вход одно натуральное число N, не превосходящее 100 000.

Программа должна вывести одно натуральное число — N - е в порядке возрастания число - палиндром.

Пример входных и выходных данных Ввод 20 Вывод 111.

Anya040904 5 дек. 2020 г., 04:08:00 | 10 - 11 классы

Чебурашка составлял палиндромы из букв Ч и Б?

Чебурашка составлял палиндромы из букв Ч и Б.

Получилось 35 палиндромов.

Сколько было букв Ч, если букв Б было 7?

(В каждом палиндроме использовались все буквы Ч и все буквы Б.

) В качестве ответа укажите одно натуральное число.

Комментарий.

Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево.

Например, ЧЧББЧЧ — это палиндром.

Вы перешли к вопросу Помогите пожалуйста решить задачу в паскале : Составить программу, проверяющую, является ли заданное натуральное число палиндромом, т?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.