Даны целые числа а1, а2, ?

Информатика | 10 - 11 классы

Даны целые числа а1, а2, .

, аn.

Определить количество чисел, входящих в последовательность только один раз.

Помогите решить задачу в паскале.

Срочно дам 20 баллов за ответ помогите пожалуйста.

Ответить на вопрос
Ответы (1)
Катюша001 6 февр. 2020 г., 19:33:11

Var n, k, i, imax, j : integer ; a : array[1.

100]of integer ;

begin randomize ; n : = random(30) + 10 ; for i : = 1 to n do begin a[i] : = Random(30) ; write(a[i], ' ') ; end ; writeln() ; {сортировочка} for i : = 1 to n - 1 do begin imax : = i ; for j : = i + 1 to n do if a[j] > ; a[imax] then imax : = j ; k : = a[i] ; a[i] : = a[imax] ; a[imax] : = k ; end ; for i : = 1 to n do write(a[i], ' ') ; k : = 0 ; for i : = 2 to n - 1 do if (a[i] < ; > ; a[i - 1]) and (a[i] < ; > ; a[i + 1]) then k : = k + 1 ; if a[1] < ; > ; a[2] then k : = k + 1 ; if a[n] < ; > ; a[n - 1] then k : = k + 1 ; writeln() ; writeln('No doubles - ', k) ;

end.

Сень123 26 сент. 2020 г., 08:30:05 | 5 - 9 классы

ПОМОГИТЕ С ПАСКАЛЕМ?

ПОМОГИТЕ С ПАСКАЛЕМ.

С клавиатуры вводятся 7 целых чисел.

Вычислить количество отрицательных членов этой последовательности.

Svetlana3012642 23 дек. 2020 г., 01:36:59 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число?

Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число.

Программа получает на вход целые числа, количество введенных данных неизвестно, последовательность чисел заканчивается числом 0.

На Паскале.

Mitiay 13 нояб. 2020 г., 07:01:09 | 5 - 9 классы

Помогите решить задачу?

Помогите решить задачу!

Даны два целых числа а и б (а< ; б) вывести на экран все целые числа расположенные между данными числами ( не включая эти числа , в порядке их убывания, а так же количество этих чисел.

(Паскаль цикл с предусловием).

NemOsTOOr230 16 дек. 2020 г., 15:30:50 | 10 - 11 классы

Решите задачу в Паскале?

Решите задачу в Паскале.

Если можно с блок - схемой.

Дана последовательность чисел.

Вывести на экран все отрицательные числа.

Anastasi482 18 июл. 2020 г., 06:14:14 | 5 - 9 классы

Решите пожалуйста в паскале задачи 1)Дана непустая последовательность целых чисел, оканчивающаяся нулем?

Решите пожалуйста в паскале задачи 1)Дана непустая последовательность целых чисел, оканчивающаяся нулем.

Найти : а) сумму всех чисел последовательности, больших числа x ; б) количество всех четных чисел последовательности.

2)Дана последовательность ненулевых целых чисел, оканчивающая нулем.

Оп - ределить, сколько раз в этой последовательности меняется знак.

(Например, в последовательности 10, –4, 12, 56, –4 знак меняется 3 раза.

).

Irina79201 15 окт. 2020 г., 04:26:49 | 5 - 9 классы

Вводится число А и 7 целых чисел, определить, каким по счету в последовательности будет число а , если его нет, то вывести ноль решите пожалуйста способом паскаля?

Вводится число А и 7 целых чисел, определить, каким по счету в последовательности будет число а , если его нет, то вывести ноль решите пожалуйста способом паскаля.

Aselyaabylhano 19 апр. 2020 г., 13:19:05 | 10 - 11 классы

Помогите пожалуйста решить эту задачу в паскале, просто для новичка и с объяснениями, почему выполнено то или иное действие?

Помогите пожалуйста решить эту задачу в паскале, просто для новичка и с объяснениями, почему выполнено то или иное действие.

Очень срочно надо.

Дано целое к и набор из ненулевых чисел, признак его завершения - число 0.

Вывести количество чисел в наборе, меньших к.

Vipexb 20 янв. 2020 г., 03:20:33 | 5 - 9 классы

Дана последовательность целых чисел, оканчивающаяся числом 100?

Дана последовательность целых чисел, оканчивающаяся числом 100.

Определить, есть ли в последовательности число 77.

Если такое число есть, то вывести «Yes».

В противном случае вывести «No».

Решить данную задачу двумя способами, используя циклы с пред и пост условиями.

( в ПАСКАЛЕ).

Rena212 8 мар. 2020 г., 20:57:06 | 5 - 9 классы

Дам 59 баллов помогите пожалуйста, буду очень благодарен?

Дам 59 баллов помогите пожалуйста, буду очень благодарен.

Дано время — два целых числа количество часов и минут.

Необходимо определить меньший угол между часовой и минутной стрелками на циферблате часов.

Решить в паскаль.

Islan03 7 дек. 2020 г., 06:48:48 | 10 - 11 классы

Решите, пожалуйста, задачу на языке Паскаль Дана непустая последовательность целых чисел, за которой следует ноль (признак конца последовательности)?

Решите, пожалуйста, задачу на языке Паскаль Дана непустая последовательность целых чисел, за которой следует ноль (признак конца последовательности).

Найти первое отрицательное число этой последовательности.

Заранее благодарю за ответы.

На этой странице сайта вы найдете ответы на вопрос Даны целые числа а1, а2, ?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.