Вводится число А и 7 целых чисел, определить, каким по счету в последовательности будет число а , если его нет, то вывести ноль решите пожалуйста способом паскаля?

Информатика | 5 - 9 классы

Вводится число А и 7 целых чисел, определить, каким по счету в последовательности будет число а , если его нет, то вывести ноль решите пожалуйста способом паскаля.

Ответить на вопрос
Ответы (1)
Mixa20003595 15 окт. 2020 г., 04:26:54

Program pr ;

uses crt ;

Var a, b, x1, i : integer ;

Begin

x1 : = 0 ;

Writeln('vvedite chislo') ;

readln(a) ;

Writeln('vvedite posledovatelnost') ;

For i : = 1 to 7 do

Begin

readln(b) ;

if a = b then x1 : = i ;

end ;

Writeln('¹ = ', x1) ;

readln ;

end.

Если номер последовательность выводить нужно каждый раз когда встречается то число тогда так

Program pr ;

uses crt ;

Var a, b, x1, i : integer ;

Begin

x1 : = 0 ;

Writeln('vvedite chislo') ;

readln(a) ;

Writeln('vvedite posledovatelnost') ;

For i : = 1 to 7 do

Begin

readln(b) ;

if a = b then Writeln('¹ = ', i) ;

end ;

readln ;

end.

Asasin007 8 дек. 2020 г., 18:06:28 | 5 - 9 классы

Программа в Паскале?

Программа в Паскале!

"Напишите программу, которая в последовательности целых чисел определяет сумму максимального и минимального чисел .

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом ноль (ноль – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30000.

" Отдал все пункты что есть!

Помогите!

NemOsTOOr230 16 дек. 2020 г., 15:30:50 | 10 - 11 классы

Решите задачу в Паскале?

Решите задачу в Паскале.

Если можно с блок - схемой.

Дана последовательность чисел.

Вывести на экран все отрицательные числа.

Makcimys12395 28 окт. 2020 г., 15:23:13 | 5 - 9 классы

Дана последовательность целых чисел, оканчивающаяся числом 100?

Дана последовательность целых чисел, оканчивающаяся числом 100.

Определить, есть ли в последовательности число 77.

Если такое число есть, то вывести «Yes».

В противном случае вывести «No».

Решить данную задачу двумя способами, используя циклы с пред и пост условиями.

Shjwjan 14 янв. 2020 г., 09:31:33 | 10 - 11 классы

Паскаль Пусть вводится последовательность вещественных чисел, оканчивающаяся нулем и состоящая более чем из одного ненулевого элемента?

Паскаль Пусть вводится последовательность вещественных чисел, оканчивающаяся нулем и состоящая более чем из одного ненулевого элемента.

Определите наибольшее число последовательности.

Vipexb 20 янв. 2020 г., 03:20:33 | 5 - 9 классы

Дана последовательность целых чисел, оканчивающаяся числом 100?

Дана последовательность целых чисел, оканчивающаяся числом 100.

Определить, есть ли в последовательности число 77.

Если такое число есть, то вывести «Yes».

В противном случае вывести «No».

Решить данную задачу двумя способами, используя циклы с пред и пост условиями.

( в ПАСКАЛЕ).

Jekaman2013 20 мар. 2020 г., 13:25:44 | 10 - 11 классы

Решить задачу на Паскале, используя циклы?

Решить задачу на Паскале, используя циклы.

Вводится последовательность целых чисел, не превосходящих по модулю 10 ^ 9, и при этом не равных нулю.

Ноль – признак конца.

Вы - дайте три максимальных числа этой последовательности, не игнорируя дубликаты (то есть, три числа в ответе могут совпадать).

Гарантирует - ся, что в последовательности есть как минимум три содержательных элемента.

Дашуляяяяяяяяяя 1 июн. 2020 г., 18:30:20 | 5 - 9 классы

Напишите задачи в Паскале задача1 {вводится целое число n от [0?

Напишите задачи в Паскале задача1 {вводится целое число n от [0.

200].

Затеи вводится n целых чисел от [0.

1000000] Вывести на экран их произведение.

} задача2 {вводится целое число n от [0.

200].

Затеи вводится n целых чисел от [0.

1000000] вывести на экран наибольшее из них} задача 3 {вводится целое число n от [0.

200].

Затеи вводится n целых чисел от [0.

1000000] Вывести на экран номер наименьшего из них.

}.

Indira3927 7 авг. 2020 г., 05:44:57 | 5 - 9 классы

Требуется использовать язык Паскаль Даны три целых числа A, B, C?

Требуется использовать язык Паскаль Даны три целых числа A, B, C.

Значения чисел вводятся с клавиатуры.

Определить количество нулей среди данных чисел.

Результат вывести на экран.

Jingo 23 янв. 2020 г., 06:36:25 | 5 - 9 классы

Требуется использовать язык Паскаль Даны три целых числа A, B, C?

Требуется использовать язык Паскаль Даны три целых числа A, B, C.

Значения чисел вводятся с клавиатуры.

Определить количество нулей среди данных чисел.

Результат вывести на экран.

Islan03 7 дек. 2020 г., 06:48:48 | 10 - 11 классы

Решите, пожалуйста, задачу на языке Паскаль Дана непустая последовательность целых чисел, за которой следует ноль (признак конца последовательности)?

Решите, пожалуйста, задачу на языке Паскаль Дана непустая последовательность целых чисел, за которой следует ноль (признак конца последовательности).

Найти первое отрицательное число этой последовательности.

Заранее благодарю за ответы.

Вы открыли страницу вопроса Вводится число А и 7 целых чисел, определить, каким по счету в последовательности будет число а , если его нет, то вывести ноль решите пожалуйста способом паскаля?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.