Дам 59 баллов помогите пожалуйста, буду очень благодарен?

Информатика | 5 - 9 классы

Дам 59 баллов помогите пожалуйста, буду очень благодарен.

Дано время — два целых числа количество часов и минут.

Необходимо определить меньший угол между часовой и минутной стрелками на циферблате часов.

Решить в паскаль.

Ответить на вопрос
Ответы (1)
Solomatinanata 8 мар. 2020 г., 20:57:10

Считаем, что часовая стрелка движется непрерывно, а минутная в конце минуты перепрыгивает на следующее деление.

Var m, h : integer ; fm, fh, f : real ;

begin Write('Введите через пробел число часов и минут : ') ; Read(h, m) ; if h> ; = 12 then h : = h - 12 ; fm : = 6 * m ; fh : = 30 * h + 0.

5 * m ; f : = abs(fh - fm) ; if f> ; 180 then f : = 360 - f ; Writeln('Меньший угол между стрелками : ', f)

end.

Тестовое решение :

Введите через пробел число часов и минут : 21 10

Меньший угол между стрелками : 145.

Rome341 21 янв. 2020 г., 05:39:56 | 10 - 11 классы

Помогите пожалуйста написать алгоритм к этой задаче : Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество ми?

Помогите пожалуйста написать алгоритм к этой задаче : Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд.

Количество минут и секунд при необходимости дополняются до двузначного числа нулями.

С начала суток прошло n секунд.

Выведите, что покажут часы.

Alinochkanekrasova 3 окт. 2020 г., 16:51:03 | 5 - 9 классы

Дано количество секунд сначала суток?

Дано количество секунд сначала суток.

Вычислить текущее время в виде количества часов, минут и секунд.

Magda233 27 июн. 2020 г., 04:06:50 | 10 - 11 классы

Дано число n?

Дано число n.

С начала суток прошло n минут.

Определите, сколько часов и минут будут показывать электронные часы в этот момент.

Программа должна вывести два числа : количество часов (от 0 до 23) и количество минут (от 0 до 59).

Учтите, что число n может быть больше, чем количество минут в сутках.

Пример Ввод Вывод 150 2 30.

Aselyaabylhano 19 апр. 2020 г., 13:19:05 | 10 - 11 классы

Помогите пожалуйста решить эту задачу в паскале, просто для новичка и с объяснениями, почему выполнено то или иное действие?

Помогите пожалуйста решить эту задачу в паскале, просто для новичка и с объяснениями, почему выполнено то или иное действие.

Очень срочно надо.

Дано целое к и набор из ненулевых чисел, признак его завершения - число 0.

Вывести количество чисел в наборе, меньших к.

Kascheikos 6 февр. 2020 г., 19:33:05 | 10 - 11 классы

Даны целые числа а1, а2, ?

Даны целые числа а1, а2, .

, аn.

Определить количество чисел, входящих в последовательность только один раз.

Помогите решить задачу в паскале.

Срочно дам 20 баллов за ответ помогите пожалуйста.

Sergey228989 24 мар. 2020 г., 22:20:56 | 5 - 9 классы

Дано число n?

Дано число n.

С начала суток прошло n минут.

Определите, сколько часов и минут будут показывать электронные часы в этот момент.

Входные данные Вводится число n - целое, положительное, не превышает 107.

Выходные данные Программа должна вывести два числа : количество часов (от 0 до 23) и количество минут (от 0 до 59).

Учтите, что число n может быть больше, чем количество минут в сутках.

Arsila 12 июн. 2020 г., 14:21:40 | 5 - 9 классы

Для шифрования некоторого значения решили использовать изображение часов с циферблатом и тремя стрелками (часовой, минутной и секундной)?

Для шифрования некоторого значения решили использовать изображение часов с циферблатом и тремя стрелками (часовой, минутной и секундной).

В качестве значений цифр решили брать дискретные положения этих стрелок (произвольные, не зависящие друг от друга - нет механической связи) относительно часовой шкалы (12 делений - значения берутся от 0 до 11, вертикальное положение любой стрелки соответствует нулевому значению) и закодированные в соответствующей системе счисления, то есть в системе счисления использующей строго такое же количество цифр.

При шифровании получается число, каждый из разрядов которого может принимать значение от 0 до 11.

Младший разряд зашифрованного числа соответствует значению циферблата, указываемому секундной стрелкой, средний - минутной, старший - часовой.

Зашифрованное число перевели в десятичную систему счисления.

Какое значение получилось, если на циферблате секундная стрелка указывала на - 2, минутная - на 3, часовая - на цифру 4?

В ответе напишите значение зашифрованного десятичного числа.

Ralodrivereyela 18 сент. 2020 г., 15:41:10 | 5 - 9 классы

Часовая стрелка повернулась с начала суток на d градусов?

Часовая стрелка повернулась с начала суток на d градусов.

Определите, сколько сейчас целых часов h и целых минут m.

Входные данные : На вход программе подается целое число d (0< ; = d< ; = 360).

Выходные данные : Выведите на экран фразу : It is .

Hours .

Minutes.

ЗАДАНИЕ НА ЯЗЫКЕ ПАСКАЛЬ.

Misha13Misha13 11 июн. 2020 г., 14:04:04 | 5 - 9 классы

Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд?

Электронные часы показывают время в формате h : mm : ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд.

Количество минут и секунд при необходимости дополняются до двузначного числа нулями.

С начала суток прошло n секунд.

Выведите, что покажут часы.

Входные данные Вводится целое число n.

Выходные данные Выведите ответ на задачу, соблюдая требуемый формат.

Примеры Входные данные 3602 Выходные данные 1 : 00 : 02 Входные данные 129700 Выходные данные 12 : 01 : 40.

Arsentimur 12 окт. 2020 г., 11:41:26 | 5 - 9 классы

JAVA Дано число n?

JAVA Дано число n.

С начала суток прошло n минут.

Определите, сколько часов и минут будут показывать электронные часы в этот момент.

Программа должна вывести два числа : количество часов (от 0 до 23) и количество минут (от 0 до 59).

Учтите, что число n может быть больше, чем количество минут в сутках.

Перед вами страница с вопросом Дам 59 баллов помогите пожалуйста, буду очень благодарен?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.