Решите пожалуйста в паскале задачи 1)Дана непустая последовательность целых чисел, оканчивающаяся нулем?

Информатика | 5 - 9 классы

Решите пожалуйста в паскале задачи 1)Дана непустая последовательность целых чисел, оканчивающаяся нулем.

Найти : а) сумму всех чисел последовательности, больших числа x ; б) количество всех четных чисел последовательности.

2)Дана последовательность ненулевых целых чисел, оканчивающая нулем.

Оп - ределить, сколько раз в этой последовательности меняется знак.

(Например, в последовательности 10, –4, 12, 56, –4 знак меняется 3 раза.

).

Ответить на вопрос
Ответы (1)
Veller 18 июл. 2020 г., 06:14:20

Program n1 ;

var a, k, sum, x : integer ;

begin

write('Введите число X : ') ;

readln(x) ;

sum : = 0 ; k : = 0 ;

writeln('Введите непустую последовательность целых чисел, которая оканчивается нулем : ') ;

read(a) ;

while a < ; > ; 0 do

begin

if a> ; x then sum : = sum + a ;

if a mod 2 = 0 then k : = k + 1 ;

read(a) ;

end ;

writeln('Сумма всех чисел последовательности, больших числа X : ', sum) ;

writeln('Количество всех четных чисел последовательности : ', k) ;

end.

Program n2 ;

var a, b, k : integer ;

begin

writeln('Введите последовательность ненулевых целых чисел, которая оканчивается нулем : ') ;

read(a) ;

while a< ; > ; 0 do

begin

read(b) ;

if a * b< ; 0 then k : = k + 1 ;

a : = b ;

end ;

writeln(k, ' раз(а) в введенной последовательности меняется знак') ;

end.

Bjasiya 20 окт. 2020 г., 04:14:28 | 5 - 9 классы

Записать, как програму в паскале Дана последовательность чисел, оканчивающихся нулем?

Записать, как програму в паскале Дана последовательность чисел, оканчивающихся нулем.

Найти произведение чисел, оканчивающихся цифрой 5.

Olga050577 16 дек. 2020 г., 12:21:35 | 5 - 9 классы

Дана непустая последовательность положительный целых чисел, за которой следует 0?

Дана непустая последовательность положительный целых чисел, за которой следует 0.

Найти сумму всех четных чисел этой последовательности

Записать, как программу в паскале.

Shjwjan 14 янв. 2020 г., 09:31:33 | 10 - 11 классы

Паскаль Пусть вводится последовательность вещественных чисел, оканчивающаяся нулем и состоящая более чем из одного ненулевого элемента?

Паскаль Пусть вводится последовательность вещественных чисел, оканчивающаяся нулем и состоящая более чем из одного ненулевого элемента.

Определите наибольшее число последовательности.

Rjrjhtdf84 7 мая 2020 г., 23:26:52 | 5 - 9 классы

Дана последовательность чисел, заканчивающаяся нулем?

Дана последовательность чисел, заканчивающаяся нулем.

Найти сумму отрицательных и произведение положительных чисел.

Напишите в паскале.

InnaPshonko 23 дек. 2020 г., 16:50:27 | 5 - 9 классы

Помогите пожалуйста, язык программирования паскаль?

Помогите пожалуйста, язык программирования паскаль.

1)Дана последовательность чисел, оканчивающихся 0.

Определите сумму всех двузначных положительных и четных чисел.

2)дана последовательность из n чисел.

Сколько чисел этой последовательности являются двузначными, у которых последняя цифра 3.

1Демон1 31 дек. 2020 г., 04:01:46 | 10 - 11 классы

С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем?

С клавиатуры вводится последовательность целых чисел, оканчивающаяся нулем.

Найти количество отрицательных чисел и сумму чисел кратных 4.

ГиперГолубь 19 апр. 2020 г., 15:49:51 | 10 - 11 классы

Напишите программу, которая вводит последовательность целых чисел заканчивающихся нулем, и определяет количество четных положительных чисел в этой последовательности?

Напишите программу, которая вводит последовательность целых чисел заканчивающихся нулем, и определяет количество четных положительных чисел в этой последовательности.

Islan03 7 дек. 2020 г., 06:48:48 | 10 - 11 классы

Решите, пожалуйста, задачу на языке Паскаль Дана непустая последовательность целых чисел, за которой следует ноль (признак конца последовательности)?

Решите, пожалуйста, задачу на языке Паскаль Дана непустая последовательность целых чисел, за которой следует ноль (признак конца последовательности).

Найти первое отрицательное число этой последовательности.

Заранее благодарю за ответы.

Gp1950 21 дек. 2020 г., 04:24:54 | 10 - 11 классы

Дана последовательность целых чисел?

Дана последовательность целых чисел.

Найти количество различных чисел в этой последовательности.

Помогите с блок схемой через цикл while.

Rudtatv 16 сент. 2020 г., 03:09:44 | 5 - 9 классы

Помогите решить задачу на c + + вот зададча Дана последовательность чисел, оканчивающаяся числом 1000?

Помогите решить задачу на c + + вот зададча Дана последовательность чисел, оканчивающаяся числом 1000.

Определите какое из чисел, оканчивающихся нулем, наибольшее в этой последовательности.

1000 элементом последовательности не считается.

Гарантируется, что хотя бы одно такое число в последовательности есть.

Вопрос Решите пожалуйста в паскале задачи 1)Дана непустая последовательность целых чисел, оканчивающаяся нулем?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.