Решите, пожалуйста, задачу на языке Паскаль Дана непустая последовательность целых чисел, за которой следует ноль (признак конца последовательности)?

Информатика | 10 - 11 классы

Решите, пожалуйста, задачу на языке Паскаль Дана непустая последовательность целых чисел, за которой следует ноль (признак конца последовательности).

Найти первое отрицательное число этой последовательности.

Заранее благодарю за ответы.

Ответить на вопрос
Ответы (1)
Vikusichka2003 7 дек. 2020 г., 06:48:51

Var k, n : integer ;

begin n : = 0 ; Writeln('Введите последовательность целых чисел, завершающуюся нулем') ; repeat Read(k) ; if (n = 0) and (k< ; 0) then n : = k until k = 0 ; if n< ; 0 then Writeln('Первое отрицательное число равно ', n) else Writeln('Последовательность не содержит отрицательных чисел')

end.

Тестовое решение

Введите последовательность целых чисел, завершающуюся нулем

5 11 17 3 - 8 14 - 6 3 0

Первое отрицательное число равно - 8.

Kolyan4iklol 24 нояб. 2020 г., 08:30:37 | 5 - 9 классы

ПАСКАЛЬ?

ПАСКАЛЬ!

Найти величину наибольшего из отрицательных чисел последовательности из 100 целых чисел.

Asasin007 8 дек. 2020 г., 18:06:28 | 5 - 9 классы

Программа в Паскале?

Программа в Паскале!

"Напишите программу, которая в последовательности целых чисел определяет сумму максимального и минимального чисел .

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом ноль (ноль – признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30000.

" Отдал все пункты что есть!

Помогите!

ФМТ 4 окт. 2020 г., 15:12:04 | 10 - 11 классы

Дана непустая последовательность различных натуральных чисел , за которой следует 0?

Дана непустая последовательность различных натуральных чисел , за которой следует 0.

Определить порядковый номер наименьшего из них.

Olga050577 16 дек. 2020 г., 12:21:35 | 5 - 9 классы

Дана непустая последовательность положительный целых чисел, за которой следует 0?

Дана непустая последовательность положительный целых чисел, за которой следует 0.

Найти сумму всех четных чисел этой последовательности

Записать, как программу в паскале.

NemOsTOOr230 16 дек. 2020 г., 15:30:50 | 10 - 11 классы

Решите задачу в Паскале?

Решите задачу в Паскале.

Если можно с блок - схемой.

Дана последовательность чисел.

Вывести на экран все отрицательные числа.

Anastasi482 18 июл. 2020 г., 06:14:14 | 5 - 9 классы

Решите пожалуйста в паскале задачи 1)Дана непустая последовательность целых чисел, оканчивающаяся нулем?

Решите пожалуйста в паскале задачи 1)Дана непустая последовательность целых чисел, оканчивающаяся нулем.

Найти : а) сумму всех чисел последовательности, больших числа x ; б) количество всех четных чисел последовательности.

2)Дана последовательность ненулевых целых чисел, оканчивающая нулем.

Оп - ределить, сколько раз в этой последовательности меняется знак.

(Например, в последовательности 10, –4, 12, 56, –4 знак меняется 3 раза.

).

Irina79201 15 окт. 2020 г., 04:26:49 | 5 - 9 классы

Вводится число А и 7 целых чисел, определить, каким по счету в последовательности будет число а , если его нет, то вывести ноль решите пожалуйста способом паскаля?

Вводится число А и 7 целых чисел, определить, каким по счету в последовательности будет число а , если его нет, то вывести ноль решите пожалуйста способом паскаля.

Babinaanastasi 1 июн. 2020 г., 02:21:24 | 10 - 11 классы

Создать процедуру на языке VBA Дана последовательность целых чисел a1, …a45?

Создать процедуру на языке VBA Дана последовательность целых чисел a1, …a45.

Получить число отрицательных элементов последовательности a1, …a35 и число нулевых элементов всей последовательности.

Jekaman2013 20 мар. 2020 г., 13:25:44 | 10 - 11 классы

Решить задачу на Паскале, используя циклы?

Решить задачу на Паскале, используя циклы.

Вводится последовательность целых чисел, не превосходящих по модулю 10 ^ 9, и при этом не равных нулю.

Ноль – признак конца.

Вы - дайте три максимальных числа этой последовательности, не игнорируя дубликаты (то есть, три числа в ответе могут совпадать).

Гарантирует - ся, что в последовательности есть как минимум три содержательных элемента.

ZlataFox 23 дек. 2020 г., 17:19:43 | 5 - 9 классы

Дана последовательность из n целых чисел?

Дана последовательность из n целых чисел.

Определить, есть ли в ней число, равное первому из этой последовательности.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Решите, пожалуйста, задачу на языке Паскаль Дана непустая последовательность целых чисел, за которой следует ноль (признак конца последовательности)?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.