Составить программу на языке паскаль задание : дана матрица А(N, N)?

Информатика | 10 - 11 классы

Составить программу на языке паскаль задание : дана матрица А(N, N).

Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали.

Ответить на вопрос
Ответы (1)
Helen9013 23 мар. 2020 г., 19:46:25

Var n, i, j, ans : integer ;

a : array[, ] of integer ;

begin read(n) ; ans : = 0 ; SetLength(a, n + 1, n + 1) ; for i : = 1 to n do for j : = 1 to n do read(a[i, j]) ; for i : = 1 to n do for j : = i + 1 to n do if (a[i, j] > ; 0) then ans : = ans + 1 ; writeln(ans) ;

end.

Metelkinakristina 19 нояб. 2020 г., 08:56:07 | 10 - 11 классы

Дана квадратная матрица действительных чисел?

Дана квадратная матрица действительных чисел.

Найти сумму модулей элементов , расположенных выше главной диагонали.

СоняРыбакова 16 апр. 2020 г., 22:47:36 | 10 - 11 классы

Опишите на русском языке или на одном из языков программирования алгоритм определения количества положительных элементов квадратной матрицы, превышающих по величине среднее арифметическое всех элемент?

Опишите на русском языке или на одном из языков программирования алгоритм определения количества положительных элементов квадратной матрицы, превышающих по величине среднее арифметическое всех элементов главной диагонали.

Язык Паскаль.

Polina2101203 23 дек. 2020 г., 10:22:02 | 10 - 11 классы

Pascal?

Pascal.

Паскаль.

Написать программу, которая меняет знак всех положительных элементов, расположенных в строке и столбце матрицы с максимальным элементом.

Dodydyd 13 янв. 2020 г., 18:54:23 | 10 - 11 классы

Даны три целых числа?

Даны три целых числа.

Определить, сколько среди них положительных чисел.

Составить программу на языке Паскаль.

Nila123 8 окт. 2020 г., 22:07:07 | 10 - 11 классы

Помогите решить задачу в Паскале Дан двумерный массив?

Помогите решить задачу в Паскале Дан двумерный массив.

Найти сумму и количество положительных элементов, лежащих выше главной диагонали.

Naffana 1 авг. 2020 г., 12:58:37 | 10 - 11 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

Есть код программы в QBasic, нужно продолжить блок - схему.

Дана квадратная матрица.

Найти минимальное значение среди элементов, расположенных выше главной диагонали.

Лиза231001 14 окт. 2020 г., 12:10:52 | 10 - 11 классы

Дана целочисленная матрица 5 на 5?

Дана целочисленная матрица 5 на 5.

Определить положительные элементы на побочной диагонали.

(Паскаль).

Денис333337 13 сент. 2020 г., 17:12:06 | 10 - 11 классы

Помогите пожалуйста, я должна написать 6 лабораторных работ((?

Помогите пожалуйста, я должна написать 6 лабораторных работ((.

Написать программу на Паскале.

Дана матрица.

Вычислить среднее арифметическое четных элементов главной диагонали.

Karlikovasvetlana 9 дек. 2020 г., 08:01:38 | 10 - 11 классы

Составить программу на языке паскаль для вычисления количества положительных элементов в матрице В(8 * 8)?

Составить программу на языке паскаль для вычисления количества положительных элементов в матрице В(8 * 8).

SonnyLuchyu 15 нояб. 2020 г., 01:12:07 | 10 - 11 классы

Pascal?

Pascal.

Составить программу для вычисления количества положительных элементов матрицы Q(4х9).

Если вам необходимо получить ответ на вопрос Составить программу на языке паскаль задание : дана матрица А(N, N)?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.