Дана целочисленная матрица 5 на 5?

Информатика | 10 - 11 классы

Дана целочисленная матрица 5 на 5.

Определить положительные элементы на побочной диагонали.

(Паскаль).

Ответить на вопрос
Ответы (1)
Polevaya1105 14 окт. 2020 г., 12:10:56

Const n = 5 ; / / Размер матрицы

var i, e, r : Integer ; m : array [1.

N, 1.

N] of Integer ;

begin for i : = 1 to n do for e : = 1 to n do begin / / m[i, e] : = Random(101) - 50 ; / / Заполнение случайными числами Write('m[', i, ', ', e, '] = ') ; Readln(m[i, e]) ; / / Ручной ввод матрицы end ; r : = n ; for i : = 1 to n do begin if m[i, r] > ; = 0 then Write(m[i, r], ' ') ; dec(r) ; end ; Readln ;

end.

Snezhana250603 28 нояб. 2020 г., 02:59:38 | 5 - 9 классы

23. Дана действительная квадратная матрица порядка n?

23. Дана действительная квадратная матрица порядка n.

Выяснить, верно ли, что наибольшее из значений элементов главной диагонали больше, чем наименьшее из значений элементов побочной диагонали.

Irina03081958 16 нояб. 2020 г., 00:07:51 | 10 - 11 классы

Задача на c + + Дана целочисленная матрица?

Задача на c + + Дана целочисленная матрица.

Определить : А) номер первой из строк, содержащей хотя бы один положительный элемент Б) характеристику каждой строки матрицы.

Характеристикой строки матрицы называется сумма ее отрицательных элементов.

Kiryashonok1 1 июл. 2020 г., 00:45:12 | 10 - 11 классы

Дана целочисленная квадратная матрица?

Дана целочисленная квадратная матрица.

Найти число строк, сумма элементов которых равна сумме элементов главной диагонали данной матрицы.

Нужна на языке си.

IrishkaBetty 16 июн. 2020 г., 20:45:36 | 10 - 11 классы

Всем Привет?

Всем Привет!

1. В текстовом файле хранятся квадратные целочисленные матрицы порядка n.

Преобразовать файл, удалив из каждой матрицы элементы побочной диагонали.

Salvatore210 17 апр. 2020 г., 11:31:23 | 10 - 11 классы

Программирование C + + ?

Программирование C + + .

Дана целочисленная прямоугольная матрица.

Найти разность сумм элементов на главной и побочной диагоналях.

ПуФФысТиК19 23 окт. 2020 г., 11:48:40 | 10 - 11 классы

Дана целочисленная матрица 5 на 5 ?

Дана целочисленная матрица 5 на 5 .

Определить положительные элементы на побочной диагонали.

(В Паскале).

Zajchikova1986 2 апр. 2020 г., 15:05:57 | 10 - 11 классы

Дана квадратная матрица порядка N?

Дана квадратная матрица порядка N.

Найти произведение элементов побочных диагонали квадратной матрицы.

KarinaAksenova 16 мар. 2020 г., 23:26:59 | 10 - 11 классы

Написать программу на С + + ?

Написать программу на С + + .

Дана целочисленная квадратная матрица произвольной размерности.

Сформировать одномерный массив, в который поместить элементы двумерной матрицы, находящиеся над побочной диагонали ; упорядочить их по возрастанию и найти их среднее арифметическое.

Z2114 28 февр. 2020 г., 10:54:06 | 10 - 11 классы

1. Дана целочисленная матрица А(N, N)?

1. Дана целочисленная матрица А(N, N).

Определите, будет ли сумма всех элементов, расположенных выше главной диагонали при делении на три нечётным числом.

Babinababina 5 февр. 2020 г., 02:02:02 | 10 - 11 классы

4. Дана целочисленная матрица А(N, N)?

4. Дана целочисленная матрица А(N, N).

Определите, будет ли сумма всех элементов, расположенных ниже вспомогательной (побочной) диагонали при делении на два четным числом.

Если вам необходимо получить ответ на вопрос Дана целочисленная матрица 5 на 5?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.