Pascal?

Информатика | 10 - 11 классы

Pascal.

Паскаль.

Написать программу, которая меняет знак всех положительных элементов, расположенных в строке и столбце матрицы с максимальным элементом.

Ответить на вопрос
Ответы (1)
Nadya0684 23 дек. 2020 г., 10:22:03

Program gt ;

var a : array[1.

100, 1.

100]of integer ;

n, m, i, j, max, h, l : integer ;

begin

read(n, m) ;

max : = - maxint ;

for i : = 1 to n do

for j : = 1 to m do

begin

read(a[i, j]) ;

if(a[i, j]> ; max)then begin

max : = a[i, j] ;

h : = i ; l : = j ;

end ;

for j : = 1 to m do

a[h, j] : = - a[h, j] ;

for i : = 1 to n do

a[i, l] : = - a[i, l] ;

a[h, l] : = - a[h, l] ;

for i : = 1 to n do

begin

for j : = 1 to m do

write(a[i, j], ' ') ;

writeln ;

end ;

end.

Di4308 26 февр. 2020 г., 09:09:51 | 10 - 11 классы

Помогите написать программу на Паскале?

Помогите написать программу на Паскале.

В целочисленной матрице размером 10x10 найдите максимальное значение и индексы всех элементов, равных ему.

Sashaegorov05 19 мая 2020 г., 11:12:44 | 10 - 11 классы

Составить программу в PASCAL?

Составить программу в PASCAL.

Ввести размерность матрицы и значения ее элементов.

Определить максимальный и минимальный элемент.

Переставить их местами.

Найти среднее арифметическое отрицательных элементов в i - ой строке.

FroZen007 14 нояб. 2020 г., 19:08:11 | 10 - 11 классы

Напишите программу пожалуйста в паскалепроизведение элементов массива, расположенных между максимальным и минимальным элементами ?

Напишите программу пожалуйста в паскале

произведение элементов массива, расположенных между максимальным и минимальным элементами ;

Vikik123 2 апр. 2020 г., 08:19:27 | 10 - 11 классы

Напишите программу поиска минимального и максимального элементов матрицы?

Напишите программу поиска минимального и максимального элементов матрицы.

Программа должна менять максимальный и минимальный элементы между собой и выводить на экран исходную и преобразованную матрицы (Турбо Паскаль).

Aleksandrova01 14 февр. 2020 г., 23:57:03 | 10 - 11 классы

Составить программу в PASCAL?

Составить программу в PASCAL.

Ввести размерность матрицы и значения ее элементов.

Определить максимальный и минимальный элемент.

Переставить их местами.

Найти среднее арифметическое отрицательных элементов в i - ой строке.

Iwanrikowм 30 окт. 2020 г., 06:40:49 | 10 - 11 классы

Написать программу на паскале : определить количество строк матрицы, в которых хотя бы один элемент равен t?

Написать программу на паскале : определить количество строк матрицы, в которых хотя бы один элемент равен t.

Lob2004 10 янв. 2020 г., 04:47:43 | 10 - 11 классы

Написать программы в паскале : 1?

Написать программы в паскале : 1.

Найти среднее арифметическое положительных элементов.

2. Вычислить сумму элементов, расположенных после максимального элемента.

3. Найти произведение элементов, расположенных до минимального элемента.

4. Заменить все отрицательные элементы их моделями.

Так же надо использовать массив.

Yanabrizhasheva 2 июн. 2020 г., 22:39:42 | 10 - 11 классы

Паскаль написать программу которая для прямоугольной целочисленной матрицы 3×4 определяет номер самого левого столбца содержащего только положительные элементы?

Паскаль написать программу которая для прямоугольной целочисленной матрицы 3×4 определяет номер самого левого столбца содержащего только положительные элементы.

Если такого столбца нет выводится сообщение.

Marinasturova7 23 сент. 2020 г., 11:11:44 | 5 - 9 классы

Найти максимальный среди всех элементов тех строк заданной матрицы, которые упорядочены (либо по возрастанию, либо по убыванию)?

Найти максимальный среди всех элементов тех строк заданной матрицы, которые упорядочены (либо по возрастанию, либо по убыванию).

Составить программу в Pascal.

SonnyLuchyu 15 нояб. 2020 г., 01:12:07 | 10 - 11 классы

Pascal?

Pascal.

Составить программу для вычисления количества положительных элементов матрицы Q(4х9).

На этой странице находится вопрос Pascal?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.