Помогите пожалуйста, я должна написать 6 лабораторных работ((?

Информатика | 10 - 11 классы

Помогите пожалуйста, я должна написать 6 лабораторных работ((.

Написать программу на Паскале.

Дана матрица.

Вычислить среднее арифметическое четных элементов главной диагонали.

Ответить на вопрос
Ответы (1)
Rayahka 13 сент. 2020 г., 17:12:12

/ / PascalABC.

NET 3.

1, сборка 1230 от 27.

04. 2016

begin var n : = ReadInteger('n = ') ; var a : = MatrixRandom(n, n, 10, 99) ; var s : = 0 ; var k : = 0 ; for var i : = 0 to n - 1 do begin for var j : = 0 to n - 1 do Print(a[i, j]) ; Writeln ; if a[i, i].

IsEven then begin s + = a[i, i] ; Inc(k) end ; end ; if k> ; 0 then Writeln('S = ', s / k : 0 : 2) else Writeln('На главной диагонали нет четных элементов')

end.

Тестовое решение

n = 8

63 13 33 90 25 21 87 91

88 88 48 13 30 59 81 27

73 23 76 77 52 19 33 97

53 87 13 74 17 35 61 70

77 96 51 61 82 33 63 22

39 88 84 54 88 73 74 69

76 26 69 14 45 80 70 54

80 36 47 38 18 22 84 62

S = 75.

33.

Ivanivanov2014 24 нояб. 2020 г., 06:14:16 | 10 - 11 классы

Разработать паскаль - программу, вычисляющую среднее арифметическое элементов матрицы?

Разработать паскаль - программу, вычисляющую среднее арифметическое элементов матрицы.

Madina7182 23 мар. 2020 г., 19:46:19 | 10 - 11 классы

Составить программу на языке паскаль задание : дана матрица А(N, N)?

Составить программу на языке паскаль задание : дана матрица А(N, N).

Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали.

Lerusay 30 авг. 2020 г., 11:42:38 | 10 - 11 классы

Написать программу на ПАСКАЛЕ : Дана матрица А, имеющая N строк и N столбцов?

Написать программу на ПАСКАЛЕ : Дана матрица А, имеющая N строк и N столбцов.

Сформируйте два одномерных массива.

В один перешлите четные, а в другой - нечетные элементы матрицы.

Выведите на экран все массивы.

ИЛИ

написать программу на ПАСКАЛЕ : Вычислить произведение n!

До значения 1255534676756.

Пожалуйста решите какую сможете.

Alsunya91 17 июн. 2020 г., 06:45:17 | 10 - 11 классы

Помогите написать программу в pascal'e?

Помогите написать программу в pascal'e.

Если матрица квадратная, то поменять местами минимальный и максимальный элементы побочной диагонали.

В противном случае - заменить элементы четных строк нулями.

Apvapavpva00 1 мар. 2020 г., 05:47:45 | 10 - 11 классы

Очень срочно?

Очень срочно!

Нужна ваша помощь!

Написать программу на паскале : сформировать матрицу и найти наименьшее среди средних арифметических элементов ее столбцов.

( В ответе достаточно рабочего кода).

Ruslan15200 24 мар. 2020 г., 22:23:37 | 10 - 11 классы

Помогите пожалуйста, написать программу в паскале?

Помогите пожалуйста, написать программу в паскале!

Срочно!

Дана действительная матрица размера m x n.

Найти значение наибольшего по модулю элемента матрицы, а так же определить есть ли в матрице хотя бы один простой элемент.

Ntv1978 2 окт. 2020 г., 11:05:37 | 10 - 11 классы

Очень срочно?

Очень срочно!

Нужна ваша помощь!

Написать программу на паскале : сформировать матрицу и найти наименьшее среди средних арифметических элементов ее столбцов.

( В ответе достаточно рабочего кода).

KarinaAksenova 16 мар. 2020 г., 23:26:59 | 10 - 11 классы

Написать программу на С + + ?

Написать программу на С + + .

Дана целочисленная квадратная матрица произвольной размерности.

Сформировать одномерный массив, в который поместить элементы двумерной матрицы, находящиеся над побочной диагонали ; упорядочить их по возрастанию и найти их среднее арифметическое.

Ученик141100 27 апр. 2020 г., 14:31:32 | 5 - 9 классы

Дан массив из 5 элементов, найти среднее арифметическое всех элементов массива?

Дан массив из 5 элементов, найти среднее арифметическое всех элементов массива.

Выполнять на паскале.

Нужно написать программу самым легким способом.

IvanWein 14 сент. 2020 г., 17:25:44 | 10 - 11 классы

Написать программу для следующей задачи : в матрице А(8, 8) все отрицательные элементы, стоящие на главной диагонали и ниже нее, заменить нулями?

Написать программу для следующей задачи : в матрице А(8, 8) все отрицательные элементы, стоящие на главной диагонали и ниже нее, заменить нулями.

На этой странице сайта вы найдете ответы на вопрос Помогите пожалуйста, я должна написать 6 лабораторных работ((?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.