Решите, пожалуйста, задачу на Паскале?

Информатика | 10 - 11 классы

Решите, пожалуйста, задачу на Паскале.

Найти среднее арифметической каждой строки в двумерном массиве и скинуть в новый массив.

Ответить на вопрос
Ответы (1)
Slava2000smoan 26 окт. 2020 г., 12:21:15

Const n = 5 ;

var

a : array[1.

N, 1.

N] of integer ;

b : array[1.

N] of real ;

i, j, k : integer ;

begin / / считываем матрицу

for i : = 1 to n do for j : = 1 to n do readln(a[i, j]) ; / / находим среднее для каждой строки / / и заполняем ими массив b

for i : = 1 to n do begin k : = 0 ; for j : = 1 to n do k : = k + a[i, j] ; b[i] : = k / n ; end ; / / вывод массива b

for i : = 1 to n do

writeln(b[i]) ;

end.

Lera184567 21 февр. 2020 г., 13:53:50 | 10 - 11 классы

ТЕМА : ОБРАБОТКА ДВУМЕРНЫХ МАССИВОВ?

ТЕМА : ОБРАБОТКА ДВУМЕРНЫХ МАССИВОВ.

ПО ПАСКАЛЬ!

Задание : Дан двумерный массив А состоящий из 4 строк и 5 столбцов .

Найти, сколько положительных элементов содержит данная матрица в каждом столбце.

Ktibr260 23 янв. 2020 г., 21:05:46 | 5 - 9 классы

Помогите решить задачу : дан двумерный массив?

Помогите решить задачу : дан двумерный массив.

Найти среднее арифметическое четных элементов массива.

(Gambas)!

Marsovin 7 февр. 2020 г., 08:25:25 | 10 - 11 классы

Паскаль, составьте программу для двумерного массива : Найти произведение отрицательных элементов указанной строки двумерного массива размером 4 * 5 целых чисел?

Паскаль, составьте программу для двумерного массива : Найти произведение отрицательных элементов указанной строки двумерного массива размером 4 * 5 целых чисел.

Alina2003435 13 янв. 2020 г., 22:04:39 | 5 - 9 классы

Как в двумерном массиве найти среднее арифметическое однозначных элементов?

Как в двумерном массиве найти среднее арифметическое однозначных элементов.

Annagusakova1999 16 мая 2020 г., 16:59:46 | 10 - 11 классы

В двумерном массиве размерностью N * M, содержащем целые числа, найти среднее арифметическое минимальных элементов строк?

В двумерном массиве размерностью N * M, содержащем целые числа, найти среднее арифметическое минимальных элементов строк.

Mottter2002 15 окт. 2020 г., 22:25:17 | 10 - 11 классы

Дан массив 0из 6 элементов?

Дан массив 0из 6 элементов.

Найти среднее арифметического элементов этого массива.

В паскале.

Lizagacenko 27 окт. 2020 г., 19:57:22 | 10 - 11 классы

Помоги пожалуйста?

Помоги пожалуйста!

: * дан двумерный массив вывести на экран все элементы n - й строки массива паскаль.

Катеринка3585 11 июл. 2020 г., 02:16:45 | 5 - 9 классы

Найти среднее арифметическое отрицательных элементов массива в Паскале?

Найти среднее арифметическое отрицательных элементов массива в Паскале.

Распишите пожалуйста.

Катерина706 18 янв. 2020 г., 03:57:13 | 5 - 9 классы

Найдите сумму всех элементов двумерного массива и сумму элементов каждой строки?

Найдите сумму всех элементов двумерного массива и сумму элементов каждой строки.

(паскаль).

Jador1 26 сент. 2020 г., 10:03:20 | 10 - 11 классы

Двумерные массивы?

Двумерные массивы.

Дан двумерный массив чисел.

Первый нечетный элемент каждой строки удвоить (предполагается, что в каждой строке есть нечетный элемент).

Вы перешли к вопросу Решите, пожалуйста, задачу на Паскале?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.