В двумерном массиве размерностью N * M, содержащем целые числа, найти среднее арифметическое минимальных элементов строк?

Информатика | 10 - 11 классы

В двумерном массиве размерностью N * M, содержащем целые числа, найти среднее арифметическое минимальных элементов строк.

Ответить на вопрос
Ответы (1)
FanSpanchBob 16 мая 2020 г., 16:59:47

Uses crt ;

var i, j, min, n, m : integer ; s : real ;

a : array[1.

100, 1.

100] of integer ;

b : array[1.

100] of integer ;

begin

readln(n, m) ;

s : = 0 ;

for i : = 1 to n do begin

for j : = 1 to m do

a[i, j] : = random(25) + 1 ;

end ;

for i : = 1 to n do begin writeln ;

for j : = 1 to m do

write(a[i, j], ' ') ;

end ; writeln ; WriteLn('Ìèíèìàëüíûå ýëåìåíòû ñòðîê : ') ; for i : = 1 to n do begin min : = a[i, j] ; for j : = 2 to m do begin if min> ; a[i, j] then begin min : = a[i, j] ; end ; end ; s : = s + min ;

Write(min, ' ') ; end ; writeln('avg = ', (s / n) : 0 : 1) ;

end.

Nshinshina 29 июн. 2020 г., 05:29:08 | 10 - 11 классы

Определить минимальный элемент двумерного массива?

Определить минимальный элемент двумерного массива.

Напечатать номер строки, содержащей максимальное число минимальных элементов, если такие имеются ; ).

Sashaegorov05 19 мая 2020 г., 11:12:44 | 10 - 11 классы

Составить программу в PASCAL?

Составить программу в PASCAL.

Ввести размерность матрицы и значения ее элементов.

Определить максимальный и минимальный элемент.

Переставить их местами.

Найти среднее арифметическое отрицательных элементов в i - ой строке.

IlyaBro 31 авг. 2020 г., 11:07:49 | 10 - 11 классы

Даны два одномерных массива из целых чисел, разной размерности?

Даны два одномерных массива из целых чисел, разной размерности.

Найти целую часть среднего арифмитического элементов каждого массива и их сумму.

Gavrilovavaleri 21 июл. 2020 г., 23:14:23 | 10 - 11 классы

Дан двумерный массив сосстоящий из 4 строк и 5 стобцов и заполненный случайным образом целыми числами от 1 до 100?

Дан двумерный массив сосстоящий из 4 строк и 5 стобцов и заполненный случайным образом целыми числами от 1 до 100.

Найти разность максимального и минимального элемента массива.

Marsovin 7 февр. 2020 г., 08:25:25 | 10 - 11 классы

Паскаль, составьте программу для двумерного массива : Найти произведение отрицательных элементов указанной строки двумерного массива размером 4 * 5 целых чисел?

Паскаль, составьте программу для двумерного массива : Найти произведение отрицательных элементов указанной строки двумерного массива размером 4 * 5 целых чисел.

Alina2003435 13 янв. 2020 г., 22:04:39 | 5 - 9 классы

Как в двумерном массиве найти среднее арифметическое однозначных элементов?

Как в двумерном массиве найти среднее арифметическое однозначных элементов.

Aleksandrova01 14 февр. 2020 г., 23:57:03 | 10 - 11 классы

Составить программу в PASCAL?

Составить программу в PASCAL.

Ввести размерность матрицы и значения ее элементов.

Определить максимальный и минимальный элемент.

Переставить их местами.

Найти среднее арифметическое отрицательных элементов в i - ой строке.

In17021989 6 янв. 2020 г., 02:17:01 | 5 - 9 классы

Даны два одномерных массива из целых чисел разной размерности?

Даны два одномерных массива из целых чисел разной размерности.

Найти целую часть среднего арифметического элементов каждого массива и их сумму.

Помогите написать программу в паскале.

Turenko80 10 сент. 2020 г., 16:57:05 | 5 - 9 классы

Найти среднее арифметическое элементов целого массива кол - во элементов в массиве 8?

Найти среднее арифметическое элементов целого массива кол - во элементов в массиве 8.

Помогать1 6 нояб. 2020 г., 19:51:15 | 5 - 9 классы

Pascal 1?

Pascal 1.

Найти среднее арифметическое положительных элементов одномерного массива.

2. Найти минимальный элемент одномерного массива.

На странице вопроса В двумерном массиве размерностью N * M, содержащем целые числа, найти среднее арифметическое минимальных элементов строк? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.