Помогите решить задачу : дан двумерный массив?

Информатика | 5 - 9 классы

Помогите решить задачу : дан двумерный массив.

Найти среднее арифметическое четных элементов массива.

(Gambas)!

Ответить на вопрос
Ответы (1)
Pro100aleks89 23 янв. 2020 г., 21:05:48

Pascal

const N = 10 ;

var arr : array[1.

N] of integer ; i, k : byte ; sum : integer ; avr : real ;

begin writeln('Enter the ten elements of the array : ') ; for i : = 1 to N do read(arr[i]) ; sum : = 0 ; i : = 1 ; k : = 0 ; while i < ; = N do begin if (arr[i] mod 2) = 0 then begin sum : = sum + arr[i] ; k : = k + 1 end ; i : = i + 2 end ; writeln(sum) ; if k < ; > ; 0 then begin avr : = sum / k ; writeln(avr) end else writeln('No elements') ;

readln ;

end.

Lorik77 11 мая 2020 г., 06:31:08 | 10 - 11 классы

Написать двумерный массив?

Написать двумерный массив.

Найдите среднее арифметическое элементов массива заданных случайным образом [0.

20].

Alina2003435 13 янв. 2020 г., 22:04:39 | 5 - 9 классы

Как в двумерном массиве найти среднее арифметическое однозначных элементов?

Как в двумерном массиве найти среднее арифметическое однозначных элементов.

Mottter2002 15 окт. 2020 г., 22:25:17 | 10 - 11 классы

Дан массив 0из 6 элементов?

Дан массив 0из 6 элементов.

Найти среднее арифметического элементов этого массива.

В паскале.

Таантя 26 сент. 2020 г., 19:41:16 | 5 - 9 классы

1. Дан одномерный массив из N элементов?

1. Дан одномерный массив из N элементов.

Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2.

Дан одномерный массив из Н элементов.

Найти среднее арифметическое положительных четных элементов данного массива.

Tarik9696bkru 26 окт. 2020 г., 12:21:14 | 10 - 11 классы

Решите, пожалуйста, задачу на Паскале?

Решите, пожалуйста, задачу на Паскале.

Найти среднее арифметической каждой строки в двумерном массиве и скинуть в новый массив.

Qwefhnjhhv 19 мар. 2020 г., 06:19:08 | 10 - 11 классы

В одном массиве найти среднее арифметическое четных элементов стоящих на не нечетных местах ?

В одном массиве найти среднее арифметическое четных элементов стоящих на не нечетных местах .

Паскаль.

Jenya932 26 мая 2020 г., 12:10:21 | 10 - 11 классы

HELP?

HELP!

Дан двумерный массив(4 * 5) написать программу, которая определит кол - во четных элементов двумерного массива.

Заполонить с клавиатуры.

RiGa 17 февр. 2020 г., 15:40:45 | 5 - 9 классы

Дан массив из 15 чисел заполненный случайными числами из интервала [ - 20 ; 20]?

Дан массив из 15 чисел заполненный случайными числами из интервала [ - 20 ; 20].

Определить , что больше среднее арифметическое элементов стоящих на четных местах или среднее арифметическое положительных элементов массива.

Сладкая897 20 авг. 2020 г., 06:33:45 | 10 - 11 классы

Помогите пожалуйста решить задачи 1?

Помогите пожалуйста решить задачи 1.

Найти сумму элементов двумерного массива у которых номер строки не четный 2.

Вывести на экран элементы двумерного массива у которых n столбца нечетный.

Annst5inabald 14 дек. 2020 г., 23:08:46 | 10 - 11 классы

Помогите с информатикой 60 баллов?

Помогите с информатикой 60 баллов.

Двумерный массив.

Паскаль.

1) Дан двумерный массив размерностью 5 на 7.

Найти максимальный элемент массива.

2) Дан двумерный массив размерностью 5 на 7.

Найти произведение четных элементов.

На этой странице находится вопрос Помогите решить задачу : дан двумерный массив?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.