Дано натуральное число, подсчитать общее количество его делителей?

Информатика | 10 - 11 классы

Дано натуральное число, подсчитать общее количество его делителей.

Помогите пожалуйста.

Pascal.

Ответить на вопрос
Ответы (1)
Карасеввадим 5 июн. 2020 г., 23:48:46

Var n, i, number : integer ;

begin readln(n) ; number : = 1 ; {т.

К. само число является своим делителем} for i : = 1 to n div 2 do {т.

К. делителей больше половины чила ровно} begin {один, который мы уже учли} if n mod i = 0 then number : = number + 1 ; end ; writeln(number) ;

end.

Wowwic200 11 окт. 2020 г., 16:06:25 | 5 - 9 классы

Составить программу?

Составить программу.

Дано натуральное число n.

Подсчитать количество цифр этого числа.

8713 4 сент. 2020 г., 09:13:15 | 10 - 11 классы

Pascal Дано три целых числа?

Pascal Дано три целых числа.

Вывести на экран те, для которых число А будет делителем.

Срочно помогите.

Natali85271 13 апр. 2020 г., 04:29:03 | 10 - 11 классы

Pascal В заданном тексте подсчитайте общее количество букв "х" и "у"?

Pascal В заданном тексте подсчитайте общее количество букв "х" и "у".

Nastya132000 1 сент. 2020 г., 01:35:08 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить количество его нечетных делителей.

Написать программу паскаль).

Пустой 15 мар. 2020 г., 10:32:37 | 5 - 9 классы

Найти количество делителей натурального числа А, больших К?

Найти количество делителей натурального числа А, больших К.

(А и К вводятся с клавиатуры, K< ; = A).

Код должен быть написан на языке Паскаля (Pascal).

Kiborg113 9 авг. 2020 г., 01:39:35 | 5 - 9 классы

Найти количество делителей натурального числа?

Найти количество делителей натурального числа.

Сколько из них четных?

Решить в Turbo Pascal, без массивов.

Срочно, ПОЖАЛУЙСТА.

Denizqamzaeva 28 дек. 2020 г., 13:57:24 | 5 - 9 классы

Найти сумму делителей данного натурального числа?

Найти сумму делителей данного натурального числа.

Prishchepa 10 авг. 2020 г., 22:27:07 | 10 - 11 классы

3. Дано натуральное число?

3. Дано натуральное число.

Найти сумму его четных делителей и количество этих делителей.

Random73 12 февр. 2020 г., 02:06:22 | 10 - 11 классы

Плииииизз Составить программу с помощью процедуры?

Плииииизз Составить программу с помощью процедуры.

Дано число, найти все его делители и подсчитать их количество.

Timi 25 мар. 2020 г., 02:44:19 | 10 - 11 классы

Дано натуральное число N ?

Дано натуральное число N .

Определить наименьшую и наибольшую цифры данного числа (Pascal ABC).

На этой странице находится вопрос Дано натуральное число, подсчитать общее количество его делителей?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.