Найти сумму делителей данного натурального числа?

Информатика | 5 - 9 классы

Найти сумму делителей данного натурального числа.

Ответить на вопрос
Ответы (1)
3353378 28 дек. 2020 г., 13:57:27

#include < ; stdio.

H> ;

# define IN "input.

Txt"

# define OUT "output.

Txt"

unsigned long long sum(int n){

unsigned long long otv = 0 ;

for (int i = 1 ; i * i< ; = n ; i + + )

if (!

(n%i)){

otv + = i ;

if(i * i!

= n)otv + = n / i ; }

return otv ; }

int main(void){

unsigned long long n, otv = 0 ;

freopen(IN, "r", stdin) ;

freopen(OUT, "w", stdout) ;

scanf("%I64d", & ; n) ;

otv = sum(n) ;

printf("%I64d", otv) ;

return 0 ; }.

Neka200 9 авг. 2020 г., 08:35:35 | 10 - 11 классы

Дано натуральное четырехзначное число n?

Дано натуральное четырехзначное число n.

Найти сумму его цифр.

VOLAN97 27 июл. 2020 г., 16:21:50 | 5 - 9 классы

1)найти количесво делителей натурального числа, сколько из них чётных?

1)найти количесво делителей натурального числа, сколько из них чётных?

2) дано натуральное число : найти две первые цыфры числа верно ли, что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа, которые состоят из разных цыфр, а их сумма равна А(А вводится с клавиатуры) 4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры).

Drashchiker 21 февр. 2020 г., 23:43:56 | 5 - 9 классы

Дано натуральное число n?

Дано натуральное число n.

Найти сумму первой и последней цифры этого числа.

Demon160702 9 авг. 2020 г., 12:27:16 | 10 - 11 классы

Помогите пожалуйста с програмированием С + + ?

Помогите пожалуйста с програмированием С + + .

"в последовательности из N натуральных чисел, найти число с максимальной суммой делителей" и другая "в записи данного натурального числа N найти наибольшую и наименьшую цифры", решите хотя бы одну, пожалуйста!

Ром28 16 июн. 2020 г., 13:31:06 | 5 - 9 классы

Найти все делители натурального числа n?

Найти все делители натурального числа n.

Mur4ik313 23 июн. 2020 г., 08:38:00 | 5 - 9 классы

Дано натуральное число : а)получить все его делители б)найти сумму его делителей в)найти сумму его четных делителей г)определить количество его нечетных делителей е)определить количество его делителей?

Дано натуральное число : а)получить все его делители б)найти сумму его делителей в)найти сумму его четных делителей г)определить количество его нечетных делителей е)определить количество его делителей.

Сколько из них четных?

Ж)найти количество его делителей, больших d" На ТУРБО ПАСКАЛЕ СРОЧНО!

CamKo 22 мар. 2020 г., 10:05:22 | 5 - 9 классы

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа?

Составить программу на паскале Дано натуральное число, найти сумму цифр этого числа!

Ее19th 6 мая 2020 г., 19:20:42 | 5 - 9 классы

Найти все делители натурального числа N?

Найти все делители натурального числа N.

NATA2000000000 2 июл. 2020 г., 14:27:36 | 10 - 11 классы

Найти все делители натурального числа по возрастанию?

Найти все делители натурального числа по возрастанию.

Prishchepa 10 авг. 2020 г., 22:27:07 | 10 - 11 классы

3. Дано натуральное число?

3. Дано натуральное число.

Найти сумму его четных делителей и количество этих делителей.

Вы открыли страницу вопроса Найти сумму делителей данного натурального числа?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.