3. Дано натуральное число?

Информатика | 10 - 11 классы

3. Дано натуральное число.

Найти сумму его четных делителей и количество этих делителей.

Ответить на вопрос
Ответы (1)
KaTyA20052005 10 авг. 2020 г., 22:27:13

/ / Pascal ABC.

NET v3.

1 сборка 1172

Var

n, s, k, i : integer ;

begin

readln(n) ;

for i : = 1 to n do if (n mod i = 0) and (i mod 2 = 0) then begin inc(k) ; s : = s + i ; end ; writeln('s = ', s) ; write('k = ', k) ;

end.

Пример ввода :

22

Пример вывода :

s = 24

k = 2.

Nastya132000 1 сент. 2020 г., 01:35:08 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить количество его нечетных делителей.

Написать программу паскаль).

Ром28 16 июн. 2020 г., 13:31:06 | 5 - 9 классы

Найти все делители натурального числа n?

Найти все делители натурального числа n.

Mur4ik313 23 июн. 2020 г., 08:38:00 | 5 - 9 классы

Дано натуральное число : а)получить все его делители б)найти сумму его делителей в)найти сумму его четных делителей г)определить количество его нечетных делителей е)определить количество его делителей?

Дано натуральное число : а)получить все его делители б)найти сумму его делителей в)найти сумму его четных делителей г)определить количество его нечетных делителей е)определить количество его делителей.

Сколько из них четных?

Ж)найти количество его делителей, больших d" На ТУРБО ПАСКАЛЕ СРОЧНО!

Kiborg113 9 авг. 2020 г., 01:39:35 | 5 - 9 классы

Найти количество делителей натурального числа?

Найти количество делителей натурального числа.

Сколько из них четных?

Решить в Turbo Pascal, без массивов.

Срочно, ПОЖАЛУЙСТА.

Нежданка 5 июн. 2020 г., 23:48:41 | 10 - 11 классы

Дано натуральное число, подсчитать общее количество его делителей?

Дано натуральное число, подсчитать общее количество его делителей.

Помогите пожалуйста.

Pascal.

Ее19th 6 мая 2020 г., 19:20:42 | 5 - 9 классы

Найти все делители натурального числа N?

Найти все делители натурального числа N.

Denizqamzaeva 28 дек. 2020 г., 13:57:24 | 5 - 9 классы

Найти сумму делителей данного натурального числа?

Найти сумму делителей данного натурального числа.

NATA2000000000 2 июл. 2020 г., 14:27:36 | 10 - 11 классы

Найти все делители натурального числа по возрастанию?

Найти все делители натурального числа по возрастанию.

Skallid 6 февр. 2020 г., 10:06:12 | 10 - 11 классы

Для натурального числа необходимо найти максимальное натуральное число, большее 1, не превосходящее , имеющее минимальное количество делителей?

Для натурального числа необходимо найти максимальное натуральное число, большее 1, не превосходящее , имеющее минимальное количество делителей.

Для N = 201220151 таким числом будет ….

Aizhana030989 17 дек. 2020 г., 08:33:54 | 10 - 11 классы

Составить программу для решения следующей задачи : дано натуральное число n найти все его натуральные делители n = 5 делители 1, 5 n = 6 делители 1 2 3 6?

Составить программу для решения следующей задачи : дано натуральное число n найти все его натуральные делители n = 5 делители 1, 5 n = 6 делители 1 2 3 6.

Вы находитесь на странице вопроса 3. Дано натуральное число? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.