Pascal?

Информатика | 10 - 11 классы

Pascal.

1. Определить количество слов в предложении.

2. Определить какая буква в строке встречается чаще : первая или последняя.

3. Написать программу меняющую слово "Петр" на "Иван".

Ответить на вопрос
Ответы (1)
Erendeeva55 22 июл. 2020 г., 03:16:07

Для подсчёта слов в предложении, вот код :

program Slova ;

var

s : string ;

r, i : integer ;

begin

writeln('Введите ваше предложение') ;

readln(s) ;

s : = s + ' ' ;

for i : = 1 to length(s) - 1 do

if (s< ; > ; ' ') and (s[i + 1] = ' ') then

r : = r + 1 ;

writeln('В предложении ', r, ' слов.

') ;

readln ;

end.

Какая буква встречается чаще

Program Bykv ;

Var s : String ; i, k1, k2 : byte ;

Begin write('Введите строку : ') ; readln(s) ; For i : = 2 to Length(s) - 1 do if s[i] = s[1] then inc(k1) else if s[i] = s[Length(s)] then inc(k2) ; writeln('Первая буква встречается ', k1) ; writeln('Последняя буква встречается ', k2) ; writeln('Вывод : ') ; if k1> ; k2 then writeln('Первая буква встречается чаще') else if k1< ; k2 then writeln('Последняя буква чаще') else writeln('Одинаково') ; readln ;

End.

Изменить слово петя на иван в строке

program test ;

var s, t, z, p : string ; j : integer ;

begin

writeln('Введите ваше предложение') ;

readln(s) ;

write('Введите слово которое хотите заменить : ') ;

readln(t) ;

write('Введите замену слову : ', t, ' < ; > ; ') ;

readln(z) ;

if pos(t, s)< ; > ; 0 then

j : = pos(t, s) ;

p : = copy(s, 1, j - 1) ;

p : = p + z ;

p : = p + copy(s, j + length(t), length(s)) ;

writeln(p) ;

readln ;

end.

Kksseennia 9 февр. 2020 г., 10:36:32 | 5 - 9 классы

Напишите программу для вывода на экран последовательности символов : ABBCCCDDDD…ZZZZZZZZZZZZZZZZZZZZZZZZZZ Напишите программу, которая выводит «Да», если буква «а» встречается в тексте чаще, чем буква?

Напишите программу для вывода на экран последовательности символов : ABBCCCDDDD…ZZZZZZZZZZZZZZZZZZZZZZZZZZ Напишите программу, которая выводит «Да», если буква «а» встречается в тексте чаще, чем буква «о», и «Нет» в обратном случае.

Поменяйте местами k первых и k последних символов строки.

Удвойте вхождение буквы в текст.

Например, если пользователь ввёл текст «мама мыла раму» и выбрал для удвоения букву «м», то после работы программы должно быть выведено на экран сообщение «ммамма ммыла рамму» Проверьте написанный текст на правильность написания сочетаний «жи», «ши».

Если слова написаны с ошибкой – исправьте их.

Удалите в каждом слове предложения первую и последнюю букву.

Hazeevar79 20 дек. 2020 г., 12:41:51 | 10 - 11 классы

С клавиатуры вводится строка?

С клавиатуры вводится строка.

С новой строки вводится буква.

Составьте программу подсчета количества заданных букв в заданной строке.

Определить, является ли длина введенного слова числом, кратным трем.

Определить, заканчивается ли введенное слово гласной буквой.

Annapushkina 7 сент. 2020 г., 00:09:24 | 10 - 11 классы

ПОМОГИТЕ ПОЖАЛУЙСТА?

ПОМОГИТЕ ПОЖАЛУЙСТА!

PASCAL !

1. Составьте программу, вычисляющую, сколько букв надо исправить в слове Х, чтобы получилось слово Y (слова X и Y одинаковой длины).

2. Составьте программу, определения номера первой буквы "а" в слове Х.

3. Составьте программу, позволяющую выяснить, первая или последняя буква слова встречается в слове Х чаще.

Lpozharova 26 дек. 2020 г., 08:32:05 | 5 - 9 классы

Плиииз?

Плиииз!

Люди решите!

Напишите программу определяющую какая из букв первая или последняя встречаются в заданном слове чаще.

Alekseeva20044 19 нояб. 2020 г., 21:52:38 | 10 - 11 классы

Программа в Pascal 1?

Программа в Pascal 1.

Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м.

2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о.

Джувия5Локсар 20 июл. 2020 г., 11:06:48 | 5 - 9 классы

1. Даны две строки?

1. Даны две строки.

Написать программу для вывода на экран слова полученного из суммы двух первых букв каждой строки.

2. Дана строка.

Определить есть ли в данной строке буква h.

Massimka 26 авг. 2020 г., 14:18:08 | 10 - 11 классы

Определить сколько слов в заданной строке начинаются на букву "а"?

Определить сколько слов в заданной строке начинаются на букву "а".

Pascal.

87786095109 2 дек. 2020 г., 00:42:45 | 10 - 11 классы

Помогите написать программу в pascal?

Помогите написать программу в pascal.

Дан набор слов, разделенных точкой с запятой ( ; ).

Набор заканчивается двоеточием ( : ).

Определить, сколько в нем слов, заканчивающихся буквой а.

Teler 24 сент. 2020 г., 18:55:48 | 5 - 9 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

Написать программу.

Вводится предложение, определить количество слов в нем.

Sesnation 19 авг. 2020 г., 09:04:03 | 5 - 9 классы

Дано предложение - строка?

Дано предложение - строка.

Подсчитать количество слов, начинающихся с буквы 'а' написать программу на паскале.

Вопрос Pascal?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.