1)Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом?

Информатика | 5 - 9 классы

1)Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом.

2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).

Ответить на вопрос
Ответы (1)
Mendel 22 мая 2020 г., 18:32:35

1. var a, tmp : integer ;

var b : boolean ;

begin

b : = false ;

readln(a) ;

tmp : = a mod 10 ; a : = a div 10 ;

while a > ; 0 do

begin if tmp = a mod 10 then b : = true else tmp : = a mod 10 ; a : = a div 10 ;

end ;

writeln(b) ;

end.

2. var a, i : integer ;

var t : array[0.

9] of integer ;

var b : boolean ;

begin

b : = false ;

readln(a) ;

while a > ; 0 do

begin inc(t[a mod 10]) ; a : = a div 10 ;

end ;

for i : = 0 to 9 do if t[i] > ; 1 then b : = true ;

writeln(b) ;

end.

Opsdas 15 июн. 2020 г., 23:25:08 | 10 - 11 классы

Ввести целое число и определить верно ли что в его записи есть две одинаковые цифры стоящие рядом?

Ввести целое число и определить верно ли что в его записи есть две одинаковые цифры стоящие рядом.

Написать программу в Паскале без массивов.

Pgg 8 апр. 2020 г., 21:18:27 | 10 - 11 классы

Напишите программу , которая определяет , верно ли , что введенное число содержит две одинаковые цифры , стоящие рядом?

Напишите программу , которая определяет , верно ли , что введенное число содержит две одинаковые цифры , стоящие рядом.

Adelisamolkova 1 февр. 2020 г., 17:37:02 | 10 - 11 классы

В Паскале?

В Паскале!

Ввести целое число и найти сумму его цифр 1) Ввести целое Число - 1234 - Сумма цифр числа равна 10 2) Ввести целое число и определить, верно ли, что в его записи есть 2 одинаковые цифры.

Пример.

Введите целое число - 1234 - НЕТ 1224 - ДА.

Помогите пожалуйста!

))).

Zdance 8 июн. 2020 г., 08:11:47 | 10 - 11 классы

Ввести целое число и определить верно ли что все его цифры расположены в порядке возрастания?

Ввести целое число и определить верно ли что все его цифры расположены в порядке возрастания.

Romasolousov 2 февр. 2020 г., 16:57:30 | 10 - 11 классы

Ввести натуральное число N (не больше 2147483647)?

Ввести натуральное число N (не больше 2147483647).

Определить сколько в нем знаков, вычислить сумму цифр числа и определить старшую цифру числа СРОЧНО НАДО!

Kcy81 12 июл. 2020 г., 17:04:03 | 5 - 9 классы

Ввести целое число и определить, верно ли, что все его цифры четные?

Ввести целое число и определить, верно ли, что все его цифры четные.

(Кумир).

Gosha8 2 окт. 2020 г., 01:37:03 | 10 - 11 классы

Всем привет?

Всем привет!

Помогите пожалуйста по информатике.

Задача : ввести целое число и найти сумму его цифр.

Пример : введите целое число : 1234.

Сумма цифр числа 1234 равна 10.

Задача : сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры.

Пример : введите целое число 1234 нет введите целое число 1224 да.

Zver966 6 июн. 2020 г., 18:22:58 | 10 - 11 классы

Дано натуральное число N?

Дано натуральное число N.

Определить, верно ли, что это число содержит ровно три одинаковые цифры.

Решите алгоритмом.

Perfiliewa1 1 мая 2020 г., 00:22:48 | 5 - 9 классы

Уровень C?

Уровень C.

Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).

Serjana 9 окт. 2020 г., 05:42:28 | 10 - 11 классы

Уровень B?

Уровень B.

Задача M.

Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 5221 выходные данные YES входные данные 1232 выходные данные NO

Уровень C.

Задача O.

Две одинаковые цифры Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом (как, например, 212).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 212 выходные данные YES входные данные 12345 выходные данные NO.

На этой странице находится вопрос 1)Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.