Ввести целое число и определить верно ли что все его цифры расположены в порядке возрастания?

Информатика | 10 - 11 классы

Ввести целое число и определить верно ли что все его цифры расположены в порядке возрастания.

Ответить на вопрос
Ответы (1)
Оличкамимими 8 июн. 2020 г., 08:11:50

Uses crt ;

const n = 8 ;

var a : integer ;

b : array[1.

N] of integer ;

i, k, t : integer ;

begin

readln(a) ;

k : = 1 ;

repeat

for i : = k to k do

b[i] : = a mod 10 ;

a : = a div 10 ;

inc(k) ;

until a = 0 ;

t : = 0 ;

for i : = k - 1 downto 2 do

if (b[i]> ; b[i - 1]) then inc(t) ;

if t = 0 then writeln('yes') else writeln('no') ;

end.

Katygita 25 окт. 2020 г., 05:47:15 | 10 - 11 классы

Задача в паскале?

Задача в паскале.

Ввести натуральное число N.

Проверить, расположены ли его цифры в порядке неубывания.

Решить НЕ ЧЕРЕЗ МАССИВ.

(циклами).

Tu02 19 мая 2020 г., 09:46:33 | 5 - 9 классы

Ввести с клавиатуры двузначное число и цифру?

Ввести с клавиатуры двузначное число и цифру.

Определить, есть ли данная цифра в этом числе.

Opsdas 15 июн. 2020 г., 23:25:08 | 10 - 11 классы

Ввести целое число и определить верно ли что в его записи есть две одинаковые цифры стоящие рядом?

Ввести целое число и определить верно ли что в его записи есть две одинаковые цифры стоящие рядом.

Написать программу в Паскале без массивов.

Adelisamolkova 1 февр. 2020 г., 17:37:02 | 10 - 11 классы

В Паскале?

В Паскале!

Ввести целое число и найти сумму его цифр 1) Ввести целое Число - 1234 - Сумма цифр числа равна 10 2) Ввести целое число и определить, верно ли, что в его записи есть 2 одинаковые цифры.

Пример.

Введите целое число - 1234 - НЕТ 1224 - ДА.

Помогите пожалуйста!

))).

Kcy81 12 июл. 2020 г., 17:04:03 | 5 - 9 классы

Ввести целое число и определить, верно ли, что все его цифры четные?

Ввести целое число и определить, верно ли, что все его цифры четные.

(Кумир).

Gosha8 2 окт. 2020 г., 01:37:03 | 10 - 11 классы

Всем привет?

Всем привет!

Помогите пожалуйста по информатике.

Задача : ввести целое число и найти сумму его цифр.

Пример : введите целое число : 1234.

Сумма цифр числа 1234 равна 10.

Задача : сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры.

Пример : введите целое число 1234 нет введите целое число 1224 да.

Minikotik12367 22 мая 2020 г., 18:32:33 | 5 - 9 классы

1)Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом?

1)Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом.

2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).

Наташа230697 3 нояб. 2020 г., 14:11:35 | 5 - 9 классы

ВВЕСТИ ДВУЗНАЧНОЕ ЧИСЛО ПОЛУЧИТЬ ЧИСЛО ЗАПИСАННОЕ ТЕМИ ЖЕ ЦИФРАМИ В ОБРАТНОМ ПОРЯДКЕ?

ВВЕСТИ ДВУЗНАЧНОЕ ЧИСЛО ПОЛУЧИТЬ ЧИСЛО ЗАПИСАННОЕ ТЕМИ ЖЕ ЦИФРАМИ В ОБРАТНОМ ПОРЯДКЕ.

Verafaith 3 июл. 2020 г., 09:56:42 | 10 - 11 классы

Расположите числа в порядке возрастания 748, 1100102, 7210, 3716?

Расположите числа в порядке возрастания 748, 1100102, 7210, 3716?

Perfiliewa1 1 мая 2020 г., 00:22:48 | 5 - 9 классы

Уровень C?

Уровень C.

Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).

Перед вами страница с вопросом Ввести целое число и определить верно ли что все его цифры расположены в порядке возрастания?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.