Уровень C?

Информатика | 5 - 9 классы

Уровень C.

Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).

Ответить на вопрос
Ответы (1)
Marinak1979 1 мая 2020 г., 00:22:54

Есть много разных способов решения этой задачи.

Например :

var n : integer ; b : boolean ; m : set of 0.

9 ;

begin

write('n = ') ; readln(n) ;

m : = [] ;

b : = false ;

while (n> ; 0) and not bdo

if n mod 10 in m then b : = true else begin m : = m + [n mod 10] ; n : = n div 10 ; end ;

if bthen writeln('В записи введенного числа есть одинаковые цифры') else writeln('В записи введенного числа нет одинаковых цифр') ;

end.

Пример :

n = 123432

В записи введенного числа есть одинаковые цифры.

Opsdas 15 июн. 2020 г., 23:25:08 | 10 - 11 классы

Ввести целое число и определить верно ли что в его записи есть две одинаковые цифры стоящие рядом?

Ввести целое число и определить верно ли что в его записи есть две одинаковые цифры стоящие рядом.

Написать программу в Паскале без массивов.

Pgg 8 апр. 2020 г., 21:18:27 | 10 - 11 классы

Напишите программу , которая определяет , верно ли , что введенное число содержит две одинаковые цифры , стоящие рядом?

Напишите программу , которая определяет , верно ли , что введенное число содержит две одинаковые цифры , стоящие рядом.

Adelisamolkova 1 февр. 2020 г., 17:37:02 | 10 - 11 классы

В Паскале?

В Паскале!

Ввести целое число и найти сумму его цифр 1) Ввести целое Число - 1234 - Сумма цифр числа равна 10 2) Ввести целое число и определить, верно ли, что в его записи есть 2 одинаковые цифры.

Пример.

Введите целое число - 1234 - НЕТ 1224 - ДА.

Помогите пожалуйста!

))).

Anatoliy2002 10 окт. 2020 г., 19:23:55 | 5 - 9 классы

Вывести целое число и определить верно ли, что в его записи есть две одинаковые цифры?

Вывести целое число и определить верно ли, что в его записи есть две одинаковые цифры.

Например, 1234 - нет ; 1224 - да.

Обязательно должен присутствовать цикл с предусловием while < ; условие> ; do.

Информатика.

8 класс.

Паскаль ABC.

Zdance 8 июн. 2020 г., 08:11:47 | 10 - 11 классы

Ввести целое число и определить верно ли что все его цифры расположены в порядке возрастания?

Ввести целое число и определить верно ли что все его цифры расположены в порядке возрастания.

Kcy81 12 июл. 2020 г., 17:04:03 | 5 - 9 классы

Ввести целое число и определить, верно ли, что все его цифры четные?

Ввести целое число и определить, верно ли, что все его цифры четные.

(Кумир).

Gosha8 2 окт. 2020 г., 01:37:03 | 10 - 11 классы

Всем привет?

Всем привет!

Помогите пожалуйста по информатике.

Задача : ввести целое число и найти сумму его цифр.

Пример : введите целое число : 1234.

Сумма цифр числа 1234 равна 10.

Задача : сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры.

Пример : введите целое число 1234 нет введите целое число 1224 да.

Minikotik12367 22 мая 2020 г., 18:32:33 | 5 - 9 классы

1)Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом?

1)Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом.

2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).

Zver966 6 июн. 2020 г., 18:22:58 | 10 - 11 классы

Дано натуральное число N?

Дано натуральное число N.

Определить, верно ли, что это число содержит ровно три одинаковые цифры.

Решите алгоритмом.

Serjana 9 окт. 2020 г., 05:42:28 | 10 - 11 классы

Уровень B?

Уровень B.

Задача M.

Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 5221 выходные данные YES входные данные 1232 выходные данные NO

Уровень C.

Задача O.

Две одинаковые цифры Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом (как, например, 212).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 212 выходные данные YES входные данные 12345 выходные данные NO.

На странице вопроса Уровень C? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.