Уровень B?

Информатика | 10 - 11 классы

Уровень B.

Задача M.

Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 5221 выходные данные YES входные данные 1232 выходные данные NO

Уровень C.

Задача O.

Две одинаковые цифры Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом (как, например, 212).

Входные данные Входная строка содержит одно натуральное число.

Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, и слово 'NO', если такой пары цифр нет.

Примеры входные данные 212 выходные данные YES входные данные 12345 выходные данные NO.

Ответить на вопрос
Ответы (1)
Irina20020410 9 окт. 2020 г., 05:42:35

Program n1 ;

var a, b, c, s : longint ;

begin read(c) ; repeat a : = c mod 10 ; c : = c div 10 ; s : = c ; while s > 0 do begin b : = s mod 10 ; s : = s div 10 ; if (a = b) then begin writeln('yes') ; a : = 77 ; break ; end ; end ; if (a = 77) then break until (c = 0) ; if (a 77) then writeln('no') ;

end.

Nastyaepta 10 нояб. 2020 г., 01:33:15 | 10 - 11 классы

Напишите программу, которая вводит натуральное число N и определяет его факториал, то есть произведение натуральных чисел от 1 до N : N ?

Напишите программу, которая вводит натуральное число N и определяет его факториал, то есть произведение натуральных чисел от 1 до N : N !

= 1·2·{.

}· N .

Входные данные Входная строка содержит одно натуральное число N .

Выходные данные Программа должна вывести одно число – факториал введённого числа N .

Ddannya 10 дек. 2020 г., 10:29:38 | 5 - 9 классы

Дано трёхзначное число?

Дано трёхзначное число.

Напишите программу, которая определяет : есть ли среди цифр заданного целого трёхзначного числа одинаковые ; Пример входных данных : 123 121 122 Пример выходных данных : Нет Да Да.

Целуйкиса 2 авг. 2020 г., 12:14:05 | 5 - 9 классы

Напишите программу, которая строит "линию" из знаков ' - ' заданной длины?

Напишите программу, которая строит "линию" из знаков ' - ' заданной длины.

Используйте процедуру.

Входные данные Входная строка содержит единственное натуральное число – длину линии N .

Выходные данные Программа должна вывести N знаков ' - '.

ПРОГРАММА - PYTHON !

Только PYTHON !

Range1337 26 янв. 2020 г., 08:19:22 | 5 - 9 классы

Напишите программу на Python Даны два четырехзначных числа А и В?

Напишите программу на Python Даны два четырехзначных числа А и В.

Выведите в порядке возрастания все четырехзначные числа в интервале от А до В, запись которых содержит ровно три одинаковые цифры Входные данные - 1900 ; 2100 Выходные данные - 1911 ; 1999 ; 2000 ; 2022.

Balashovamarin 2 июл. 2020 г., 18:04:30 | 5 - 9 классы

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное?

Напишите программу, которая определяет, верно ли, что введённое число - – трёхзначное.

Входные данные : Входная строка содержит единственное натуральное число.

Выходные данные : Если введённое число – трёхзначное, нужно вывести ответ YES, если нет, то вывести ответ NO.

Анютка355 21 янв. 2020 г., 02:55:58 | 10 - 11 классы

Входные данные Входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x - координата, затем – y - координата)?

Входные данные Входная строка содержит два вещественных числа – координаты точки на плоскости (сначала x - координата, затем – y - координата).

Выходные данные Программа должна вывести слово 'YES', если точка попала в заштрихованную область, и слово 'NO', если не попала.

ЛизаПоняша 25 дек. 2020 г., 09:24:13 | 10 - 11 классы

Напишите программу, которая возводит натуральное число A в натуральную степень B ?

Напишите программу, которая возводит натуральное число A в натуральную степень B .

Входные данные

Входная строка содержит два числа, A и B , разделённые пробелом.

Гарантируется, что 1 ≤ A , B ≤ 1000 .

Выходные данные

Программа должна вывести одно число : A в степени B .

Примеры

входные данные

2 6

выходные данные

64.

Паскаль ABC 1.

8.

Маша133 31 окт. 2020 г., 06:11:15 | 10 - 11 классы

Напишите программу, которая удаляет из строки все повторяющиеся символы?

Напишите программу, которая удаляет из строки все повторяющиеся символы.

Входные данные

На вход программы подаётся строка, содержащая символы таблицы ASCII.

Выходные данные

Программа должна вывести исходную строку, из которой удалены все повторяющиеся символы.

Примеры

входные данные

abc13a1b2z3c

выходные данные

abc132z

входные данные

QWasd123

выходные данные

QWasd123

Pascal ABC 1.

8.

Akolesova2002 30 нояб. 2020 г., 01:46:11 | 5 - 9 классы

Дано натуральное число N?

Дано натуральное число N.

Напишите функцию (Pascal), вычисляющую сумму цифр числа N.

Входные данные

Задано единственное число N

Выходные данные

Необходимо вывести сумму цифр числа N.

Примеры

входные данные

12

выходные данные

3

ПРОГРАММА БЫЛА, НО ВВОДИЛ 12 И ВЫВОДИЛ ВМЕСТО 3, 0.

Jamilya456 27 дек. 2020 г., 04:26:34 | 10 - 11 классы

Натуральное число называется автоморфным , если оно равно последним цифрам своего квадрата?

Натуральное число называется автоморфным , если оно равно последним цифрам своего квадрата.

Например, 25 ^ 2 = 625 .

Напишите программу, которая находит все автоморфные числа на отрезке [ a , b ] .

Входные данные

Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами.

Гарантируется, что a ≤ b .

Выходные данные

Программа должна вывести в одну строчку все автоморфные числа на отрезке [ a , b ] , разделив их пробелами.

Если таких чисел нет, программа должна вывести число - 1.

Примеры

входные данные

20 100

выходные данные

25 76

На паскале, через циклы, пожалуйста.

Вопрос Уровень B?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.