ПОМОГИТЕ ПОЖАЛУЙСТА?

Информатика | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТА!

ОЧЕНЬ НУЖНО!

Дана строка.

Строка состоит из слов, разделенных пробелами.

Требуется : 1) Выделить из строки и напечатать слова : а)не содержащие цифры 0 - 3.

Б) слова, оканчивающиеся на "Я".

Ответить на вопрос
Ответы (1)
Daniillaskin 1 июн. 2020 г., 18:10:11

Const bd = ['0'.

'3'] ;

var s, wa, wb, w : string ; c : char ; i, n : integer ; bad_a : boolean ;

begin WriteLn('Вводите фразу, разделяя слова ровно одним пробелом') ; Read(s) ; s : = s + ' ' ; n : = Length(s) ; wa : = '' ; wb : = '' ; i : = 1 ; bad_a : = false ; w : = '' ; while i< ; = n do begin repeat c : = s[i] ; if c< ; > ; ' ' then begin bad_a : = bad_a or (c in bd) ; w : = w + c ; Inc(i) end else begin if not bad_a then wa : = wa + ' ' + w ; if s[i - 1] = 'Я' then wb : = wb + ' ' + w ; w : = '' ; bad_a : = false end until c = ' ' ; Inc(i) ; end ; wa : = Copy(wa, 2, Length(wa) - 1) ; wb : = Copy(wb, 2, Length(wb) - 1) ; Writeln(wa) ; Writeln(wb)

end.

Ваня147 14 дек. 2020 г., 12:30:36 | 5 - 9 классы

Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими)?

Дана строка, состоящая из русских слов, разделенных пробелами (одним или несколькими).

Вывести строку, содержащую эти же слова (разделенные одним пробелом), но расположенные в обратном порядке.

Help me!

Kiri4ka2101 25 февр. 2020 г., 02:39:32 | 10 - 11 классы

Дан текст в виде строки?

Дан текст в виде строки.

Слова в строке разделены несколькими пробелами.

Требуется удалить лишние пробелы, оставив только по одному между словами.

Marinapavlova21 30 авг. 2020 г., 08:23:36 | 5 - 9 классы

Дана строка, содержащая, по крайней мере, один символ пробела?

Дана строка, содержащая, по крайней мере, один символ пробела.

Вывести подстроку, расположенную между первым и последним пробелом исходной строки.

Если строка содержит только один пробел, то вывести пустую строку после пробела.

Kulikovacelina 13 дек. 2020 г., 07:54:35 | 10 - 11 классы

Паскаль?

Паскаль.

Дана строка, содержащая слова, разделенные одним пробелом.

Напечатать все слова, предварительно преобразовав каждое из них по следующему правилу : удалить из слова все последующие вхождения первой буквы.

Christinka1708 13 дек. 2020 г., 07:14:07 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста!

) Напечатать программу в паскале.

Пожалуйста.

Срочно.

Завтра крайний срок сдачи.

Помогите.

Дан массив строк без пробелов.

Напечатать строки, вторая половина которых не содержит цифры.

Kras22 17 янв. 2020 г., 12:55:20 | 10 - 11 классы

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом?

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом.

Написать программу меняющую части строки до и после пробела местами и добавляющую в конец строки восклицательный знак.

Решить в паскале.

Аза21 28 окт. 2020 г., 02:21:51 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста.

Напечатать программу в паскале.

Срочно.

Завтра последний срок сдачи.

Дан массив строк без пробелов.

Напечатать строки, вторая половина которых не содержит цифры.

Obuhancova 29 янв. 2020 г., 13:51:14 | 10 - 11 классы

Дана символьная строка, содержащая русские буквы, цифры и пробелы?

Дана символьная строка, содержащая русские буквы, цифры и пробелы.

Написать строку задом наперед, удалив из нее все цифры и пробелы.

СинийШар 15 янв. 2020 г., 00:09:44 | 10 - 11 классы

Составьте программу которая находит позицию пробела в строке s состоящей из двух слов разделенных пробелом?

Составьте программу которая находит позицию пробела в строке s состоящей из двух слов разделенных пробелом.

Строка вводится с клавиатуры.

Kiti2259 24 июн. 2020 г., 06:59:43 | 10 - 11 классы

Дана строка слова в которой разделены пробелом, подсчитайте количество слов в этой строке?

Дана строка слова в которой разделены пробелом, подсчитайте количество слов в этой строке.

На этой странице находится вопрос ПОМОГИТЕ ПОЖАЛУЙСТА?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.