Помогите пожалуйста?

Информатика | 10 - 11 классы

Помогите пожалуйста.

Напечатать программу в паскале.

Срочно.

Завтра последний срок сдачи.

Дан массив строк без пробелов.

Напечатать строки, вторая половина которых не содержит цифры.

Ответить на вопрос
Ответы (1)
Hastya15 28 окт. 2020 г., 02:21:55

Program Strok ;

uses crt ;

const number = ['0', '1', '2', '3', '4', '5', '6', '7', '8', '9'] ;

var A : array[1.

10] of string ;

i, j, k : integer ;

s : string ;

begin

{Ввод элементов массива}

for i : = 1 to 10 do

begin

write('Введите ', i, ' элемент массива : ') ;

readln(a[i])

end ;

{проверка условий}

for i : = 1 to 10 do {перебираем элементы массива}

begin

k : = 0 ; {задаем триггер}

s : = a[i] ;

for j : = length(s) div 2 + 1 to length(s) do

if s[j] in number then k : = 1 ; {Pascal позволяет обращаться со строковыми переменными, как с массивами символов, проверяем строку со второй половины на "вшивость", и, если встретилась цифра, вызываем срабатывание тригера}

if k = 0 then writeln(s)

end ;

readln end.

Marinapavlova21 30 авг. 2020 г., 08:23:36 | 5 - 9 классы

Дана строка, содержащая, по крайней мере, один символ пробела?

Дана строка, содержащая, по крайней мере, один символ пробела.

Вывести подстроку, расположенную между первым и последним пробелом исходной строки.

Если строка содержит только один пробел, то вывести пустую строку после пробела.

Dimamakarenkorus 23 июл. 2020 г., 01:13:36 | 10 - 11 классы

Напишите программу, которая подсчитывает сумму всех цифр в данной строке?

Напишите программу, которая подсчитывает сумму всех цифр в данной строке.

Например, в строке "Sochi - 2014" сумма цифр равна 7.

Формат входных данных

Одна строка, возможно с пробелами, буквами, цифрами и спецсимволами.

Формат результата

Одно число — сумма цифр в строке.

Для Python.

5218 1 июн. 2020 г., 18:10:10 | 5 - 9 классы

ПОМОГИТЕ ПОЖАЛУЙСТА?

ПОМОГИТЕ ПОЖАЛУЙСТА!

ОЧЕНЬ НУЖНО!

Дана строка.

Строка состоит из слов, разделенных пробелами.

Требуется : 1) Выделить из строки и напечатать слова : а)не содержащие цифры 0 - 3.

Б) слова, оканчивающиеся на "Я".

Kulikovacelina 13 дек. 2020 г., 07:54:35 | 10 - 11 классы

Паскаль?

Паскаль.

Дана строка, содержащая слова, разделенные одним пробелом.

Напечатать все слова, предварительно преобразовав каждое из них по следующему правилу : удалить из слова все последующие вхождения первой буквы.

Natusik34 30 сент. 2020 г., 03:30:19 | 5 - 9 классы

ПОМОГИТЕ СРОЧНО?

ПОМОГИТЕ СРОЧНО!

Добавить в ниже данную программу (Паскаль ABC) всего одну строку так, чтобы числа с четной суммой цифр отмечались * .

Christinka1708 13 дек. 2020 г., 07:14:07 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста!

) Напечатать программу в паскале.

Пожалуйста.

Срочно.

Завтра крайний срок сдачи.

Помогите.

Дан массив строк без пробелов.

Напечатать строки, вторая половина которых не содержит цифры.

Sportgirl 20 дек. 2020 г., 02:01:38 | 5 - 9 классы

Дана строка ?

Дана строка .

Написать программу для вывода на экран первой буквы строки.

Срочно!

(паскаль).

Kras22 17 янв. 2020 г., 12:55:20 | 10 - 11 классы

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом?

СРОЧНО дана строка, состоящая из двух слов, разделенных пробелом.

Написать программу меняющую части строки до и после пробела местами и добавляющую в конец строки восклицательный знак.

Решить в паскале.

Ника527 17 июн. 2020 г., 17:23:00 | 10 - 11 классы

Написать программу в паскале : Дана строка текста?

Написать программу в паскале : Дана строка текста.

Слова в тексте друг от друга отделяются одним пробелом.

Удалить из строки все слова, начинающиеся и заканчивающиеся на "о".

Милена678985 11 сент. 2020 г., 01:41:18 | 5 - 9 классы

Дана строка?

Дана строка.

Поместить все цифры строки в отдельную строку.

Паскаль.

Помогите пожалуйста, решить!

Перед вами страница с вопросом Помогите пожалуйста?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.