(Паскаль)2?

Информатика | 5 - 9 классы

(Паскаль)2.

Заполнить с клавиатуры массив из 10 элементов.

Если минимальный элемент находится в первой половине массива увеличить каждый четный элемент массива в два раза, в противном случае массив оставить без изменения.

Вывести новый массив на экран в виде строки.

Ответить на вопрос
Ответы (1)
Нюта295677 15 апр. 2020 г., 10:37:50

Programchik3 ;

vara : array[1.

1000]ofinteger ;

i, min, l : integer ;

begin

fori : = 1to10do

begin

read(a[i]) ;

end ;

min : = a[1] ; l : = 1 ;

fori : = 2to10do

begin

if(a[i]< ; min)thenbegin

min : = a[i] ;

l : = i ;

end ;

end ;

fori : = 1to 5do

begin

if(a[i] = min)thenl : = - 50 ;

end ;

if(l = - 50)thenbegin

fori : = 1to10do

begin

if(a[i]mod2 = 0)thena[i] : = a[i] * 2 ;

end ;

end ;

fori : = 1to10do

begin

write(a[i], '') ;

end ;

end.

Кatya554 2 сент. 2020 г., 10:00:00 | 5 - 9 классы

Заполнить массив n элементов , затем сохранить в массив n2 четные элементы деленные на 2 , а четные умноженные на 2 ?

Заполнить массив n элементов , затем сохранить в массив n2 четные элементы деленные на 2 , а четные умноженные на 2 .

Вывести на экран исходный массив , после чего с первого массива вычесть 2 и вывести на экран изменённый первый массив.

Evgeniya198 23 мар. 2020 г., 23:05:18 | 5 - 9 классы

(Паскаль)Заполнить с клавиатуры массив из 10 элементов?

(Паскаль)Заполнить с клавиатуры массив из 10 элементов.

Вывести на экран те элементы массива, которые имеют четный номер и четное значение .

Zenks 10 мар. 2020 г., 02:56:58 | 10 - 11 классы

Найди все четные по значению элементы массива?

Найди все четные по значению элементы массива.

Вывести на экран значение элементов и их индекс.

Ввод элементов массива с клавиатуры.

Программа пишется на языке Паскаль.

Hatashaprudhik 4 авг. 2020 г., 01:37:25 | 10 - 11 классы

Дан целочисленный одномерный массив из n - элементов?

Дан целочисленный одномерный массив из n - элементов.

Вывести на экран четные элементы стоящие на нечетных массивов через паскаль.

Lera5762 22 дек. 2020 г., 07:31:29 | 5 - 9 классы

Заполнить массив размером 10 элементов целыми числами , вводимыми с клавиатуры ?

Заполнить массив размером 10 элементов целыми числами , вводимыми с клавиатуры .

Вывести на экран элементы массива и из произведения.

МаксимШевкунов2004 18 нояб. 2020 г., 09:05:52 | 10 - 11 классы

1. Заполнить массив с клавиатуры целыми числами?

1. Заполнить массив с клавиатуры целыми числами.

Вывести элементы этого массива на экран.

(Добавить комментарии) 2.

Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса).

3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива.

4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных.

5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных.

6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами.

Вывести на экран исходный и новый массив.

7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы.

8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Tati123 25 февр. 2020 г., 11:27:23 | 5 - 9 классы

Вывести на экран максимальный элемент массива, массив заполняется с клавиатуры?

Вывести на экран максимальный элемент массива, массив заполняется с клавиатуры.

Яапелс 7 июн. 2020 г., 06:57:01 | 5 - 9 классы

С клавиатуры ввести массив А (Б)?

С клавиатуры ввести массив А (Б).

Найти сумму всех элементов массива.

Вывести ее на экран, и массив опять.

Maneckoba0sha 21 апр. 2020 г., 16:28:40 | 10 - 11 классы

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный?

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент.

Наталья19951 14 февр. 2020 г., 14:04:32 | 5 - 9 классы

Помогите, пожалуйста?

Помогите, пожалуйста.

Нужно составить программу в Турбо Паскаль, которая находит минимальный элемент в массиве и ставит его на первое место, при этом все остальные элементы сдвигаются.

Вывести на экран новый массив.

Если вам необходимо получить ответ на вопрос (Паскаль)2?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.