Помогите, пожалуйста?

Информатика | 5 - 9 классы

Помогите, пожалуйста.

Нужно составить программу в Турбо Паскаль, которая находит минимальный элемент в массиве и ставит его на первое место, при этом все остальные элементы сдвигаются.

Вывести на экран новый массив.

Ответить на вопрос
Ответы (1)
Yamamouse77 14 февр. 2020 г., 14:04:38

Const n = 10 ;

var a : array[1.

N]of integer ; min, imin, i, oldmin : integer ;

begin / / Заполнение массива значениями в диапазоне / / от - 100 до 100 / / и одновременно находим минимальный элемент элемент min : = 100 ; for i : = 1 to n do begin a[i] : = random(201) - 100 ; if a[i]< ; = min then begin min : = a[i] ; imin : = i ; / / Запомним index минимального end ; write(a[i] : 5) ; end ; writeln ; / / В цикле сдвигаем элементы массива / / до индекса минимального включительно на / / одну позицию вправо for i : = imin downto 2 do a[i] : = a[i - 1] ; a[1] : = min ; / / вывод элементов массива for i : = 1 to n do write(a[i] : 5) ;

end.

Soltanly 15 апр. 2020 г., 10:37:47 | 5 - 9 классы

(Паскаль)2?

(Паскаль)2.

Заполнить с клавиатуры массив из 10 элементов.

Если минимальный элемент находится в первой половине массива увеличить каждый четный элемент массива в два раза, в противном случае массив оставить без изменения.

Вывести новый массив на экран в виде строки.

Zenks 10 мар. 2020 г., 02:56:58 | 10 - 11 классы

Найди все четные по значению элементы массива?

Найди все четные по значению элементы массива.

Вывести на экран значение элементов и их индекс.

Ввод элементов массива с клавиатуры.

Программа пишется на языке Паскаль.

Adilkami 27 февр. 2020 г., 07:19:50 | 10 - 11 классы

Вывести на экран элементы, расположеные перед первым минимальным ?

Вывести на экран элементы, расположеные перед первым минимальным .

Массив, паскаль.

Vikik123 2 апр. 2020 г., 08:19:27 | 10 - 11 классы

Напишите программу поиска минимального и максимального элементов матрицы?

Напишите программу поиска минимального и максимального элементов матрицы.

Программа должна менять максимальный и минимальный элементы между собой и выводить на экран исходную и преобразованную матрицы (Турбо Паскаль).

Ulia026 12 мар. 2020 г., 22:54:59 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста.

Срочно нужно.

Дан одномерный массив, состоящий из 10 элементов.

Вывести на экран в строчку.

Поменять местами значения от 6 - 10 элементов массива элементов массива и снова вывести на экран!

Настя122004 1 мар. 2020 г., 21:25:50 | 5 - 9 классы

Напишите пожалуйста программу, которая находит максимальный и минимальный из элементов массива с четными положительными значениями?

Напишите пожалуйста программу, которая находит максимальный и минимальный из элементов массива с четными положительными значениями.

Если в массиве нет элементов с четными положительными значениями, нужно вывести сообщение об этом.

С объяснением!

VictoriyaR 5 июн. 2020 г., 20:05:38 | 5 - 9 классы

Помогите пожалуйста составить программы в паскале : 1?

Помогите пожалуйста составить программы в паскале : 1.

Сформировать массив из 15 элементов случайным образом и вывести его на элементы на экран в обратном порядке.

2. дан одномерный массив найдите разность наибольшего и наименьшего элемента этого массива.

Маша999910 26 мар. 2020 г., 23:07:43 | 5 - 9 классы

Дан одномерный массив из n элементов, найти max, поменять его местами с первым элементом, результат вывести на экран( Программа в Паскале)?

Дан одномерный массив из n элементов, найти max, поменять его местами с первым элементом, результат вывести на экран( Программа в Паскале).

Polinok290 8 янв. 2020 г., 04:29:13 | 10 - 11 классы

Напишите программу которая находит максимальный и минимальный из чётных пложителных элементов массива?

Напишите программу которая находит максимальный и минимальный из чётных пложителных элементов массива.

Если в массиве нет чётных положительных элементов, нужно вывести сообщение об этом.

По информатика с ответам.

Vasyapupkin201 2 июл. 2020 г., 19:43:53 | 5 - 9 классы

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран?

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран.

Язык Паскаль.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Помогите, пожалуйста?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.