В массиве А(N) поменяйте местами первый отрицательный и минимальный элементы?

Информатика | 10 - 11 классы

В массиве А(N) поменяйте местами первый отрицательный и минимальный элементы.

Ответить на вопрос
Ответы (1)
Anastasyamercku 17 нояб. 2020 г., 17:52:15

Uses crt ;

const N = 10 ;

var a : array[1.

N] of integer ; i, k, m, min, imin : integer ;

Begin

readln(m) ;

for i : = 1 to m do begin

readln(a[i]) ;

min : = min + a[i] ;

end ;

for i : = 1 to m do begin

if a[i]< ; 0 then begin

k : = i ;

break ;

end ;

end ;

for i : = 1 to m do begin

if a[i]< ; min then begin

min : = a[i] ;

imin : = i ;

end ;

end ;

min : = a[imin] ;

a[imin] : = a[k] ;

a[k] : = min ;

for i : = 1 to m do write(a[i], ' ') ;

end.

Spectorsin 28 июл. 2020 г., 23:16:56 | 5 - 9 классы

Составить программу в массиве с N числами поменять местами максимальное и минимальное значения?

Составить программу в массиве с N числами поменять местами максимальное и минимальное значения.

LeroyBogdanova 26 мар. 2020 г., 15:00:19 | 5 - 9 классы

Поменять местами минимальный и первый элементы массива?

Поменять местами минимальный и первый элементы массива.

Alina200415 17 янв. 2020 г., 01:07:56 | 10 - 11 классы

1) Поменять местами минимальный четный элемент с последним?

1) Поменять местами минимальный четный элемент с последним.

2)На место максимального отрицательного элемента поместить сумму элементов кратных 3.

(в программе Паскаль) РЕБЯТКИ помогите))))))).

Plombirka10 17 нояб. 2020 г., 18:38:13 | 10 - 11 классы

Ввести массив A(n) ?

Ввести массив A(n) .

Если в массиве не менее двух отрицательных элементов , то уменьшить отрицательные элементы массива на 2 , иначе найти номер первого минимального элемента массива.

Елизаветаа654 26 февр. 2020 г., 21:17:46 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Поменять местами первый максимальный (если таковых несколько) и последний минимальный (если таковых несколько) по значению элементы массива.

Число элементов в массиве не более 10 - ти Pascal.

Дулат2002 8 сент. 2020 г., 00:15:16 | 5 - 9 классы

Составить программу в массиве с N числами поменять местами максимальное и минимальное значения?

Составить программу в массиве с N числами поменять местами максимальное и минимальное значения.

Kris656 29 мая 2020 г., 11:19:10 | 10 - 11 классы

Написать программу и блок - схему для решения следующей задачи?

Написать программу и блок - схему для решения следующей задачи.

В двумерном массиве, состоящем из целочисленных элементов, поменять местами : в каждом столбце первый и последний отрицательные элементы ;

(Паскаль).

Gaben345 24 дек. 2020 г., 08:36:03 | 10 - 11 классы

. Поменять местами минимальные и максимальные элементы?

. Поменять местами минимальные и максимальные элементы.

Cat200235 10 июл. 2020 г., 02:03:00 | 5 - 9 классы

Дано : Массивы А(10), В(15)?

Дано : Массивы А(10), В(15).

Поменять местами их первые положительные элементы .

Для нахождения первого положительного элемента и его номера в массиве использовать подпрограмму.

Сделать в паскале.

Anatolijokshin 14 дек. 2020 г., 08:51:45 | 5 - 9 классы

Поменять местами первое положительное число с последним отрицательным числом в одномерном массиве из N целочисленых элементов (программа для PascalABC )?

Поменять местами первое положительное число с последним отрицательным числом в одномерном массиве из N целочисленых элементов (программа для PascalABC ).

Вы находитесь на странице вопроса В массиве А(N) поменяйте местами первый отрицательный и минимальный элементы? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 10 - 11 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.