Решить задачу, используя «цикл с параметром», «цикл с предусловием», «цикл с постусловием»?

Информатика | 10 - 11 классы

Решить задачу, используя «цикл с параметром», «цикл с предусловием», «цикл с постусловием».

Найти сумму и произведение первых n натуральных чисел.

Ответить на вопрос
Ответы (1)
Nastyamilka1 15 мар. 2020 г., 18:41:40

Program cikli ;

unit math ;

var i, n, s, p : integer ; a : array[1.

20]of integer ;

begin

writeln('Исходный массив : ') ;

for i : = 1 to 20 do begin a[i] : = RandomRange(1, 20) ; writeln(' Элемент ', i, ' = ', a[i]) ;

end ;

writeln('Сумму и произведения скольки первых чисел вы хотите посчитать?

') ;

readln(n) ;

s : = 0 ; p : = 1 ; / / цикл с параметром

For i : = 1 to n do begin s : = s + a[i] ; p : = p * a[i] ;

end ;

writeln('Цикл с параметром') ;

writeln('Сумма первых ', n, ' чисел = ', s) ;

writeln('Произведения первых ', n, 'чисел = ', p) ; / / цикл с предусловием

i : = 1 ; p : = 1 ; s : = 0 ;

while i< ; > ; n do begin

s : = s + a[i] ;

p : = p * a[i] ;

i : = i + 1 ;

end ;

writeln('Цикл с предусловием') ;

writeln('Сумма первых ', n, ' чисел = ', s) ;

writeln('Произведения первых ', n, 'чисел = ', p) ; / / цикл с постусловием

i : = 0 ; s : = 0 ; p : = 1 ;

repeat i : = i + 1 ; s : = s + a[i] ; p : = p * a[i] ;

until i = n ;

writeln('Цикл с постусловием') ;

writeln('Сумма первых ', n, ' чисел = ', s) ;

writeln('Произведения первых ', n, 'чисел = ', p) ;

End.

Olgas2002popkov 18 апр. 2020 г., 11:02:21 | 5 - 9 классы

Чем отличается цикл с предусловием от цикла с постусловием?

Чем отличается цикл с предусловием от цикла с постусловием?

Знания2013 25 янв. 2020 г., 20:59:36 | 10 - 11 классы

Написать программу, которая выводит таблицу квадратов первых пяти целых положительных нечетных чисел (используя цикл с параметром)?

Написать программу, которая выводит таблицу квадратов первых пяти целых положительных нечетных чисел (используя цикл с параметром).

В паскале Потом такую же только цикл с предусловием, и еще одну цикл с постусловием.

Вел2013 29 февр. 2020 г., 03:11:55 | 5 - 9 классы

Найти сумму цифр четырехзначного числа через цикл с постусловием?

Найти сумму цифр четырехзначного числа через цикл с постусловием.

Marinakolbina 7 янв. 2020 г., 10:23:28 | 10 - 11 классы

Используя цикл с параметром решить задачу?

Используя цикл с параметром решить задачу.

Найти произведение первых n четных натуральных чисел.

Zoya1Kononchuk 17 июн. 2020 г., 01:10:45 | 10 - 11 классы

Можно ли цикл с параметром переделать в цикл с предусловием или постусловием?

Можно ли цикл с параметром переделать в цикл с предусловием или постусловием.

6737960 14 июн. 2020 г., 16:12:49 | 10 - 11 классы

Помогите с паскалем))Для вот этой программы(файл прикреплен документом)Нужно 1) Решить задачу используя цикл с предусловием2) Решить задачу используя цикл с постусловием?

Помогите с паскалем))

Для вот этой программы(файл прикреплен документом)

Нужно 1) Решить задачу используя цикл с предусловием

2) Решить задачу используя цикл с постусловием.

Само задание которое в файле звучит так 1) Написать программу, которая вычисляет сумму первых n членов ряда 1, 3, 5, 7, … Количество суммируемых членов ряда задается во время работы программы (используя цикл с параметром).

Krisyakimova 3 янв. 2020 г., 09:51:04 | 10 - 11 классы

Найдите сумму натуральных чисел от 1 до m?

Найдите сумму натуральных чисел от 1 до m.

Используя цикл с предусловием.

Corut 23 нояб. 2020 г., 04:08:31 | 5 - 9 классы

Найти сумму всех двузначных чисел?

Найти сумму всех двузначных чисел.

Решить используя цикл с параметром.

(Паскаль).

Димарик0 15 авг. 2020 г., 12:35:33 | 5 - 9 классы

Если выполнения алгоритма заканчивается, когда условие цикла становится истинным, то он называется : 1) циклом с предусловием 2) бесконечность 3) циклом n - раз 4) циклом с постусловием?

Если выполнения алгоритма заканчивается, когда условие цикла становится истинным, то он называется : 1) циклом с предусловием 2) бесконечность 3) циклом n - раз 4) циклом с постусловием.

ЕленаГусакова 2 нояб. 2020 г., 20:18:49 | 5 - 9 классы

Написать программу нахождения суммы всех натуральных чисел от 1 до 99, используя цикл с параметром?

Написать программу нахождения суммы всех натуральных чисел от 1 до 99, используя цикл с параметром.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Решить задачу, используя «цикл с параметром», «цикл с предусловием», «цикл с постусловием»?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.