Используя цикл с параметром решить задачу?

Информатика | 10 - 11 классы

Используя цикл с параметром решить задачу.

Найти произведение первых n четных натуральных чисел.

Ответить на вопрос
Ответы (1)
Тёмыч1231 7 янв. 2020 г., 10:23:31

Program cikli ; unit math ; var i, n, s, p : integer ; a : array[1.

20]of integer ; beginwriteln('Исходный массив : ') ; for i : = 1 to 20 do begin a[i] : = RandomRange(1, 20) ; writeln(' Элемент ', i, ' = ', a[i]) ; end ; writeln('Сумму и произведения скольки первых чисел вы хотите посчитать?

') ; readln(n) ; s : = 0 ; p : = 1 ; / / цикл с параметромFor i : = 1 to n do begin s : = s + a[i] ; p : = p * a[i] ; end ; writeln('Цикл с параметром') ; writeln('Сумма первых ', n, ' чисел = ', s) ; writeln('Произведения первых ', n, 'чисел = ', p) ; / / цикл с предусловиемi : = 1 ; p : = 1 ; s : = 0 ; while i< ; > ; n do begins : = s + a[i] ; p : = p * a[i] ; i : = i + 1 ; end ; writeln('Цикл с предусловием') ; writeln('Сумма первых ', n, ' чисел = ', s) ; writeln('Произведения первых ', n, 'чисел = ', p) ; / / цикл с постусловиемi : = 0 ; s : = 0 ; p : = 1 ; repeat i : = i + 1 ; s : = s + a[i] ; p : = p * a[i] ; until i = n ; writeln('Цикл с постусловием') ; writeln('Сумма первых ', n, ' чисел = ', s) ; writeln('Произведения первых ', n, 'чисел = ', p) ; End.

Ленусикккк 23 июн. 2020 г., 01:57:22 | 5 - 9 классы

Найти среднее арифметическое всех чисел от 100 до 900?

Найти среднее арифметическое всех чисел от 100 до 900.

В цикле с параметром.

Знания2013 25 янв. 2020 г., 20:59:36 | 10 - 11 классы

Написать программу, которая выводит таблицу квадратов первых пяти целых положительных нечетных чисел (используя цикл с параметром)?

Написать программу, которая выводит таблицу квадратов первых пяти целых положительных нечетных чисел (используя цикл с параметром).

В паскале Потом такую же только цикл с предусловием, и еще одну цикл с постусловием.

Настя123999 15 мар. 2020 г., 18:41:35 | 10 - 11 классы

Решить задачу, используя «цикл с параметром», «цикл с предусловием», «цикл с постусловием»?

Решить задачу, используя «цикл с параметром», «цикл с предусловием», «цикл с постусловием».

Найти сумму и произведение первых n натуральных чисел.

Krasavikus 21 мар. 2020 г., 22:23:31 | 5 - 9 классы

НАЙТИ СУММУ ЧЕТНЫХ ДВУЗНАЧНЫХ НАТУРАЛЬНЫХ ЧИСЕЛ?

НАЙТИ СУММУ ЧЕТНЫХ ДВУЗНАЧНЫХ НАТУРАЛЬНЫХ ЧИСЕЛ!

Лысыйй 16 апр. 2020 г., 23:32:43 | 5 - 9 классы

Найти сумму всех двухзначных четных натуральных чисел?

Найти сумму всех двухзначных четных натуральных чисел.

Ларисочк 7 апр. 2020 г., 00:10:17 | 5 - 9 классы

Найти сумму N первых четных натуральных чисел в Qbasic?

Найти сумму N первых четных натуральных чисел в Qbasic.

Corut 23 нояб. 2020 г., 04:08:31 | 5 - 9 классы

Найти сумму всех двузначных чисел?

Найти сумму всех двузначных чисел.

Решить используя цикл с параметром.

(Паскаль).

Анар051434 22 сент. 2020 г., 13:54:22 | 5 - 9 классы

Напишите программу находящую среднее арифметическое четных чисел, вводимых с клавиатуры?

Напишите программу находящую среднее арифметическое четных чисел, вводимых с клавиатуры.

Задачу решить с помощью цикла с параметром.

ЕленаГусакова 2 нояб. 2020 г., 20:18:49 | 5 - 9 классы

Написать программу нахождения суммы всех натуральных чисел от 1 до 99, используя цикл с параметром?

Написать программу нахождения суммы всех натуральных чисел от 1 до 99, используя цикл с параметром.

Dajanaros2003 17 дек. 2020 г., 03:59:34 | 5 - 9 классы

Напишите программу нахождения N?

Напишите программу нахождения N!

- произведения первых N натуральных чисел с использованием цикла с автоувеличением параметра!

Срочно пожалуйста!

Если вам необходимо получить ответ на вопрос Используя цикл с параметром решить задачу?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.