Помогите с паскалем))Для вот этой программы(файл прикреплен документом)Нужно 1) Решить задачу используя цикл с предусловием2) Решить задачу используя цикл с постусловием?

Информатика | 10 - 11 классы

Помогите с паскалем))

Для вот этой программы(файл прикреплен документом)

Нужно 1) Решить задачу используя цикл с предусловием

2) Решить задачу используя цикл с постусловием.

Само задание которое в файле звучит так 1) Написать программу, которая вычисляет сумму первых n членов ряда 1, 3, 5, 7, … Количество суммируемых членов ряда задается во время работы программы (используя цикл с параметром).

Ответить на вопрос
Ответы (1)
Hamka2014 14 июн. 2020 г., 16:12:52

Ваши с переделанными циклами

var n, i, c, a : longint ;

begin read(n) ; a : = 1 ; i : = 1 ; while i< ; = n do begin c : = a + c ; a : = a + 2 ; i : = i + 1 end ; write(c) ;

end.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

var n, i, c, a : longint ;

begin read(n) ; a : = 1 ; i : = 1 ; repeat c : = a + c ; a : = a + 2 ; i : = i + 1 until i> ; n ; write(c) ;

end.

Знания2013 25 янв. 2020 г., 20:59:36 | 10 - 11 классы

Написать программу, которая выводит таблицу квадратов первых пяти целых положительных нечетных чисел (используя цикл с параметром)?

Написать программу, которая выводит таблицу квадратов первых пяти целых положительных нечетных чисел (используя цикл с параметром).

В паскале Потом такую же только цикл с предусловием, и еще одну цикл с постусловием.

Kravika2010 27 июл. 2020 г., 11:59:17 | 5 - 9 классы

Написать программу, которая вычисляет сумму первых n целых положительных чисел?

Написать программу, которая вычисляет сумму первых n целых положительных чисел.

Количество суммируемых чисел должно вводиться во время работы программы.

Написать ее с помощью цикла for.

To. do.

Zoya1Kononchuk 17 июн. 2020 г., 01:10:45 | 10 - 11 классы

Можно ли цикл с параметром переделать в цикл с предусловием или постусловием?

Можно ли цикл с параметром переделать в цикл с предусловием или постусловием.

Настя123999 15 мар. 2020 г., 18:41:35 | 10 - 11 классы

Решить задачу, используя «цикл с параметром», «цикл с предусловием», «цикл с постусловием»?

Решить задачу, используя «цикл с параметром», «цикл с предусловием», «цикл с постусловием».

Найти сумму и произведение первых n натуральных чисел.

Anittka 31 дек. 2020 г., 05:41:23 | 5 - 9 классы

Решите в тетради задачи, используя цикл while - wend 1?

Решите в тетради задачи, используя цикл while - wend 1.

Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры.

Youkiko 19 мар. 2020 г., 18:24:12 | 10 - 11 классы

Помогите с Паскалем пожалуйста) Паскаль АВС)1)Написать программу, которая вычисляет сумму первых n членов ряда 1, 3, 5, 7, … Количество суммируемых членов ряда задается во время работы программы (испо?

Помогите с Паскалем пожалуйста) Паскаль АВС)

1)Написать программу, которая вычисляет сумму первых n членов ряда 1, 3, 5, 7, … Количество суммируемых членов ряда задается во время работы программы (используя цикл с параметром).

2) Решить задачу 4 используя цикл с предусловием.

3)Решить задачу 4 используя цикл с постусловием.

4 задача ниже - Написать программу вычисления стоимости покупки с учетом скидки.

Скидка в 10% предоставляется, если сумма покупки больше 1000 руб.

Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).

Вычисление стоимости покупки с учетом скидки.

Введите сумму покупки и нажмите < ; Enter> ; =

1200

Вам предоставляется скидка 10%

Сумма покупки с учетом скидки : 1080.

00 руб.

Corut 23 нояб. 2020 г., 04:08:31 | 5 - 9 классы

Найти сумму всех двузначных чисел?

Найти сумму всех двузначных чисел.

Решить используя цикл с параметром.

(Паскаль).

Настя695 3 июн. 2020 г., 22:58:21 | 10 - 11 классы

Написать программу, которая вычисляет факториал числа, введенного с клавиатуры, используя цикл с постусловием?

Написать программу, которая вычисляет факториал числа, введенного с клавиатуры, используя цикл с постусловием.

Язык - pascal.

Schurka 19 июн. 2020 г., 01:49:53 | 10 - 11 классы

Пожалуйста помогите написать программу, используя базовую структуру цикла с предусловием While?

Пожалуйста помогите написать программу, используя базовую структуру цикла с предусловием While.

ЕленаГусакова 2 нояб. 2020 г., 20:18:49 | 5 - 9 классы

Написать программу нахождения суммы всех натуральных чисел от 1 до 99, используя цикл с параметром?

Написать программу нахождения суммы всех натуральных чисел от 1 до 99, используя цикл с параметром.

Вы открыли страницу вопроса Помогите с паскалем))Для вот этой программы(файл прикреплен документом)Нужно 1) Решить задачу используя цикл с предусловием2) Решить задачу используя цикл с постусловием?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.