Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения?

Информатика | 10 - 11 классы

Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения.

Паскаль.

Ответить на вопрос
Ответы (1)
Алиночка1277 3 авг. 2020 г., 03:20:08

Program a1 ;

var x, y, s : integer ;

begin

read (x, y) ;

write(x, ' * ', y, ' = ') ;

while x> ; 0 do

begin If ((x mod 2) < ; > ; 0) then s : = s + y ; x : = x div 2 ; y : = y + y ;

end ;

write(s) ;

writeln() ;

readln() ;

end.

Русский способ умножения.

Avdieienko1976 20 авг. 2020 г., 21:00:43 | 5 - 9 классы

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения?

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными (паскаль авс).

Dasa1110268 27 апр. 2020 г., 20:03:36 | 1 - 4 классы

Написать программу, которая запрашивает ввод двух целых чисел и проделывает над ними операции умножения и деления?

Написать программу, которая запрашивает ввод двух целых чисел и проделывает над ними операции умножения и деления.

Splotko 29 июн. 2020 г., 02:55:59 | 5 - 9 классы

Составить на Паскале программу определения минимума из трёх чисел c использованием логических операций?

Составить на Паскале программу определения минимума из трёх чисел c использованием логических операций.

Программа должна иметь дружественный интерфейс.

Mitrifanovaav 8 мар. 2020 г., 16:41:12 | 5 - 9 классы

Как составить программу для нахождения произведения квадрата всех целых чисел от А до В?

Как составить программу для нахождения произведения квадрата всех целых чисел от А до В.

Vorondan7772 4 дек. 2020 г., 17:37:54 | 10 - 11 классы

Программа на Паскале?

Программа на Паскале.

Нахождение произведения четных чисел и суммы нечетных чисел меньше 15.

Ya125 3 мар. 2020 г., 19:43:13 | 10 - 11 классы

Задается последовательность целых чисел?

Задается последовательность целых чисел.

Сколько чисел отличается от первого на 1 ?

Написать программу на паскале без использования массивов.

Bekzat6 1 апр. 2020 г., 09:55:35 | 5 - 9 классы

Составить программу на языке паскаль по нахождению суммы двух любых чисел?

Составить программу на языке паскаль по нахождению суммы двух любых чисел.

Pacerson 2 июл. 2020 г., 05:42:55 | 10 - 11 классы

Составить на Паскале программу определения минимума из трёх чисел с использованием логических операций?

Составить на Паскале программу определения минимума из трёх чисел с использованием логических операций.

Программа должна иметь дружественный интерфейс.

Daiyanakz2 1 дек. 2020 г., 17:21:39 | 5 - 9 классы

Написать программу для нахождения суммы первых пяти нечетных чисел (Паскаль)?

Написать программу для нахождения суммы первых пяти нечетных чисел (Паскаль).

User1000 13 окт. 2020 г., 23:10:21 | 1 - 4 классы

Составьте программу нахождения произведения z двух натуральных чисел x и y без использования операции умножения?

Составьте программу нахождения произведения z двух натуральных чисел x и y без использования операции умножения.

На странице вопроса Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.