Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения?

Информатика | 5 - 9 классы

Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными (паскаль авс).

Ответить на вопрос
Ответы (2)
Turbo007 20 авг. 2020 г., 21:00:48

UPD

__________

Var

a, b, s, i : integer ;

begin

readln(a, b) ;

if a < ; > ; b then

for i : = 1 to abs(b) do s : = s + a

else for I : = 1 to abs(b) do s : = s + a ;

if (a< ; 0) and (b< ; 0) then s : = abs(s)

else if b< ; 0 then s : = - s ;

writeln(s) ;

end.

Gromov9987 20 авг. 2020 г., 21:00:53

Var A, B, i, S : integer ;

Ch : Char ;

Begin

S : = 0 ;

Write('A = ') ; ReadLn(A) ;

Write('B = ') ; ReadLn(B) ;

if ((A< ; 0)and(B> ; 0))or((A> ; 0)and(B< ; 0)) then Ch : = ' - ' ;

A : = Abs(A) ;

B : = Abs(B) ;

For i : = 1 to A do

S : = S + B ;

WriteLn(Ch, S)

End.

Аліна199922 3 авг. 2020 г., 03:20:05 | 10 - 11 классы

Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения?

Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения.

Паскаль.

Super010600 6 июл. 2020 г., 06:56:58 | 5 - 9 классы

Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения?

Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными.

Через цикл WHILE!

Madam1violi 19 дек. 2020 г., 02:16:46 | 5 - 9 классы

В Паскале написать программу?

В Паскале написать программу.

Вводите число и по ней таблица умножения выводится.

МуШкАсупербОлТуШкА 30 сент. 2020 г., 08:57:40 | 10 - 11 классы

Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения?

Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения.

Учтите, что числа могут быть отрицательными.

Через цикл WHILE!

(c + + ).

Katerinka1297 6 февр. 2020 г., 18:40:58 | 10 - 11 классы

Составьте программу в ПАСКАЛЬ, которая запрашивает ввод целых положительных чисел и определяет произведение нечётных из них?

Составьте программу в ПАСКАЛЬ, которая запрашивает ввод целых положительных чисел и определяет произведение нечётных из них.

Признаком конца ввода считать ввод числа - 4.

Ekaterlnakozlova 27 мар. 2020 г., 07:46:06 | 5 - 9 классы

Ввести два целых числа , найти их произведение не используя операцию умножения?

Ввести два целых числа , найти их произведение не используя операцию умножения.

Аня1210 5 июн. 2020 г., 08:29:44 | 5 - 9 классы

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом?

Помогите пожалуйста, нужно написать программу в паскале которая будет вводить целые числа до 5, подсчитать количество положительных и отрицательных чисел, где 0 будет считаться положительным числом.

Revolutionmys 22 февр. 2020 г., 17:41:53 | 5 - 9 классы

Написать программу, которая находит сумму, произведения, частное и разность 2 целых чисел?

Написать программу, которая находит сумму, произведения, частное и разность 2 целых чисел.

Эти числа вводятся с клавиатуры.

Киря1321 1 апр. 2020 г., 09:32:43 | 5 - 9 классы

Написать программу которая получает два целых числа и находит их произведение не используя операцию умножения учтите что числа могут быть отрицательными?

Написать программу которая получает два целых числа и находит их произведение не используя операцию умножения учтите что числа могут быть отрицательными.

(надо в c + + ).

89207 4 апр. 2020 г., 13:51:26 | 10 - 11 классы

Решить задачу в Паскале авс?

Решить задачу в Паскале авс.

Пользователь вводит натуральное число.

Программа находит первое следующее за ним число с той же суммой цифр.

Вы перешли к вопросу Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.