Задается последовательность целых чисел?

Информатика | 10 - 11 классы

Задается последовательность целых чисел.

Сколько чисел отличается от первого на 1 ?

Написать программу на паскале без использования массивов.

Ответить на вопрос
Ответы (1)
НиккиКлайд 3 мар. 2020 г., 19:43:14

Uses crt ;

var n, a, b, k : integer ;

begin k : = 0 ;

writeln ('Сколько цифр будет в строке?

') ;

read (n) ;

writeln ('Вводите числа, после каждого ENTER.

') ;

read (b) ;

for n : = 1 to n - 1 do

begin

read (a) ;

if a + 1 = b then k : = k + 1 else

if a - 1 = b then k : = k + 1 ;

end ;

writeln ('Количество чисел отстающих на 1 от первого числа - ', k) ;

end.

Slender2774 30 янв. 2020 г., 19:21:30 | 10 - 11 классы

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЕ?

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЕ!

Задан целочисленный массив из 10 случайных целых чисел.

Выполнить сортировку элементов массива, стоящих на четных номерах по убыванию методом пузырька.

Аліна199922 3 авг. 2020 г., 03:20:05 | 10 - 11 классы

Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения?

Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения.

Паскаль.

272005 23 июл. 2020 г., 00:32:05 | 5 - 9 классы

Написать программу формирования массива из 15 целых чисел от 0 до 50 и вывод массива на экран?

Написать программу формирования массива из 15 целых чисел от 0 до 50 и вывод массива на экран.

Koshak109 23 сент. 2020 г., 21:31:22 | 10 - 11 классы

Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс?

Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс.

Shkololo228339 21 апр. 2020 г., 13:14:36 | 10 - 11 классы

Задан массив из 10 целых чисел?

Задан массив из 10 целых чисел.

Написать программу которая находт - сумму всех элементов массива - колличество чётных и нечётных элементов массива.

Paramonoff4 14 июн. 2020 г., 06:59:12 | 10 - 11 классы

Задана последовательность из n целых чисел?

Задана последовательность из n целых чисел.

Определить среднее арифметическое отрицательных элементов последовательности.

Написать программу в Pascal.

Dinargafarov2 31 мар. 2020 г., 00:09:33 | 5 - 9 классы

Составить программу поиска заданного числа в массиве из 10 целых чисел( массив одномерный)?

Составить программу поиска заданного числа в массиве из 10 целых чисел( массив одномерный).

In17021989 6 янв. 2020 г., 02:17:01 | 5 - 9 классы

Даны два одномерных массива из целых чисел разной размерности?

Даны два одномерных массива из целых чисел разной размерности.

Найти целую часть среднего арифметического элементов каждого массива и их сумму.

Помогите написать программу в паскале.

Butusovke 13 дек. 2020 г., 10:23:28 | 5 - 9 классы

Паскаль?

Паскаль.

Написать программу, которая выводит на экран количество чисел Х в массиве.

В массиве N элементов, числа целые.

Х задаётся.

Помогите))).

Andriymama 19 апр. 2020 г., 21:15:08 | 5 - 9 классы

Программу в паскале?

Программу в паскале.

Составить программу нахождения произведения положительных чисел одномерного массива В(10), элементы которого задаются датчиком случайных чисел.

Вопрос Задается последовательность целых чисел?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.