Дано целое число N?

Информатика | 10 - 11 классы

Дано целое число N.

Определите, кратна ли числу К сумма цифр в числе.

Ответить на вопрос
Ответы (1)
Alenatorlucky 24 февр. 2020 г., 14:59:07

Var n, s, k : integer ;

begin

write('n = ') ; readln(n) ;

write('k = ') ; readln(k) ;

s : = 0 ;

while n< ; > ; 0 do begin

s : = s + n mod 10 ;

n : = n div 10 ;

end ;

writeln('sum = ', s) ;

if s mod k = 0

then writeln('Сумма цифр числа кратна ', k)

else writeln('Сумма цифр числа не кратна ', k) ;

end.

Пример :

n = 123

k = 2

sum = 6

Сумма цифр числа кратна 2.

Fff555 23 окт. 2020 г., 01:29:44 | 5 - 9 классы

Дано трёхзначное число?

Дано трёхзначное число.

Определить : является ли сумма его цифр двузначным числом.

Tatanka212128 16 авг. 2020 г., 19:41:15 | 5 - 9 классы

Дано двузначное число?

Дано двузначное число.

Определить : а) является ли сумма его цифр двузначным числом ; б) больше ли числа а сумма его цифр.

Яблако 26 мар. 2020 г., 21:52:46 | 5 - 9 классы

Дано целое число N?

Дано целое число N.

Определите количество нечётных цифр в данном числе.

(Pascal).

92Altana2001 19 авг. 2020 г., 17:00:03 | 5 - 9 классы

Дано целое число?

Дано целое число.

Определить кратно ли оно 5.

Неумная 6 дек. 2020 г., 11:29:40 | 5 - 9 классы

Дано число?

Дано число.

Определить чему равна сумма нечетных цифр в этом числе.

Единорог1в1кармане 28 мар. 2020 г., 06:32:39 | 5 - 9 классы

9. Дано трехзначное число?

9. Дано трехзначное число.

Определить : а) Является ли сумма его цифр двузначным числом ; b) Является ли произведение его цифр трехзначных числом ; c) Больше ли числа А произведение его цифр ; число А – любое, оно вводится с клавиатуры ; d) Кратна ли пяти сумма его цифр ; e) Кратна ли сумма его цифр числу А ; число А – любое, оно вводится с клавиатуры ; Числа вводить, пока не будет введён нуль.

Блок - схему и программу.

Пожалуйста : ).

941267 9 дек. 2020 г., 19:23:32 | 10 - 11 классы

2) Дано целое число X?

2) Дано целое число X.

Определить кратно ли оно 2, 3 и целому числу P.

Castiell1983 21 окт. 2020 г., 13:13:42 | 5 - 9 классы

Дано трёхзначное число?

Дано трёхзначное число.

Верно ли, что сумма цифр этого числа будет кратна 3?

Программа на пскаль.

Lanabuklova 28 нояб. 2020 г., 16:38:07 | 10 - 11 классы

Решить в паскале : дано двузначное число, определить : а) кратно ли 3 сумма его цифр ; б) кратно ли сумма его цифр числу a?

Решить в паскале : дано двузначное число, определить : а) кратно ли 3 сумма его цифр ; б) кратно ли сумма его цифр числу a.

Маришко1 28 дек. 2020 г., 22:17:48 | 10 - 11 классы

Дано двузначное число?

Дано двузначное число.

Определить, кратна ли трем сумма его цифр?

( Pascal).

Если вам необходимо получить ответ на вопрос Дано целое число N?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.