Поменять местами значения х и у не используя дополнительную переменную?

Информатика | 5 - 9 классы

Поменять местами значения х и у не используя дополнительную переменную.

(Pascal).

Ответить на вопрос
Ответы (1)
Marianna11 30 сент. 2020 г., 13:43:26

Var x, y : integer ;

Begin x : = 20 ;

y : = 40 ;

x : = x + y ;

y : = x - y ;

x : = x - y ;

Write (x, ' ', y) ;

End.

Tsygankovairin 10 окт. 2020 г., 07:25:20 | 5 - 9 классы

Какая команда служит для ввода значений переменных в Pascal?

Какая команда служит для ввода значений переменных в Pascal?

Приведите пример.

DashaMakushkina 5 окт. 2020 г., 00:14:00 | 10 - 11 классы

Поменять местами максимальное и минимальное 3хзначное число х(Pascal)Типо 157 = 751?

Поменять местами максимальное и минимальное 3хзначное число х(Pascal)Типо 157 = 751.

Wownastya 29 янв. 2020 г., 00:20:48 | 10 - 11 классы

1. Написать процедуру, меняющую значения двух переменных а и b местами?

1. Написать процедуру, меняющую значения двух переменных а и b местами.

2. Используя процедуру обмена значений двух переменных, упорядочьте по возрастанию переменные a, b, c.

Sacha152002 6 июн. 2020 г., 00:06:14 | 10 - 11 классы

Составьте блок - схему алгоритма решения задачи и программу на языке Turbo Pascal, ввод данных организовать с клавиатуры?

Составьте блок - схему алгоритма решения задачи и программу на языке Turbo Pascal, ввод данных организовать с клавиатуры.

Поменять местами значения переменных А и B.

Вывести новые значения А и B.

Idef 4 авг. 2020 г., 10:03:23 | 5 - 9 классы

Помогите САМОСТОЯТЕЛЬНО?

Помогите САМОСТОЯТЕЛЬНО.

Ввести с клавиатуры значения для А, В, С.

Поменять их местами : А = > ; В, В = > ; С, С = > ; А.

Комментарий : в программе будет объявлено 4 переменных, обмен значений произведем за 4 шага.

Костя0512 7 июл. 2020 г., 23:31:23 | 1 - 4 классы

Как в pascal в if прописать несколько значений переменной?

Как в pascal в if прописать несколько значений переменной.

Анютка02022002 10 апр. 2020 г., 03:52:50 | 10 - 11 классы

Составить блок - схему решения следующей задачи?

Составить блок - схему решения следующей задачи.

Даны значения двух действительных переменых a и b.

Обменять местами их значения, при этом нельзя использовать никаких дополнительных переменных.

Елизаветаа654 26 февр. 2020 г., 21:17:46 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Поменять местами первый максимальный (если таковых несколько) и последний минимальный (если таковых несколько) по значению элементы массива.

Число элементов в массиве не более 10 - ти Pascal.

Ника880 7 нояб. 2020 г., 08:48:12 | 5 - 9 классы

Написать программу в паскале Даны две переменных с некоторыми значениями?

Написать программу в паскале Даны две переменных с некоторыми значениями.

Поменять местами значения этих переменных.

Просто1111111115 29 февр. 2020 г., 23:22:03 | 5 - 9 классы

СДЕЛАТЬ В PACKALABC Даны значения трех вещественных переменных а, b и с Обменять местами их значения при этом нельзя использовать никаких дополнительных переменных (a = b, b = c, c = a)?

СДЕЛАТЬ В PACKALABC Даны значения трех вещественных переменных а, b и с Обменять местами их значения при этом нельзя использовать никаких дополнительных переменных (a = b, b = c, c = a).

Вы зашли на страницу вопроса Поменять местами значения х и у не используя дополнительную переменную?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.