Поменять местами максимальное и минимальное 3хзначное число х(Pascal)Типо 157 = 751?

Информатика | 10 - 11 классы

Поменять местами максимальное и минимальное 3хзначное число х(Pascal)Типо 157 = 751.

Ответить на вопрос
Ответы (1)
Npronotova 5 окт. 2020 г., 00:14:03

Интересная задачка, заковыристая.

Var x, i, c, q, p : integer ; s : string ; max, min, k : char ;

Begin

readln(x) ;

str(x, s) ;

max : = s[1] ;

min : = s[1] ;

p : = 1 ; q : = 1 ;

for i : = 2 to length(s) do begin if s[i]> ; max then begin max : = s[i] ; q : = i ; end ; if s[i]< ; min then begin min : = s[i] ; p : = i ; end ; end ;

k : = s[p] ;

s[p] : = s[q] ;

s[q] : = k ;

val(s, x, c) ;

writeln(x) ;

End.

Сработает для чисел любой значности.

Spectorsin 28 июл. 2020 г., 23:16:56 | 5 - 9 классы

Составить программу в массиве с N числами поменять местами максимальное и минимальное значения?

Составить программу в массиве с N числами поменять местами максимальное и минимальное значения.

Sasa023 16 янв. 2020 г., 11:32:58 | 10 - 11 классы

4. Дан одномерный массив А размерности N?

4. Дан одномерный массив А размерности N.

Поменять местами максимальный и минимальный элементы.

LeroyBogdanova 26 мар. 2020 г., 15:00:19 | 5 - 9 классы

Поменять местами минимальный и первый элементы массива?

Поменять местами минимальный и первый элементы массива.

Alina200415 17 янв. 2020 г., 01:07:56 | 10 - 11 классы

1) Поменять местами минимальный четный элемент с последним?

1) Поменять местами минимальный четный элемент с последним.

2)На место максимального отрицательного элемента поместить сумму элементов кратных 3.

(в программе Паскаль) РЕБЯТКИ помогите))))))).

Тимур149 18 июл. 2020 г., 17:26:36 | 10 - 11 классы

Дан одномерный массив А размерности N?

Дан одномерный массив А размерности N.

Поменять местами максимальный и минимальный элементы.

Елизаветаа654 26 февр. 2020 г., 21:17:46 | 5 - 9 классы

Дан массив целых чисел?

Дан массив целых чисел.

Поменять местами первый максимальный (если таковых несколько) и последний минимальный (если таковых несколько) по значению элементы массива.

Число элементов в массиве не более 10 - ти Pascal.

Adelya5949 23 сент. 2020 г., 12:32:00 | 10 - 11 классы

Дан вектор размером N поменять местами максимальный и минимальный элементы ( пожалуйста решите, я ничего не понимаю, весь день делаю не получается?

Дан вектор размером N поменять местами максимальный и минимальный элементы ( пожалуйста решите, я ничего не понимаю, весь день делаю не получается.

).

Galinababenko 9 окт. 2020 г., 06:25:18 | 10 - 11 классы

Написать программу на паскале?

Написать программу на паскале.

Создать двухмерный массив из целых чисел, в котором поменять местами максимальный и минимальный элементы.

Помогите пж.

Дулат2002 8 сент. 2020 г., 00:15:16 | 5 - 9 классы

Составить программу в массиве с N числами поменять местами максимальное и минимальное значения?

Составить программу в массиве с N числами поменять местами максимальное и минимальное значения.

Gaben345 24 дек. 2020 г., 08:36:03 | 10 - 11 классы

. Поменять местами минимальные и максимальные элементы?

. Поменять местами минимальные и максимальные элементы.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Поменять местами максимальное и минимальное 3хзначное число х(Pascal)Типо 157 = 751?. По уровню сложности вопрос рассчитан на учащихся 10 - 11 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.