Дан массив целых чисел?

Информатика | 5 - 9 классы

Дан массив целых чисел.

Поменять местами первый максимальный (если таковых несколько) и последний минимальный (если таковых несколько) по значению элементы массива.

Число элементов в массиве не более 10 - ти Pascal.

Ответить на вопрос
Ответы (1)
Заговорогня 26 февр. 2020 г., 21:17:49

Var a : array[1.

10]of integer ;

max, min, i, n, i1, i2 : integer ;

begin

readln(n) ;

for i : = 1 to n do readln(a[i]) ;

max : = a[1] ;

min : = a[1] ;

for i : = 1 to n do begin

if a[i]> ; max then begin max : = a[i] ; i1 : = i ; end ;

if a[i]< ; = min then begin min : = a[i] ; i2 : = i ; end ;

end ;

a[i1] : = a[i1] + a[i2] ;

a[i2] : = a[i1] - a[i2] ;

a[i1] : = a[i1] - a[i2] ;

for i : = 1 to n do write(a[i], ' ') ;

end.

LeroyBogdanova 26 мар. 2020 г., 15:00:19 | 5 - 9 классы

Поменять местами минимальный и первый элементы массива?

Поменять местами минимальный и первый элементы массива.

Некит2004 13 мар. 2020 г., 18:31:07 | 10 - 11 классы

Задан одномерный массив А(N) (N< ; = 60)?

Задан одномерный массив А(N) (N< ; = 60).

На место минимального элемента массива записать сумму последних К элементов массива.

Если А[1]> ; = 0, то умножить все элементы этого массива на квадрат минимального элемента данного вектора, а если А[1]< ; 0, то умножить все элементы на квадрат максимального элемента вектора.

Полученный массив распечатать.

Значение К вводится пользователем.

Katyahey 17 нояб. 2020 г., 17:52:13 | 10 - 11 классы

В массиве А(N) поменяйте местами первый отрицательный и минимальный элементы?

В массиве А(N) поменяйте местами первый отрицательный и минимальный элементы.

2001viola 24 янв. 2020 г., 05:33:36 | 5 - 9 классы

Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25?

Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25.

Программа должна :

1)выводить на экран сначала все элементы массива, стоящие на чётных местах, а затем - все элементы массива, стоящие на нечётных местах ;

2)вывести на экран сумму всех элементов массива, значение которых кратны 3 или 5.

3)найти минимальное значение и максимальное значение элементов массива.

Romanys 27 февр. 2020 г., 14:35:19 | 10 - 11 классы

Найти количество элементов массива, расположенных между первым минимальным и последним максимальным?

Найти количество элементов массива, расположенных между первым минимальным и последним максимальным.

Программа нужна в Pascal.

Grooooyl 2 сент. 2020 г., 04:57:55 | 10 - 11 классы

Задан массив из 10 целых чисел?

Задан массив из 10 целых чисел.

Замените все положительные элементы данного массива его максимальным элементом.

Aylovat40 16 окт. 2020 г., 08:55:54 | 10 - 11 классы

Дан одномерный массив из 12 чисел?

Дан одномерный массив из 12 чисел.

Элементами массива являются целые числа.

Найти максимальный элемент указанного массива.

Coolalena200 17 окт. 2020 г., 17:57:45 | 10 - 11 классы

Помогите решить задачи в Pascal 1?

Помогите решить задачи в Pascal 1.

Поменять местами максимальный и минимальный элемент массива.

2. Вывести четные числа среди положительных элементов 3.

Напечатать сумму и номера положительных элементов после первого нулевого элемента.

Kristina1009 9 дек. 2020 г., 11:37:10 | 5 - 9 классы

Задан массив из 7 целых чисел?

Задан массив из 7 целых чисел.

Заменить все положительные элементы данного массива на его максимальный элемент.

DeadGirl5 6 сент. 2020 г., 01:59:41 | 10 - 11 классы

Turbo Pascal * * * * (Дан одномерный числовой массив?

Turbo Pascal * * * * (Дан одномерный числовой массив.

Определить произведение элементов массива, расположенных между максимальным и «центральным» элементами массива (предполагается, что число элементов – нечетное и максимальный единственный).

Если вам необходимо получить ответ на вопрос Дан массив целых чисел?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.