1. Написать процедуру, меняющую значения двух переменных а и b местами?

Информатика | 10 - 11 классы

1. Написать процедуру, меняющую значения двух переменных а и b местами.

2. Используя процедуру обмена значений двух переменных, упорядочьте по возрастанию переменные a, b, c.

Ответить на вопрос
Ответы (1)
Dashka1906 29 янв. 2020 г., 00:20:52

Procedure Swap(var a, b : object) ;

var c : object : = a ;

begin a : = b ; b : = c ;

end ;

var a, b, c : byte ;

begin readln(a, b, c) ; if (a > ; b) then Swap(a, b) ; if (b > ; c) then Swap(b, c) ; if (a > ; b) then Swap(a, b) ; if (b > ; c) then Swap(b, c) ; writeln(a, b, c) ;

end.

Screamfrompast 15 мар. 2020 г., 12:56:19 | 10 - 11 классы

Составьте программу обмена значениями двух переменных величин : по следующей схеме : в - присвоить значение с а - присвоить значение в?

Составьте программу обмена значениями двух переменных величин : по следующей схеме : в - присвоить значение с а - присвоить значение в.

Мунлаiтъ 11 янв. 2020 г., 11:56:38 | 5 - 9 классы

Задача?

Задача.

Обменять значение двух переменных используя третью.

Hulk7771 30 сент. 2020 г., 13:43:21 | 5 - 9 классы

Поменять местами значения х и у не используя дополнительную переменную?

Поменять местами значения х и у не используя дополнительную переменную.

(Pascal).

Izon836 24 февр. 2020 г., 01:30:25 | 1 - 4 классы

Написать программу, которая меняет знак у значения переменной R?

Написать программу, которая меняет знак у значения переменной R.

Анютка02022002 10 апр. 2020 г., 03:52:50 | 10 - 11 классы

Составить блок - схему решения следующей задачи?

Составить блок - схему решения следующей задачи.

Даны значения двух действительных переменых a и b.

Обменять местами их значения, при этом нельзя использовать никаких дополнительных переменных.

Smey 20 февр. 2020 г., 18:21:06 | 10 - 11 классы

ПОМОГИТЕ ПОЖАЛУЙСТА?

ПОМОГИТЕ ПОЖАЛУЙСТА!

Напишите программу, которая меняет местами значения двух переменных в памяти.

Ника880 7 нояб. 2020 г., 08:48:12 | 5 - 9 классы

Написать программу в паскале Даны две переменных с некоторыми значениями?

Написать программу в паскале Даны две переменных с некоторыми значениями.

Поменять местами значения этих переменных.

Shuren16 4 мая 2020 г., 22:54:26 | 10 - 11 классы

Описать процедуру SortInc3(A,B, C), меняющую содержимое переменных A, B, C таким образом, чтобы их значения оказались упорядоченными по возрастанию (A, B,C — вещественные параметры, являющиеся одновре?

Описать процедуру SortInc3(A,

B, C), меняющую содержимое переменных A, B, C таким образом, чтобы их значения оказались упорядоченными по возрастанию (A, B,

C — вещественные параметры, являющиеся одновременно входными и выходными).

С помощью этой процедуры упорядочить по возрастанию два данных набора из трех чисел : (A1, B1, C1) и (A2, B2, C2).

Ваня636 23 дек. 2020 г., 17:08:46 | 5 - 9 классы

Написать программу которая меняет местами значения двух переменных A и C введенных с клавиатуры?

Написать программу которая меняет местами значения двух переменных A и C введенных с клавиатуры.

Помогите плиз срочно.

Gfgfggf45644 28 дек. 2020 г., 03:52:50 | 5 - 9 классы

Вычислить Y = A + B + C , применив : а) - процедуру ввода данных ; - процедуру вычисления Y ; - процедуру вывода результата ; - глобальные переменные ;PASCAL ABC?

Вычислить Y = A + B + C , применив : а) - процедуру ввода данных ; - процедуру вычисления Y ; - процедуру вывода результата ; - глобальные переменные ;

PASCAL ABC.

Вы зашли на страницу вопроса 1. Написать процедуру, меняющую значения двух переменных а и b местами?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.