СДЕЛАТЬ В PACKALABC Даны значения трех вещественных переменных а, b и с Обменять местами их значения при этом нельзя использовать никаких дополнительных переменных (a = b, b = c, c = a)?

Информатика | 5 - 9 классы

СДЕЛАТЬ В PACKALABC Даны значения трех вещественных переменных а, b и с Обменять местами их значения при этом нельзя использовать никаких дополнительных переменных (a = b, b = c, c = a).

Ответить на вопрос
Ответы (1)
Tatyananaumova95 29 февр. 2020 г., 23:22:08

Program prog ;

uses crt ;

var a, b, c : real ;

begin ;

clrscr ;

readln(a, b, c) ;

a : = a + b + c ; / / a = a + b + c ;

b : = a - b ; / / b = a + c ;

c : = b - c ; / / c = a ;

b : = b - c ; / / b = c ;

a : = a - b - c ; / / a = b ;

write(a, ' ', b, ' ', c) ;

end.

Alex141516 26 окт. 2020 г., 02:12:39 | 5 - 9 классы

Задача :Даны значения трех действительных переменных a, b и c?

Задача :

Даны значения трех действительных переменных a, b и c.

Обменять местами их значения так, чтобы a получила бы значение b, b получила значение c, а переменная c получила исходное значение a.

Dilyadolmatova 15 февр. 2020 г., 11:35:40 | 5 - 9 классы

Напишите линейную программу, в результате выполнения которой целочисленные переменные x и y обмениваются значениями?

Напишите линейную программу, в результате выполнения которой целочисленные переменные x и y обмениваются значениями.

При этом нельзя использовать дополнительные переменные.

Мунлаiтъ 11 янв. 2020 г., 11:56:38 | 5 - 9 классы

Задача?

Задача.

Обменять значение двух переменных используя третью.

Hulk7771 30 сент. 2020 г., 13:43:21 | 5 - 9 классы

Поменять местами значения х и у не используя дополнительную переменную?

Поменять местами значения х и у не используя дополнительную переменную.

(Pascal).

Viktoriyafomen 18 мар. 2020 г., 02:48:46 | 5 - 9 классы

Pascal?

Pascal.

Даны три переменные вещественного типа : A, B, C.

Если их значения упо - рядочены по возрастанию или убыванию, то удвоить их ; в противном слу - чае заменить значение каждой переменной на противоположное.

Вывести новые значения переменных A, B, C.

Анютка02022002 10 апр. 2020 г., 03:52:50 | 10 - 11 классы

Составить блок - схему решения следующей задачи?

Составить блок - схему решения следующей задачи.

Даны значения двух действительных переменых a и b.

Обменять местами их значения, при этом нельзя использовать никаких дополнительных переменных.

Тамирис11 22 нояб. 2020 г., 12:29:43 | 5 - 9 классы

Пожалуйста?

Пожалуйста!

Напишите линейную программу, в результате выполнения которой целочисленные переменные х и у об меняются значениями.

При этом нельзя использовать дополнительные переменные .

Найдя такой алгоритм, определите, в чем его недостаток по сравнению с методом обмена через третью переменную .

Можно ли его ли его применять для вещественных чисел?

Ника880 7 нояб. 2020 г., 08:48:12 | 5 - 9 классы

Написать программу в паскале Даны две переменных с некоторыми значениями?

Написать программу в паскале Даны две переменных с некоторыми значениями.

Поменять местами значения этих переменных.

Svetoxa243 9 мая 2020 г., 17:00:36 | 5 - 9 классы

Даю 34 балла))) Составить блок - схему?

Даю 34 балла))) Составить блок - схему.

Даны значения трех действительных переменных a, b и c.

Обменять местами их значения так, чтобы a получила бы значение b, b получила значение c, а переменная c получила значение a.

Alinavorobeva1 28 апр. 2020 г., 01:34:16 | 10 - 11 классы

В вещественной переменной Y записано некоторое неотрицательное число, не превосходящее 30000?

В вещественной переменной Y записано некоторое неотрицательное число, не превосходящее 30000.

Запишите в переменную S сумму первых после десятичной точки трёх цифр числа Y.

Можно использовать дополнительные переменные любых типов, но нужно указать тип для каждой дополнительной переменной.

На этой странице сайта размещен вопрос СДЕЛАТЬ В PACKALABC Даны значения трех вещественных переменных а, b и с Обменять местами их значения при этом нельзя использовать никаких дополнительных переменных (a = b, b = c, c = a)? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.