Нужна помощь с Pascal Дан двумерный массив от 1 до 3 ввести элементы массива с клавиатуры и обнулить диагональ матрицы?

Информатика | 10 - 11 классы

Нужна помощь с Pascal Дан двумерный массив от 1 до 3 ввести элементы массива с клавиатуры и обнулить диагональ матрицы.

Ответить на вопрос
Ответы (1)
Gimbarr32 6 мая 2020 г., 02:22:01

Program Project2 ;

{$APPTYPE CONSOLE}

var a : array [1.

3, 1.

3] of integer ; i, n : Integer ;

begin

for i : = 1 to 3 do

for n : = 1 to 3 do read(a[i, n]) ;

for i : = 1 to 3 do for n : = 1 to 3 do if i = n then a[i, n] : = 0 ;

for i : = 1 to 3 do

begin

Writeln ;

for n : = 1 to 3 do

write(a[i, n] : 3) ;

end ;

readln ;

readln ;

end.

Ila2904 29 сент. 2020 г., 23:03:04 | 10 - 11 классы

Ввести двумерный массив 4х4, найти произведение элементов главной диагонали матрицы, а так же сумму элементов подобных диагоналей?

Ввести двумерный массив 4х4, найти произведение элементов главной диагонали матрицы, а так же сумму элементов подобных диагоналей.

Alesha19983 7 нояб. 2020 г., 08:01:10 | 10 - 11 классы

Помогите с задачей на двумерные массивы в Pascal?

Помогите с задачей на двумерные массивы в Pascal.

Для каждого столбца нужно подсчитать сумму отрицательных элементов и записать данные в новый массив.

Slaviknarkoman 25 мая 2020 г., 05:32:08 | 10 - 11 классы

Написать двумерный массив?

Написать двумерный массив.

Найти min элемент матрицы заданной с клавиатуры.

Andrei1707 21 июл. 2020 г., 09:38:07 | 5 - 9 классы

Нужно ввести с клавиатуры массив из 5 элементов, найти в нем два максимальных элемента и их номера?

Нужно ввести с клавиатуры массив из 5 элементов, найти в нем два максимальных элемента и их номера.

Pascal ABC.

Яапелс 7 июн. 2020 г., 06:57:01 | 5 - 9 классы

С клавиатуры ввести массив А (Б)?

С клавиатуры ввести массив А (Б).

Найти сумму всех элементов массива.

Вывести ее на экран, и массив опять.

Clashofclans080 30 нояб. 2020 г., 06:32:46 | 10 - 11 классы

Дан массив а, состоящий из 3 элементов, ввести элементы массива с клавиатуры и вывести на экран в обратном порядке?

Дан массив а, состоящий из 3 элементов, ввести элементы массива с клавиатуры и вывести на экран в обратном порядке.

Artembabynin20 3 мая 2020 г., 13:07:17 | 10 - 11 классы

Ввести с клавиатуры массив из 5 элементов, найти среднее арифметическое всех элементов массива?

Ввести с клавиатуры массив из 5 элементов, найти среднее арифметическое всех элементов массива.

Aida4925 27 сент. 2020 г., 23:26:41 | 10 - 11 классы

В двумерном массиве 10х10, содержащем числа в интервале от 50 до 100 найдите сумму элементов стоящих на главной диагонале?

В двумерном массиве 10х10, содержащем числа в интервале от 50 до 100 найдите сумму элементов стоящих на главной диагонале.

Вывести на печать исходную матрице в табличном виде и значения матрицы и полученную сумму Pascal.

Jenya932 26 мая 2020 г., 12:10:21 | 10 - 11 классы

HELP?

HELP!

Дан двумерный массив(4 * 5) написать программу, которая определит кол - во четных элементов двумерного массива.

Заполонить с клавиатуры.

Ksenia22111 8 июн. 2020 г., 11:23:19 | 10 - 11 классы

Помогите пожалуйста?

Помогите пожалуйста.

1. Дан массив (n * m).

Элементы массива ввести случайным способом.

Найти сумму элементов которые больше данного числа А.

Число А ввести с клавиатуры.

2. Дан массив (n * m).

Элементы массива ввести в программе.

Найти первый элемент, являющийся простым числом и его инедксы.

3. Дан массив (n * m).

Элементы массива ввести с клавиатуры.

Найти количество четных элементов массива.

Вы открыли страницу вопроса Нужна помощь с Pascal Дан двумерный массив от 1 до 3 ввести элементы массива с клавиатуры и обнулить диагональ матрицы?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.