Помогите с задачей на двумерные массивы в Pascal?

Информатика | 10 - 11 классы

Помогите с задачей на двумерные массивы в Pascal.

Для каждого столбца нужно подсчитать сумму отрицательных элементов и записать данные в новый массив.

Ответить на вопрос
Ответы (1)
Elenanesterova1 7 нояб. 2020 г., 08:01:13

/ / Pascal ABC.

NET Версия 2.

2 Сборка 790

var ma : array[1.

10, 1.

10] of integer ;

ar : array[1.

10] of integer ;

i, j, s : integer ;

begin ;

randomize ;

writeln('Matrix : ') ;

for i : = 1 to 10 do

begin ; writeln ; for j : = 1 to 10 do begin ; ma[i, j] : = random( - 10, 10) ; write(ma[i, j] : 5) ; if ma[i, j]< ; 0 then ar[i] + = ma[i, j] ; end ;

end ;

writeln ;

writeln('Final array : ') ;

for i : = 1 to 10 do

writeln(ar[i]) ;

end.

Пример вывода :

Matrix : 9 - 1 3 - 10 6 3 - 9 8 5 - 6 - 4 4 - 6 7 7 7 - 10 4 - 2 3 - 9 - 3 10 - 9 2 - 7 1 - 8 - 8 - 8 - 5 - 4 2 - 5 - 9 - 9 3 6 7 - 5 3 8 10 0 - 9 4 - 3 6 - 10 - 9 9 10 - 8 1 - 1 2 - 1 1 - 2 3 - 8 10 5 3 10 - 10 - 8 9 6 6 - 6 - 5 8 - 7 - 10 - 7 - 2 - 1 - 10 9 7 5 - 9 - 10 - 6 - 5 - 7 - 9 7 - 1 2 - 9 - 2 - 6 - 8 4 - 7 - 3 1 - 9

Final array : - 26 - 22 - 52 - 37 - 31 - 12 - 26 - 48 - 47 - 44.

Ванига 13 июн. 2020 г., 19:28:24 | 5 - 9 классы

Дан двумерный массив?

Дан двумерный массив.

Вывести на экран все элементы S - го столбца массива.

Lera184567 21 февр. 2020 г., 13:53:50 | 10 - 11 классы

ТЕМА : ОБРАБОТКА ДВУМЕРНЫХ МАССИВОВ?

ТЕМА : ОБРАБОТКА ДВУМЕРНЫХ МАССИВОВ.

ПО ПАСКАЛЬ!

Задание : Дан двумерный массив А состоящий из 4 строк и 5 столбцов .

Найти, сколько положительных элементов содержит данная матрица в каждом столбце.

Devuhka1 6 мая 2020 г., 02:21:57 | 10 - 11 классы

Нужна помощь с Pascal Дан двумерный массив от 1 до 3 ввести элементы массива с клавиатуры и обнулить диагональ матрицы?

Нужна помощь с Pascal Дан двумерный массив от 1 до 3 ввести элементы массива с клавиатуры и обнулить диагональ матрицы.

Cdtnf07061985 21 янв. 2020 г., 07:30:41 | 10 - 11 классы

Дан двумерный массив 7Х5?

Дан двумерный массив 7Х5.

Найти сумму отрицательных элементов в каждом столбце.

Определить минимальный элмент в 1 - й строке( значение и координаты).

Ciklomen151 2 июл. 2020 г., 22:39:18 | 10 - 11 классы

Заполнить двумерный массив N * N числами с клавиатуры и найти сумму элементов массива нечётных столбцов?

Заполнить двумерный массив N * N числами с клавиатуры и найти сумму элементов массива нечётных столбцов.

Yasmin125 14 февр. 2020 г., 01:39:11 | 10 - 11 классы

ДАН ДВУМЕРНЫЙ МАССИВ ЧИСЕЛ?

ДАН ДВУМЕРНЫЙ МАССИВ ЧИСЕЛ.

ОПРЕДЕЛИТЬ, СУММУ ЭЛЕМЕНТОВ ВТОРОГО СТОЛБЦА МАССИВА, БОЛЬШИХ 10.

Kat2005 8 мар. 2020 г., 11:53:27 | 10 - 11 классы

Из элементов двумерного массива создать два новых одномерных Один из положительных Другой из отрицательных?

Из элементов двумерного массива создать два новых одномерных Один из положительных Другой из отрицательных.

Privedenie7 2 июл. 2020 г., 15:21:42 | 10 - 11 классы

Помогите решить задачу?

Помогите решить задачу.

Решить через паскаль.

Дан массив В(50) целых чисел.

Подсчитать сумму тех элементов массива, которые нечетны и отрицательны.

Angelina21237 28 июн. 2020 г., 11:26:28 | 5 - 9 классы

Дан массив А [12] Подсчитать сумму отрицательных элементов массива?

Дан массив А [12] Подсчитать сумму отрицательных элементов массива.

Значения элементов массива целые числа от - 20 до 20 СРОЧНО!

Seregaarhipov20 23 окт. 2020 г., 02:59:02 | 5 - 9 классы

Задан двумерный массив В из 4 - х строк и 5 - и столбцов?

Задан двумерный массив В из 4 - х строк и 5 - и столбцов.

Составить программу, которая организует одномерный массив, каждый элемент которого есть сумма элементов в столбце.

Вычислить произведение элементов полученного массива.

Вы открыли страницу вопроса Помогите с задачей на двумерные массивы в Pascal?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 10 - 11 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.