Помогите пожалуйста?

Информатика | 10 - 11 классы

Помогите пожалуйста.

Определите значение переменной «a» после выполнения фрагмента программы :

a : = 10

if a < ; 5 then a : = a + 12

else a : = a - 7 ;

if a < ; 5 then a : a + 12

else a : = a - 7 ;

Ответить на вопрос
Ответы (2)
Mariyagrigorevaa 15 нояб. 2023 г., 12:35:46

Ответ :

15

Объяснение :

a = 10

если a < ; 5 (10 < ; 5 - НЕТ) то a = a + 12 (эту ветку не трогаем, т.

К. условие ложное)

иначе a = a - 7 = 10 - 7 = 3

а = 3

если a < ; 5 (3 < ; 5 - ДА) то a = a + 12 = 3 + 12 = 15

иначе a = a - 7 (эту ветку не трогаем, т.

К. условие истинное)

а = 15.

Ironman2808 15 нояб. 2023 г., 12:35:48

Ответ :

a = 15

Объяснение :

a : = 10   ; / / a = 10

if a < ; 5 then a : = a + 12   ; / / Если 10 < ; 5, тогда a = a + 12 ( условие не выполняется )

else a : = a - 7 ;   ; / / Иначе a = a - 7 (( 10 - 7 = 3 )) / / a = 3 - так как условие не выполнилось, мы выполняем тело цикла else

if a < ; 5 then a : a + 12   ; / / Если 3 < ; 5, тогда a = a + 12 (( 3 + 12 = 15 )) / / a = 15 - условие выполняется

else a : = a - 7 ; / / Иначе a = a - 7 - условие выполнилось, тело цикла else не выполняем.

Rostisk 3 нояб. 2023 г., 18:53:28 | 10 - 11 классы

Напишите через запятую что находится в переменных a и b после выполнения алгоритма :A : = 25 ; b : = 5 ;If a> ; 10 then b : = 2 * b else b : = a / 5 ?

Напишите через запятую что находится в переменных a и b после выполнения алгоритма :

A : = 25 ; b : = 5 ;

If a> ; 10 then b : = 2 * b else b : = a / 5 ;

Maxagafonov98 30 нояб. 2023 г., 00:43:39 | 5 - 9 классы

СРОЧНО?

СРОЧНО!

Заранее благодарю!

Определите значение переменных s и i после выполнения следующего фрагмента программы.

Nastyakorotkova1 10 дек. 2023 г., 09:45:41 | студенческий

Где ошибкаvara, b : real ; c : string ;beginwriteln('Цисло тигров') ;Read(a) ;b : = 30 ;if a< ; = b thenwriteln('Норма') ;if awriteln('Угроза') ;writeln('Угроза исчезновения') ;read(c) ;if c = 'Отпр?

Где ошибка

var

a, b : real ; c : string ;

begin

writeln('Цисло тигров') ;

Read(a) ;

b : = 30 ;

if a< ; = b then

writeln('Норма') ;

if a

writeln('Угроза') ;

writeln('Угроза исчезновения') ;

read(c) ;

if c = 'Отправить' then

writeln('Вы выброли отправить') ;

if c = 'Не отправить' then

writeln('Вы выброли не отправить') ;

end ;

end.

Кикл 29 нояб. 2023 г., 20:46:02 | студенческий

Определите значение переменной «a» после выполнения фрагмента программы : a : = 10 ; if a < ; 5 then a : = a + 12 else a : = a - 7 ?

Определите значение переменной «a» после выполнения фрагмента программы : a : = 10 ; if a < ; 5 then a : = a + 12 else a : = a - 7 ;

Шроворш 27 окт. 2023 г., 06:20:53 | 5 - 9 классы

! ДАЮ 50 БАЛЛОВ?

! ДАЮ 50 БАЛЛОВ!

2. 1.

Определите, значение какой функции вычисляет написанная программа?

Оформить таблицу вычислений

№ x y

1 - 2

2 0

3 6

program Virajenie ;

uses crt ;

var x, y : real ;

begin clrscr ; write('Значение x = ') ; readln(x) ; if (x< ; 0) then y : = - x else y : = x + 2 ; writeln('При x = ', x : 8 : 2, ' y = ', y : 8 : 2) ; readkey

end.

2. 2.

(БИД) Попробуйте сформулировать, что определяет данная программа.

Оформить таблицу вычислений

№ Первое число Второе число Вывод

1 2 8

2 11 7

3 25 25

program Sravnenie ;

uses crt ;

var a, b : real ;

Begin clrscr ; write('Сравниваемые числа ') ; readln(a, b) ; if (a = b) then writeln('Числа равны') else if (a> ; b) then writeln('Первое число больше') else writeln('Второе число больше') ; readkey

end.

2. 3.

Вычислить значение выражения ………….

Для заданного значения x.

Оформить таблицу вычислений (пользуясь программой, данной ниже, заполните пропуски в условии задачи и таблице)

№ x ?

1 - 3

2 0

3 5

program Virajenie ;

uses crt ;

var x, y : real ;

begin clrscr ; write('Значение x = ') ; readln(x) ; if (x = 0) then writeln('При x = ', x : 8 : 2, ' выражение не определено') else begin y : = x + 1 / x ; writeln('При x = ', x : 8 : 2, ' y = ', y : 8 : 2) end ; readkey

end.

Записать программы

2.

4 Проверить, является ли введенное с клавиатуры целое число четным.

2. 5 Проверить оканчивается ли целое число на 0.

Гумбат1 26 дек. 2023 г., 05:01:22 | 10 - 11 классы

2)Что будет выведено на экран после выполнения фрагмента программы :begina : = 45 ;if а> ; 10 then n : = а + 15 else n : = a - 11 ;writeln (n) ;end?

2)Что будет выведено на экран после выполнения фрагмента программы :

begin

a : = 45 ;

if а> ; 10 then n : = а + 15 else n : = a - 11 ;

writeln (n) ;

end.

​.

Polina52781 4 дек. 2023 г., 13:31:13 | 5 - 9 классы

Определите значение переменной x после выполнения следующегофрагмента программы : ​?

Определите значение переменной x после выполнения следующего

фрагмента программы : ​.

Davnomertviy 21 нояб. 2023 г., 17:09:16 | 5 - 9 классы

If x > ; = 0 then if x > ; 0 then write(1) else write(0)else write( - 1) ;Что выведет эта программа при разных значениях x?

If x > ; = 0 then if x > ; 0 then write(1) else write(0)

else write( - 1) ;

Что выведет эта программа при разных значениях x?

1. при x = 15 : 2.

При x = 5 : 3.

При x = 0 : 4.

При x = –5 : 5.

При x = –15 :

Viteknb 8 дек. 2023 г., 20:01:58 | 5 - 9 классы

1. В каких случаях используется структура if - else?

1. В каких случаях используется структура if - else?

2. Каков синтаксис структуры if - else?

3. В каких случаях применяется структура if - elif - else?

4. Каков синтаксис структуры if - elif - else?

5. Какова функция гора полного разветвления?

6. Какова структура вложенного условного оператора, 7.

Каковы условия применения вложенного условного опе ратора?

​.

Helena4988 8 нояб. 2023 г., 12:59:21 | 5 - 9 классы

В массиве A находятся 10 чисел : 1, - 1, 2, 7, 5, 6, 8, 9, 0, 3?

В массиве A находятся 10 чисел : 1, - 1, 2, 7, 5, 6, 8, 9, 0, 3.

Дан фрагмент программы :

s : = 0 ;

for i : = 1 to 10 do if (A[i] > ; 2) and (A[i] < ; = 8) then s : = s + 1 ;

Чему будет равно значение переменной s после выполнения программы?

На этой странице находится ответ на вопрос Помогите пожалуйста?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.